package libwbclient0 2:3.2.0-4ubuntu3 failed to install/upgrade: trying to overwrite `/usr/lib/libwbclient.so.0', which is also in package likewise-open

Bug #254434 reported by James Westby on 2008-08-03
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
likewise-open (Ubuntu)
High
Unassigned
samba (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: samba

Hi,

Installing Intrepid updates today I hit this error.

Thanks,

James

ProblemType: Package
Architecture: i386
Date: Sun Aug 3 17:27:49 2008
Dependencies:

DistroRelease: Ubuntu 8.10
ErrorMessage: trying to overwrite `/usr/lib/libwbclient.so.0', which is also in package likewise-open
Package: libwbclient0 None [modified: /var/lib/dpkg/info/libwbclient0.list]
PackageArchitecture: i386
SourcePackage: samba
Title: package libwbclient0 None [modified: /var/lib/dpkg/info/libwbclient0.list] failed to install/upgrade: trying to overwrite `/usr/lib/libwbclient.so.0', which is also in package likewise-open
Uname: Linux 2.6.26-4-generic i686

Related branches

James Westby (james-w) wrote :
Download full text (3.8 KiB)

here is my full log:
# apt-get -f upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following NEW packages will be installed:
  libwbclient0
The following packages will be upgraded:
  bug-buddy fast-user-switch-applet kfilereplace kimagemapeditor ubuntu-desktop ubuntu-docs ubuntu-minimal ubuntu-standard
8 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
22 not fully installed or removed.
Need to get 3882kB of archives.
After this operation, 13.8MB disk space will be freed.
Do you want to continue [Y/n]? y
Get:1 ftp://archive.ubuntu.com intrepid/main libwbclient0 2:3.2.0-4ubuntu3 [87.3kB]
Get:2 ftp://archive.ubuntu.com intrepid/main ubuntu-docs 8.08.1 [2271kB]
Get:3 ftp://archive.ubuntu.com intrepid/main ubuntu-minimal 1.108 [25.8kB]
Get:4 ftp://archive.ubuntu.com intrepid/main ubuntu-standard 1.108 [25.7kB]
Get:5 ftp://archive.ubuntu.com intrepid/main bug-buddy 2.23.6dfsg-0ubuntu1 [138kB]
Get:6 ftp://archive.ubuntu.com intrepid/main fast-user-switch-applet 2.22.0-1ubuntu3 [315kB]
Get:7 ftp://archive.ubuntu.com intrepid/universe kfilereplace 4:3.5.9-3ubuntu1 [648kB]
Get:8 ftp://archive.ubuntu.com intrepid/universe kimagemapeditor 4:3.5.9-3ubuntu1 [344kB]
Get:9 ftp://archive.ubuntu.com intrepid/main ubuntu-desktop 1.108 [26.9kB]
Fetched 3882kB in 11s (337kB/s)

(apt-listchanges:12880): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
apt-listchanges: Mailing apt: apt-listchanges: changelogs for blubug
(Reading database ... 269841 files and directories currently installed.)
Unpacking libwbclient0 (from .../libwbclient0_2%3a3.2.0-4ubuntu3_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libwbclient0_2%3a3.2.0-4ubuntu3_amd64.deb (--unpack):
 trying to overwrite `/usr/lib/libwbclient.so.0', which is also in package likewise-open
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace ubuntu-docs 8.04.2~hardy (using .../ubuntu-docs_8.08.1_all.deb) ...
Unpacking replacement ubuntu-docs ...
Preparing to replace ubuntu-minimal 1.107 (using .../ubuntu-minimal_1.108_amd64.deb) ...
Unpacking replacement ubuntu-minimal ...
Preparing to replace ubuntu-standard 1.107 (using .../ubuntu-standard_1.108_amd64.deb) ...
Unpacking replacement ubuntu-standard ...
Preparing to replace bug-buddy 2.23.5.1dfsg-0ubuntu1 (using .../bug-buddy_2.23.6dfsg-0ubuntu1_amd64.deb) ...
Unpacking replacement bug-buddy ...
Preparing to replace fast-user-switch-applet 2.22.0-1ubuntu2 (using .../fast-user-switch-applet_2.22.0-1ubuntu3_amd64.deb) ...
Unp...

Read more...

Zack Powers (zpowers) wrote :

Here is my terminal Log as Well:

zpowers@zircon:~$ sudo apt-get -f upgrade
[sudo] password for zpowers:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following NEW packages will be installed:
  libwbclient0
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
6 not fully installed or removed.
Need to get 0B/87.3kB of archives.
After this operation, 168kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 239724 files and directories currently installed.)
Unpacking libwbclient0 (from .../libwbclient0_2%3a3.2.0-4ubuntu3_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libwbclient0_2%3a3.2.0-4ubuntu3_amd64.deb (--unpack):
 trying to overwrite `/usr/lib/libwbclient.so.0', which is also in package likewise-open
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libwbclient0_2%3a3.2.0-4ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

James Westby (james-w) on 2008-08-04
Changed in likewise-open:
status: New → Confirmed
Thierry Carrez (ttx) wrote :

The new Samba ships with libwbclient0, and the current likewise-open still ships with it.
I am working on a likewise-open update that should use libwbclient0 rather than provide the library itself.

Changed in likewise-open:
assignee: nobody → tcarrez
importance: Undecided → High
status: Confirmed → In Progress
Zack Powers (zpowers) wrote :

Why not create a new package named libwbclinet0 and make it a dependency of both packages?

Thierry Carrez (ttx) wrote :

That's exactly what is being done. likewise-open would depend on (already existing) libwbclient0.

Sounds great. I am having this problem too, and have 4 broken packages due to the problem. I will watch for the update and confirm the fix when it is available. Thanks!

Khorne (szczygiel-piotr) wrote :

Is there any workaround for this bug? I'd love to update my system and it's impossible right now.

Thierry Carrez (ttx) wrote :

This bug was fixed in the package likewise-open - 4.1.0.2956-0ubuntu1

---------------
likewise-open (4.1.0.2956-0ubuntu1) intrepid; urgency=low

  * missing-likewise-logo.diff: removed
  * fixed copyright notice
  * updated Standards-Version to 3.8.0
  * removed path from command in prerm
  * removed stop in S runlevel

 -- Rick Clark <email address hidden> Wed, 27 Aug 2008 08:56:20 -0500

likewise-open (4.1.0.2956-0ubuntu1~ppa2) intrepid; urgency=low

  * Remove libwbclient.so.0, use libwbclient0 package instead (LP: #254434)
  * Remove library links under /usr/lib/likewise-open

 -- Thierry Carrez <email address hidden> Tue, 05 Aug 2008 15:34:18 +0200

likewise-open (4.1.0.2956-0ubuntu1~ppa1) intrepid; urgency=low

  * New upstream version. (LP: #244968)
  * Removed fix_window_close patch (was merged upstream)
  * Fixed dh_perl call so that it looks into /usr/lib/likewise-open
  * Removed perl dep from likewise-open-gui since it is now pulled from
    likewise-open perl-Depends
  * Removed superfluous /etc/defaults empty directory creation
  * More descriptive desktop entries (LP: #253032)
  * Changed desktop entry logo to domainjoin-logo.png for consistency
  * likewise-open.prerm: leave domain before uninstall (LP: #230466)
  * missing-likewise-logo.diff: fix missing logo regression in domainjoin-gui
  * no-template-modifications.diff: disable template homedir|shell
    modifications and respect whatever was put in lwiauthd.conf
  * Changed Maintainer to reflect main inclusion

 -- Thierry Carrez <email address hidden> Fri, 01 Aug 2008 15:55:43 +0200

Changed in likewise-open:
status: In Progress → Fix Released

I still cannot update. Still have the same problem. Updated today.

Zack Powers (zpowers) wrote :

I had to purge likewise-open and then reinstall the package to properly resolve the dependancy. Make sure you leave the domain before purging the package with

user@locahost# aptitude purge likewise-open

OK, so I had to remove likewise-open to get the rest of the packages to work.

I ran: sudo dpkg -r likewise-open
Then: sudo apt-get update -f
Then: sudo apt-get install -f
Then: sudo apt-get upgrade -f
Then: sudo apt-get install likewise-open

Works fine now.

I'm going to choose the simple option and just fix the packaging to place the libwbclient.so.0 from likewise-open to /usr/lib/likewise-open/. It is possible to integrate smbd from Samba to use the libwbclient.so.0 provided by likewise-open by using a virtual (replaces/conflicts/depends) package like postfix vs. exim. But I believe I'll wait on that one. Expect a fix this week,

Theirry, the fix that you are suggesting will not work. The libwbclient that likewise-open includes is compatible but not equivalent to the one provided by Samba. Here's a new rules file. Just leave the libwbclienbt.so.0 included in likewise-open in /usr/lib/likewise-open for now.

wrong rules file in previous comment. This is the correct one:

Thierry Carrez (ttx) wrote :

Reopening...
I can reproduce on a hardy (samba + likewise) -> intrepid upgrade
libwbclient0 is installed before likewise is upgraded, causing the error.

Changed in likewise-open:
assignee: tcarrez → nobody
status: Fix Released → Confirmed
Thierry Carrez (ttx) wrote :

This should be fixed with some Replaces/Conflicts magic in libwbclient0 so that it gets installed after likewise-open is upgraded.

likewise-open >= 4.1.0.2956 no longer ships /usr/lib/libwbclient.so.0 so it cannot conflict with libwbclient0.

Reconfirming that the fix in likewise-open is released, opening a new task for libwbclient0.

Changed in likewise-open:
status: Confirmed → Fix Released
Thierry Carrez (ttx) on 2008-09-12
Changed in samba:
assignee: nobody → tcarrez
importance: Undecided → High
status: New → In Progress
Thierry Carrez (ttx) wrote :

Proposed debdiff
Tested OK on a hardy (samba + likewise) -> intrepid upgrade

-----------------------------
samba (2:3.2.3-1ubuntu2) intrepid; urgency=low

  * Make libwbclient0 replace/conflict with hardy's likewise-open (LP: #254434)

 -- Thierry Carrez <email address hidden> Fri, 12 Sep 2008 14:30:00 +0200

Changed in samba:
assignee: tcarrez → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.2.3-1ubuntu2

---------------
samba (2:3.2.3-1ubuntu2) intrepid; urgency=low

  * Make libwbclient0 replace/conflict with hardy's likewise-open (LP: #254434)

 -- Thierry Carrez <email address hidden> Fri, 12 Sep 2008 14:30:00 +0200

Changed in samba:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers