Typo in Likewise Open GUI (misspelled "privileges")

Bug #253394 reported by Etienne Goyer on 2008-07-30
6
Affects Status Importance Assigned to Milestone
likewise-open (Ubuntu)
Low
Thierry Carrez
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: likewise-open-gui

The "Domain Join Authentication" dialog (what you got when you click the Join Domain button) misspell "privileges".

This is fixed in latest upstream (likewise-4.1.0-1.24061-domainjoin).

Thierry Carrez (ttx) wrote :

This should be solved when bug 244968 (migration to >=4.1.0) is complete.

Changed in likewise-open:
assignee: nobody → tcarrez
importance: Undecided → Low
status: New → Triaged

I do not think this bug is even remotely worthy of an SRU, but if an update is ever done to the likewise-open-gui package in hardy, it would be good to have it corrected. It's really an eyesore ... :(

Thierry Carrez (ttx) wrote :

This bug was fixed in the package likewise-open - 4.1.0.2956-0ubuntu1

---------------
likewise-open (4.1.0.2956-0ubuntu1) intrepid; urgency=low

  * missing-likewise-logo.diff: removed
  * fixed copyright notice
  * updated Standards-Version to 3.8.0
  * removed path from command in prerm
  * removed stop in S runlevel

 -- Rick Clark <email address hidden> Wed, 27 Aug 2008 08:56:20 -0500

likewise-open (4.1.0.2956-0ubuntu1~ppa2) intrepid; urgency=low

  * Remove libwbclient.so.0, use libwbclient0 package instead (LP: #254434)
  * Remove library links under /usr/lib/likewise-open

 -- Thierry Carrez <email address hidden> Tue, 05 Aug 2008 15:34:18 +0200

likewise-open (4.1.0.2956-0ubuntu1~ppa1) intrepid; urgency=low

  * New upstream version. (LP: #244968)
  * Removed fix_window_close patch (was merged upstream)
  * Fixed dh_perl call so that it looks into /usr/lib/likewise-open
  * Removed perl dep from likewise-open-gui since it is now pulled from
    likewise-open perl-Depends
  * Removed superfluous /etc/defaults empty directory creation
  * More descriptive desktop entries (LP: #253032)
  * Changed desktop entry logo to domainjoin-logo.png for consistency
  * likewise-open.prerm: leave domain before uninstall (LP: #230466)
  * missing-likewise-logo.diff: fix missing logo regression in domainjoin-gui
  * no-template-modifications.diff: disable template homedir|shell
    modifications and respect whatever was put in lwiauthd.conf
  * Changed Maintainer to reflect main inclusion

 -- Thierry Carrez <email address hidden> Fri, 01 Aug 2008 15:55:43 +0200

Changed in likewise-open:
status: Triaged → Fix Released

I have documentation to write with screenshot from likewise-open-gui, and this typo just cannot get into it. I have a package for hardy that fix it in my PPA:

   deb http://ppa.launchpad.net/etienne-goyer-outlands/ubuntu hardy main

Attached a debdiff that correct the problem.

description: updated
Thierry Carrez (ttx) wrote :

SRU report

Bug impact:
Ugly typo in the domain join "AD admin password" dialog. Would not warrant a SRU on its own but since I'm doing a SRU for high-impact bug 222224 and bug 230466, I propose to fix this as well.

Fix in the development branch:
This was addressed in Intrepid for version 4.1.0.2956-0ubuntu1, upstream fixed the typo.

Minimal patch:
see debdiff from Etienne just above.

TEST CASE:
$ sudo apt-get install likewise-open likewise-open-gui
System > Administration > Likewise, enter a domain name and click "Join domain"
On the AD admin password dialog that appears then,
Without the fix: "priviledges"
With the fix: "privileges"

Regression potential:
This patch is just a cosmetic change that only affects the default label contents in that dialog...

Thierry Carrez (ttx) wrote :

Combined SRU debdiff (with bug 230466 and bug 222224) has been posted on bug 230466.

Martin Pitt (pitti) wrote :

How many translations will break with this change? Please fix the according .po files with it, so that Rosetta gets the updated strings imported.

Thierry Carrez (ttx) wrote :

Martin:
I may have missed something, but likewise-open-gui doesn't seem to support i18n so the messages are only defined in that glade file... If I got it wrong and this has more impact than I think it does, I'll just drop it from the combined SRU.

Martin Pitt (pitti) wrote :

Ah, approved then, thanks. Please upload.

Changed in likewise-open:
status: New → In Progress
Thierry Carrez (ttx) on 2008-10-31
Changed in likewise-open:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package likewise-open - 4.0.5-0ubuntu3.1

---------------
likewise-open (4.0.5-0ubuntu3.1) hardy-proposed; urgency=low

  [ Etienne Goyer ]
  * Fixed ugly typo in "Domain Join Authentication" dialog
    (LP: #253394)

  [ Thierry Carrez ]
  * debian/likewise-open.prerm: Leave the domain before uninstalling,
    otherwise you wouldn't be able to login anymore (LP: #230466)
  * debian/patches/graceful_dbus_restart.diff: fix Gnome session blow-up when
    using GUI to join domain (LP: #222224)

 -- Thierry Carrez <email address hidden> Tue, 28 Oct 2008 16:07:40 +0000

Changed in likewise-open:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers