ffe for likewise-open 4.0.4 to 4.0.5

Bug #201484 reported by Rick Clark on 2008-03-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
likewise-open (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: likewise-open

I would like to ask for a feature freeeze exception to upgrade likewise-open from 4.0.4 to 4.0.5. I have attached the changelog, diffstat, and diff.

This version adds improved error messages, necessary for useful debugging. It builds and installs cleanly and is not a dependency for any other package

     Update Debian changelog for new release.
      Fix the prefix path in Debian init script (moved from /opt/likewise-open to /usr)
      Update Fedora/RHEL specfile for 4.0.4 changes.
      Adding missing scripts to the Debian likewise-open package
      Update script name when invoking ConfigureShellPrompt from ConfigureLogin
      [Debian] Install support scripts to /usr/lib/likewise-open
      Remove file extension from call to gpcron (fixes a domain join failure
      Move the domainjoin-gtk.glade file to $(sharedir)/likewise-open/
      -Tagging new winbindd merge from upstream
      Marking latest winbindd merge
      Update SUSE packaging for release.
      Reset RPM release number for Fedora/RHEL in preparation for 4.0.4 release.
      Script cleanup from Rick Clark @ ubuntu.com.
      Ubuntu packaging fixes from Rick Clark @ Ubuntu.com
      Mark the winbindd soname fixes and add note to Ubuntu changelog.
      Fix inverted logic when checking the "modify hosts" check box in domainjoin-gui.
      Marking test branch as version 4.0.5.
      Add changelog for debian packaging for 4.0.5 test release.
      Mark the smbcontrol bug fix in winbindd code.
      Check for /etc/init.d/apparmor when reloading updating apparmor profile.
      Remove 15 character limit check when validating the local hostname
      Fixup ConfigureAppArmor to be a no-op on Ubuntu and Debian.
      Revert "Remove 15 character limit check when validating the local hostname"
      Merge better ifcfg detection code to FixNetworkInterfaces().
      Mark idmap_lwopen segv fix
      Mark winbindd version change
      Changing winbindd path to match Samba name space
      Removed use of submodule for Samba code
      Importing Likewise Open 4.0.5-test1 release from SVN r21462
      RedHat packaging fixes for 4.0.5 code base.
      Set package version to 1.test3 for Fedora and openSUSE.
      Syncing from SVN r21616 from Likewise SVN tree.
      Remove CenterisPam.pm from packaging files on Ubuntu/Debian and Fedora/RHEL.
      More updates for Debian/Ubuntu packaging to reflect the removal of CenterisPam.pm
      Pickup build fixes for likewise-open from SVN r21653.
      Fixes for Fedora/RHEL specfile.
      Set RPM release info to 1.test4
      Grab fixes from SVN r21662. Includes removal of krb5 checks
      Fedora/RHEL packaging updates to automatically disable build of GUI
      Fix typo in --with-libxml2-dir when build domainjoin in Fedora specfile.
      Add new changelog entry for 4.0.5-test4 to Ubuntu packaging
      Enable copying from skel directory when creating a new home directory.
      Set home directory template path to /home/%D/%U rather than /local
      Cleanup Debian rules for fixes to the centutils lib directory in Makefile
      Sync from Likewise SVN tree r22180
      Fixing installation of pam_lwidentity
      Another sync from Likewise SVN tree.
      Consolidate to a single build-rpm script that takes the distro names as its arguement.
      RPM packaging fixes for openSUSE 10.3 and likewise-open 4.0.5 release.
      Move the packaging/fedora directory to redhat.
      Remove bad merge line from GUI gtk xml file
      More path fixes for openSUSE RPM specfile
      Update top level Makefile to reflect changes in rpm packaging scripts
      Fix another bad merge in the GTK XML file for domainjoin GUI
      Update packaging release number for final 4.0.5 release

diffstat for likewise-open 4.0.4 to 4.0.5

Rick Clark (dendrobates) on 2008-03-12
description: updated
Changed in likewise-open:
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
Rick Clark (dendrobates) wrote :

Since a MIR is being submitted simultaneously, I have subscribed both the motu-release and ubuntu-release teams

Scott Kitterman (kitterman) wrote :

Ack from me for motu-release.

Fine by me too. Unsubscribing motu-release. Don't you need ubuntu-mir subscribed for the MIR?

Changed in likewise-open:
status: New → Confirmed

Bah. this is already uploaded anyway.

Changed in likewise-open:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers