Cannot remove the lighttpd pkg from Edgy Eft

Bug #68401 reported by Asif on 2006-10-26
8
Affects Status Importance Assigned to Milestone
lighttpd (Ubuntu)
Undecided
Unassigned
Dapper
Medium
Unassigned

Bug Description

Binary package hint: lighttpd

sudo dpkg --force-all --remove lighttpd
(Reading database ... 254798 files and directories currently installed.)
Removing lighttpd ...
 * Stopping web server lighttpd [fail]
invoke-rc.d: initscript lighttpd, action "stop" failed.
dpkg: error processing lighttpd (--remove):
 subprocess pre-removal script returned error exit status 1
Errors were encountered while processing:
 lighttpd

sudo apt-get remove lighttpd
Reading package lists... Done
Building dependency tree... Done
The following packages were automatically installed and are no longer required:
  lighttpd
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  lighttpd
0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 848kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 254798 files and directories currently installed.)
Removing lighttpd ...
 * Stopping web server lighttpd [fail]
invoke-rc.d: initscript lighttpd, action "stop" failed.
dpkg: error processing lighttpd (--remove):
 subprocess pre-removal script returned error exit status 1
Errors were encountered while processing:
 lighttpd
E: Sub-process /usr/bin/dpkg returned an error code (1)

Asif (vadud3) wrote :

I had lighttpd install on dapper drake. After I upgrade to Edgy I see the orange update avaliable icon on top right corner for lighttpd. I tried to upgrade and it fails with the following error.

E: /var/cache/apt/archives/lighttpd_1.4.13~r1370-1ubuntu1_i386.deb: subprocess new pre-removal script returned error exit status 1

The orange icon won't go away since it thinks I have a pkg available to update. I tried to remove using dpkg, apt-get and synaptic. Still failing to remove. Not sure how to clean up this pkg.

Error while trying to remove using Synaptic Package Manager:

E: lighttpd: subprocess pre-removal script returned error exit status 1

Have you tried to kill the server before to uninsall it ?

On 10/26/06, Adrians <email address hidden> wrote:
> Have you tried to kill the server before to uninsall it ?

The lighttpd is not running according to `ps aux | grep http'

>
> --
> Cannot remove the lighttpd pkg from Edgy Eft
> https://launchpad.net/bugs/68401
>

--
Asif Iqbal
PGP Key: 0xE62693C5 KeyServer: pgp.mit.edu

Asif (vadud3) wrote :

lighttpd is not running.

Lukas Fittl (lfittl) wrote :

Try to start lighttpd and then remove the package, this seems to be an error in the dapper prerm script.

Asif (vadud3) wrote :

On 10/26/06, Lukas Fittl <email address hidden> wrote:
> Try to start lighttpd and then remove the package, this seems to be an
> error in the dapper prerm script.

That did it.

Excellent!

>
> --
> Cannot remove the lighttpd pkg from Edgy Eft
> https://launchpad.net/bugs/68401
>

--
Asif Iqbal
PGP Key: 0xE62693C5 KeyServer: pgp.mit.edu

Lukas Fittl (lfittl) wrote :

The edgy init.d script is just fine, this is a problem with the dapper script, bugfix should be uploaded soon to dapper-updates. Patch for this can be found at bug #59269.

Changed in lighttpd:
status: Unconfirmed → Fix Released
assignee: nobody → lfittl
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Lukas Fittl (lfittl) on 2006-11-04
Changed in lighttpd:
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

Accepted into dapper-proposed (although, in future, please provide a better description of the change in debian/changelog; a reasonable guideline is to concentrate more on the effects of the change than on the details of how you changed it). Please test, if possible via Simon Law and the QA team.

Michal Ingeli (xyzz) wrote :

this bug still remain in dapper. last package for dapper update also failed, because lighttpd was not running at the time of update.

works for me with the package in dapper-proposed.

Kyle McMartin (kyle) wrote :

lighttpd_1.4.11-3ubuntu3.2.dsc accepted into dapper-proposed.

Changed in lighttpd:
status: In Progress → Fix Committed
Adam Sommer (asommer) wrote :

I too was able to remove lighttpd using the dapper-proposed package.

just an FYI.

Changed in lighttpd:
assignee: lfittl → nobody
Scott Kitterman (kitterman) wrote :

Debdiff for going from dapper-proposed to dapper-updates

Changed in lighttpd:
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that there was an error on your system when trying to install a particular package. Please execute the following command, as it will clear your package cache, in a terminal:

sudo apt-get clean

Then try performing the update again. This will likely resolve your issue, but the failure can be caused by filesystem or memory corruption. So please also run a fsck on your filesystem(s) and a memory test. If this does resolve your bug please set its status to Invalid. Thanks in advance!

Changed in lighttpd (Ubuntu):
status: Fix Released → Incomplete
Changed in lighttpd (Ubuntu Dapper):
status: Fix Released → Incomplete
tags: added: short-read
tags: removed: short-read
Changed in lighttpd (Ubuntu):
status: Incomplete → Fix Released
Changed in lighttpd (Ubuntu Dapper):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers