After upgrading from 10.04 to 10.10 amd64, every execution of a php page causes a 403 error. Lighttpd + PHP cgi

Bug #660421 reported by Alfredo Gemma on 2010-10-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lighttpd (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: php5-cgi

Upgrading to 10.10 amd64 causes a 403 error (Forbidden) on every attempt to execute a php page.

The starting environment before the upgrade is:

Lighttpd-1.4.26-1.1ubuntu3
php5-cgi-5.3.2-1ubuntu4.5

James Page (james-page) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

We would be really grateful if you could provide us with the following files as attachments to this bug report:

  /etc/lighttpd/lighttpd.conf

  Directory listings of:
     /etc/lighttpd/conf-available
     /etc/lighttpd/conf-enabled

  /var/log/lighttpd/error.log

  Any log files in /var/log/dist-upgrade/

This will help us to find and resolve the problem.

Changed in php5 (Ubuntu):
status: New → Incomplete
James Page (james-page) wrote :

Please could you also execute the following command, as it will automatically gather debugging information, in a terminal:

  apport-collect 660421

When reporting bugs in the future please use apport, using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Alfredo Gemma (alfredo-gemma) wrote :

James,

Attached you can find the lighttpd.tar.bz2 file containing all the log and configuration files requested.

I hope this can be helpful.

Thank you!

P.S. I can not use apport or ubuntu-bug from the inside of my company network, at the moment.

James Page (james-page) wrote :

Alfredo

Thanks for the information that you uploaded - it was really helpful. I have reproduced your issue successfully; in the newer version of lighttpd on Maverick you will need to enable the fastcgi and fastcgi-php modules (which is new as of 1.4.26-2). These files separate the configuration that was in fastcgi in version 1.4.26-1.1ubuntu3.

Running the following command should resolve your issue:

  sudo lighty-enable-mod fastcgi-php

Please update this bug report if this does resolve your issue.

Thanks

Alfredo Gemma (alfredo-gemma) wrote :

James,

I can confirm that on all my systems (Server and Desktop) affected by this bug, applying your solution definitively solves the problem.

Thank you very much!

James Page (james-page) wrote :

This bug report is being closed due to your last comment regarding this being fixed with a configuration change. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in php5 (Ubuntu):
status: Incomplete → Invalid
Alfredo Gemma (alfredo-gemma) wrote :

In my opinion, this bug can not be considered invalid: the upgrade process does not take in account the new settings needed by lighttpd.
After upgrading, php stops working and It is needed a further intervention to restore the situation.

Thanks.

Changed in php5 (Ubuntu):
status: Invalid → Opinion
Ondřej Surý (ondrej) wrote :

Not a php5 bug, but a lighttpd one.

affects: php5 (Ubuntu) → lighttpd (Ubuntu)
Changed in lighttpd (Ubuntu):
status: Opinion → New
Ondřej Surý (ondrej) wrote :

James,

Alfredo is right. At least it needs a NEWS.Debian entry for lighttpd. Upgrades should not break existing installations (at least not without prior notice).

Ondrej

Thierry Carrez (ttx) on 2010-10-20
Changed in lighttpd (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in lighttpd (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium

Alfredo/Ondrej

I agree; discussed on #ubuntu-server and this will be nominated for a
SRU.

Regards

James

--
James Page
Software Engineer, Ubuntu Server Team

Alfredo Gemma (alfredo-gemma) wrote :

Thank you, guys!!!

Rolf Leggewie (r0lf) wrote :

maverick has seen the end of its life and is no longer receiving any updates. Marking the maverick task for this ticket as "Won't Fix".

Changed in lighttpd (Ubuntu Maverick):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers