lighttpd mod_openssl undefined symbol

Bug #1814374 reported by Szebenyi Bálint on 2019-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lighttpd (Ubuntu)
Undecided
Unassigned

Bug Description

Expected behaviour:
- lighttpd starts

What happened:
Lighttpd does not start after this morning's unattended-upgrades. The upgrade was the following:

Start-Date: 2019-02-01 06:46:48
Commandline: /usr/bin/unattended-upgrade
Upgrade: libavahi-common-data:amd64 (0.6.32~rc+dfsg-1ubuntu2.2, 0.6.32~rc+dfsg-1ubuntu2.3), libavahi-common3:amd64 (0.6.32~rc+dfsg-1ubuntu2.2, 0.6.32~rc+dfsg-1ubuntu2.3), lighttpd:amd64 (1.4.35-4ubuntu2, 1.4.35-4ubuntu2.1), lighttpd-dev:amd64 (1.4.35-4ubuntu2, 1.4.35-4ubuntu2.1), libavahi-client3:amd64 (0.6.32~rc+dfsg-1ubuntu2.2, 0.6.32~rc+dfsg-1ubuntu2.3)
End-Date: 2019-02-01 06:47:11

Journalctl shows the following error for a service restart:
Feb 02 11:26:11 s systemd[1]: Stopped Lighttpd Daemon.
Feb 02 11:26:11 s systemd[1]: Starting Lighttpd Daemon...
Feb 02 11:26:11 s lighttpd[22575]: Syntax OK
Feb 02 11:26:11 s systemd[1]: Started Lighttpd Daemon.
Feb 02 11:26:11 s lighttpd[22582]: 2019-02-02 11:26:11: (plugin.c.169) dlopen() failed for: /usr/lib/lighttpd/mod_openssl.so /usr/lib/lighttpd/mod_openssl.so: undefined symbol: buffer_copy_buffer
Feb 02 11:26:11 s lighttpd[22582]: 2019-02-02 11:26:11: (server.c.679) loading plugins finally failed
Feb 02 11:26:11 s systemd[1]: lighttpd.service: Main process exited, code=exited, status=255/n/a
Feb 02 11:26:11 s systemd[1]: lighttpd.service: Unit entered failed state.
Feb 02 11:26:11 s systemd[1]: lighttpd.service: Failed with result 'exit-code'.

What I have tried:
* Restarting lighttpd multiple times
* Rolling back lighttpd, lighttpd-dev, openssl (separately, one-by-one)

System info:
lsb_release -rd
Description: Ubuntu 16.04.5 LTS
Release: 16.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers