undefined symbol: FAMNoExists

Bug #1453463 reported by Moses Moore on 2015-05-09
144
This bug affects 35 people
Affects Status Importance Assigned to Milestone
lighttpd
Fix Released
Unknown
lighttpd (Ubuntu)
Medium
Unassigned

Bug Description

lighttpd won't start.

Steps to reproduce:
$ sudo /usr/sbin/lighttpd
or
$ sudo systemctl start lighttpd

Expected outcome:
daemon starts.

Seen instead:
/usr/sbin/lighttpd: symbol lookup error: /usr/sbin/lighttpd: undefined symbol: FAMNoExists
or
Job for lighttpd.service failed. See "systemctl status lighttpd.service" and "journalctl -xe" for details.
$ systemctl status lighttpd.service -l
May 09 17:53:32 deunan systemd[1]: Starting Lighttpd Daemon...
May 09 17:53:32 deunan lighttpd[8229]: /usr/sbin/lighttpd: symbol lookup error: /usr/sbin/lighttpd: undefined symbol: FAMNoExists

Other info:
`ldd /usr/sbin/lighttpd` does not report any missing shared libraries.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: lighttpd 1.4.35-4ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-16.16-generic 3.19.3
Uname: Linux 3.19.0-16-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1
Architecture: i386
Date: Sat May 9 17:51:52 2015
InstallationDate: Installed on 2013-06-08 (700 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release i386 (20130423.1)
ProcEnviron:
 LANGUAGE=en_CA:en
 TERM=screen
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: lighttpd
UpgradeStatus: Upgraded to vivid on 2015-04-25 (14 days ago)
mtime.conffile..etc.lighttpd.conf.available.10.cgi.conf: 2013-08-02T23:17:55
mtime.conffile..etc.lighttpd.conf.available.10.fastcgi.conf: 2013-09-11T11:19:16

Moses Moore (moses-ubuntu) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lighttpd (Ubuntu):
status: New → Confirmed
Changed in lighttpd (Ubuntu):
importance: Undecided → Medium
pwaring (launchpad-pwaring) wrote :

I'm unable to reproduce this problem on a clean install with no configuration - installing lighttpd and then visiting http://localhost brings up the default placeholder page.

What happens if you disable all your user-defined configuration files? Can you get the basic placeholder page up?

Travis Allen (travis-r-allen) wrote :

I had this problem. The workaround:

sudo apt-get install gamin

It appears that the default lighttpd configuration tries to use fam (aka gamin), but there is no dependency on gamin. I would suggest either the package adds a gamin dependency, or the default configuration removes the fam dependency.

pwaring (launchpad-pwaring) wrote :

That workaround fixed the problem for me too - turns out the image I was working with already had gamin installed. Purging gamin also removed lighttpd, then re-installed lighttpd produced the following:

Setting up lighttpd (1.4.35-4ubuntu1) ...
Job for lighttpd.service failed. See "systemctl status lighttpd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript lighttpd, action "start" failed.

Hadmut Danisch (hadmut) wrote :

Same problem here with 15.10 beta:

lighttpd[5854]: /usr/sbin/lighttpd: symbol lookup error: /usr/sbin/lighttpd: undefined symbol: FAMNoExists

Installing gamin solves the problem, but kicks libfam0 out, maybe creating other problems elsewhere...

I was also affected by this issue on a quite fresh 15.10

Version: 1.4.35-4ubuntu1
Provides: httpd, httpd-cgi
Depends: libattr1 (>= 1:2.4.46-8), libbz2-1.0, libc6 (>= 2.15), libgamin0 | libfam0, libldap-2.4-2 (>= 2.4.7), libpcre3, libssl1.0.0 (>= 1.0.0), zlib1g (>= 1:1.1.4), init-system-helpers (>= 1.18~), perl, lsb-base (>= 3.2-14) | systemd (>= 29.1), mime-support, libterm-readline-perl-perl

apt pulled libfam0 by default and lighttpd got the undefined symbol raised.
Installing "gamin" instead solved the issue.

luator (anon-w) wrote :

Still the same on Ubuntu 16.04 -- installing gamin solved it, though.

Dmitry (dmitrymq) wrote :

Still the same on Ubuntu 16.04

Will this ever get fixed?

Changed in lighttpd (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed

Yep, install gamin solve this issue > it adds FAM libraries

Thomas (t-hartwig) wrote :

Same here: Ubuntu 16.04.2 LTS
Installing gamin fixes the issue. Please, please update the deps.

Ubuntu 17.04 and the problem remains!!!

Jarkko Hakala (roide) wrote :

Affects Ubuntu beta 17.10, 19th.Oct.2017 and replacing (lib?)fam with Gamin fixes it. 700+ days and counting..

Jaap (jwstolk) wrote :

I currently have this error in Ubuntu 16.04.3 LTS (recent fresh install)
works after installing gamin.

Same here, Ubuntu 16.04 LTS and ran into this problem immediately.

Mélodie (meets) wrote :

Hi, using Ubuntu 18.04 updated each day, I tried to install lighttpd, but it fails. First attempt, I got the same messages as the ones described above, when trying to restart it.

Then after I removed it completely and cleaned all packages in the cache, I reinstalled to see exactly how the messages could help find what is wrong. Here is what I get after a new reinstall:

**********

$ sudo apt install lighttpd
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Paquets suggérés :
  rrdtool php5-cgi apache2-utils lighttpd-doc
Paquets recommandés :
  spawn-fcgi
Les NOUVEAUX paquets suivants seront installés :
  lighttpd
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 276 ko dans les archives.
Après cette opération, 979 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 http://bouyguestelecom.ubuntu.lafibre.info/ubuntu bionic/universe amd64 lighttpd amd64 1.4.45-1ubuntu3 [276 kB]
276 ko réceptionnés en 0s (1 398 ko/s)
Sélection du paquet lighttpd précédemment désélectionné.
(Lecture de la base de données... 239794 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../lighttpd_1.4.45-1ubuntu3_amd64.deb ...
Dépaquetage de lighttpd (1.4.45-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour ufw (0.35-5) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-20) ...
Paramétrage de lighttpd (1.4.45-1ubuntu3) ...
Created symlink /etc/systemd/system/multi-user.target.wants/lighttpd.service → /lib/systemd/system/lighttpd.service.
Job for lighttpd.service failed because the control process exited with error code.
See "systemctl status lighttpd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript lighttpd, action "start" failed.
● lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sat 2018-05-26 18:00:41 CEST; 7ms ago
  Process: 4325 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (code=exited, status=127)
Traitement des actions différées (« triggers ») pour systemd (237-3ubuntu10.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-20) ...
Traitement des actions différées (« triggers ») pour ufw (0.35-5) ...

*********

thanks for fixing it!

psl (slansky) wrote :

Ubuntu 18.04

The same problem

# service lighttpd status
● lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabl
   Active: failed (Result: exit-code) since Fri 2018-06-08 17:03:43 CEST; 16s ago
  Process: 28595 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (c

Jun 08 17:03:43 desk systemd[1]: lighttpd.service: Service hold-off time over, schedul
Jun 08 17:03:43 desk systemd[1]: lighttpd.service: Scheduled restart job, restart coun
Jun 08 17:03:43 desk systemd[1]: Stopped Lighttpd Daemon.
Jun 08 17:03:43 desk systemd[1]: lighttpd.service: Start request repeated too quickly.
Jun 08 17:03:43 desk systemd[1]: lighttpd.service: Failed with result 'exit-code'.
Jun 08 17:03:43 desk systemd[1]: Failed to start Lighttpd Daemon.

# /usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf
/usr/sbin/lighttpd: Symbol `FamErrlist' has different size in shared object, consider re-linking
/usr/sbin/lighttpd: symbol lookup error: /usr/sbin/lighttpd: undefined symbol: FAMNoExists

FIX:
sudo apt-get install gamin

Please, add dependency of "gamin" to "lighttpd" package or remove dependency of gamin from lighttpd code.

Changed in lighttpd:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.