new upstream release(s)

Bug #1075629 reported by Stefan Bühler on 2012-11-06
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lighttpd (Ubuntu)
Undecided
Unassigned

Bug Description

Hi!

TLDR: Please import the debian package, and drop the lighttpd-dev package.

1. You really need to get the current release, there are many security/bug fixes.
2. As there is no stable api a lighttpd-dev package is insane. If someone/you want(s) to add modules to it, add them directly in the package, rebuild the package, and make sure you have strict version dependencies.
3. It would probably be good if you don't modify the debian package, so future imports are easier - I guess that is what keeps updates getting merged in a sane way.
4. If you are not able to keep your packages up to date, I have to ask you to remove them - the current status is NOT ACCEPTABLE.

If you want to discuss the second point in more detail, just join #lighttpd on freenode, thx.

greetings from the upstream team,
stefan (stbuehler in #lighttpd)

Micah Gersten (micahg) on 2012-11-06
tags: added: upgrade-software-version
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lighttpd (Ubuntu):
status: New → Confirmed
gstrauss (gstrauss) wrote :

Hello Debian maintainers. Need an extra hand maintaining lighttpd packages on Debian? How would I become a maintainer? Like stbuehler, I am a lighttpd developer and would like to see Debian and Ubuntu user issues resolved when fixes are available and backporting involves small, safe patches.

For review, stbuehler builds Debian packages for recent releases at
https://build.opensuse.org/package/show/home:stbuehler:lighttpd-1.4.x/lighttpd

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers