lighttpd crashes when accessed over ssl from my mobile

Bug #1015730 reported by Austin on 2012-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lighttpd (Ubuntu)
Undecided
Unassigned

Bug Description

I don't know what's going on here. Fully patched system (as of June 20, 2012)

$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

$ apt-cache policy lighttpd
lighttpd:
  Installed: 1.4.28-2ubuntu4
  Candidate: 1.4.28-2ubuntu4
  Version table:
 *** 1.4.28-2ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

When I access the server over ssl with my mobile, a Motorola Milestone XT720 running Cyanogenmod 7.2, user agent: "Mozilla/5.0 (Linux; U; Android 2.3.7; en-us; XT720 Build/GINGERBREAD; CyanogenMod-7.2.0) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1", the lighttpd server process crashes immediately. Nothing is written to /var/log/lighttpd/error.log or /var/log/lighttpd/access.log regarding the request.

If i access the same server over http with the device, everything is fine and dandy. If I had to guess I'd say something is wrong with the SSL behavior of lighttpd in version 1.4.28. I have an Ubuntu 10.04 server running lighttpd 1.4.30 that does not have this issue.

Austin (ninjamonic) wrote :

Issue is also present when I compile 1.4.31 and 1.4.30 from source on the affected box.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers