Thunderbird and Sunbird claim to be able to open PNG , JPEG and GIF files

Bug #458148 reported by Matthew Paul Thomas on 2009-10-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lightning-sunbird (Ubuntu)
Low
Unassigned
thunderbird (Ubuntu)
Low
Micah Gersten
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Sunbird 0.9, Ubuntu 9.10; Thunderbird 2.0.0.23, Ubuntu 9.10

1. Right-click on a PNG or JPEG file.
2. Open the "Open With" submenu.
3. Choose "Mozilla Thunderbird Mail/News" or "Sunbird".

What happens:
2. "Mozilla Thunderbird Mail/News" and "Sunbird" are present in the submenu.
3. Thunderbird or Sunbird launches, but does not open the image.

What should happen:
2. Thunderbird and Sunbird should not be present in the submenu.

John Vivirito (gnomefreak) wrote :

This is a bug in firefox download manager

affects: lightning-sunbird (Ubuntu) → firefox-3.5 (Ubuntu)
Matthew Paul Thomas (mpt) wrote :

How does it have anything at all to do with Firefox?

Micah Gersten (micahg) wrote :

Moving to Sunbird.

I can confirm the desktop file claims to support the image types.

affects: firefox-3.5 (Ubuntu) → lightning-sunbird (Ubuntu)
Changed in lightning-sunbird (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
John Vivirito (gnomefreak) wrote :

Matthew:
Sorry i thought you stated that you were trying to download the image. As i recall there is a bug for other apps that have same issues, I just dont recall the bug #

John Vivirito (gnomefreak) wrote :

Ignore my last comment i was doing 2 bugs at once. i found the problem but i will wait for either a list of fixes or 1.0* this way im not uploading 1 fix that is not really important as much as some others would be.

The reason for this bug is when i first packaged sunbird i used thunderbird package and adjusted as needed and it seems i forgot to remove that. It has been there since 0.5 (fairly sure that was the first package in Ubuntu

Changed in lightning-sunbird (Ubuntu):
assignee: nobody → John Vivirito (gnomefreak)
Matthew Paul Thomas (mpt) wrote :

I guess this bug needs to be fixed in exactly the same way in the Thunderbird package as it does in the Sunbird package.

description: updated
summary: - Sunbird claims to be able to open PNG and JPEG files
+ Thunderbird and Sunbird claim to be able to open PNG and JPEG files

On 11/03/09 06:27, Matthew Paul Thomas wrote:
> I guess this bug needs to be fixed in exactly the same way in the
> Thunderbird package as it does in the Sunbird package.
>
> ** Description changed:
>
> - Sunbird 0.9, Ubuntu Karmic beta
> + Sunbird 0.9, Ubuntu 9.10; Thunderbird 2.0.0.23, Ubuntu 9.10
>
> 1. Right-click on a PNG or JPEG file.
> 2. Open the "Open With" submenu.
> - 3. Choose "Sunbird".
> + 3. Choose "Mozilla Thunderbird Mail/News" or "Sunbird".
>
> What happens:
> - 2. Sunbird is present in the submenu.
> - 3. Sunbird launches, but does not open the image.
> + 2. "Mozilla Thunderbird Mail/News" and "Sunbird" are present in the submenu.
> + 3. Thunderbird or Sunbird launches, but does not open the image.
>
> What should happen:
> - 2. Sunbird should not be present in the submenu.
> + 2. Thunderbird and Sunbird should not be present in the submenu.
>
> ** Also affects: thunderbird (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Summary changed:
>
> - Sunbird claims to be able to open PNG and JPEG files
> + Thunderbird and Sunbird claim to be able to open PNG and JPEG files
>
I am taking a vacation for about ~3 months i am leaving for it
in ~2weeks not sure if i am bring this PC or a different one yet.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

ok i will bring this up if someone ends up packaging 1.0b* and than after that release will we not be updating sunbird since upstream will not be supporting it any longer. but either me or if someone else packages it to fix this bug

John Vivirito (gnomefreak) wrote :

ah forgot to mention im on Lucid and will be adding more info to this bug about system

John Vivirito (gnomefreak) wrote :

sorry wrong bug :(

Changed in lightning-sunbird (Ubuntu):
assignee: John Vivirito (gnomefreak) → nobody
Kangarooo Jānis (kangarooo) wrote :

I just got something weird. Png files wanted to open with thunderbird. Yesrterday they were beeing opened with rosseta witch is defaul image opener in Xubuntu.
Last things i did:
Yesterday i made update
Installed gobby
Totady installed xchat qwit gwibber
uninstalled xchat.

Lionel Le Folgoc (mrpouit) wrote :

Default file associations in xubuntu-default-settings already use ristretto as image viewer, not thunderbird.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Invalid
Kangarooo Jānis (kangarooo) wrote :

Yes ristretto was default till now and now it has changed to tunderbird.

Architecture: i386
DistroRelease: Ubuntu 9.10
InstallationMedia: Xubuntu 9.10 "Karmic Koala" - Release i386 (20091028.3)
Package: xubuntu-default-settings 0.67
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected
summary: - Thunderbird and Sunbird claim to be able to open PNG and JPEG files
+ Thunderbird and Sunbird claim to be able to open PNG , JPEG and GIF
+ files
John Vivirito (gnomefreak) wrote :

This should be fixed when we update to 1.0
I am unable to package it for this dev cycle due to personal responsibility

Micah Gersten (micahg) wrote :

This has been fixed in our bzr branch. You should be able to test the build in the daily PPA tomorrow with the fix if you like.

Changed in thunderbird (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 3.0.3+nobinonly-0ubuntu1

---------------
thunderbird (3.0.3+nobinonly-0ubuntu1) lucid; urgency=low

  * New upstream release v3.0.3 (THUNDERBIRD_3_0_3_RELEASE)

  * fix LP: #458148 - Thunderbird and Sunbird claim to be able to open PNG,
    JPEG and GIF files
    - update debian/thunderbird.desktop
  * fix failure in build due to unrecognized line-end-escapes in Makefile
    (Thanks kees for the original patch)
    - add debian/patches/fix-build-glitch.patch
    - update debian/patches/series
 -- Micah Gersten <email address hidden> Mon, 08 Mar 2010 08:28:50 -0600

Changed in thunderbird (Ubuntu):
status: Fix Committed → Fix Released
John Vivirito (gnomefreak) wrote :

Marking triaged since there is no more info needed. This will be fixed in 1.0b1(final Sunbird version)

Changed in lightning-sunbird (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers