After upgrading to Ubuntu 9.04, I cannot create any new calendar

Bug #372230 reported by mosses on 2009-05-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lightning-sunbird (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to Ubuntu 9.04, I cannot create any new calendar, Please make it available for Ubuntu 9.04

exhuma.twn (exhuma-web) wrote :

Same here. In fact, it looks as if the calendar does not render properly.

exhuma.twn (exhuma-web) wrote :

Here's a screenshot of the context menu where the option to create a new calendar is disabled.

John Vivirito (gnomefreak) wrote :

When you say "create calendars" What exactly are you trying to do? create a personal calendar?
Version of lightning and thunderbird is needed.
Are you also using sunbird or just lightning?
Can you try in sunbird to see if you can create one.
I'm not having problems with creating calendars in lightning or sunbird
Also please list step by step instructions on how to reproduce this

Changed in lightning-sunbird (Ubuntu):
status: New → Incomplete
John Vivirito (gnomefreak) wrote :

Are you able to create say tasks or anything else in an existing calendar you have write permissions on?

John Vivirito (gnomefreak) wrote :

do you have google-agenda-provider installed?

exhuma.twn (exhuma-web) wrote :

Thunderbird Version 2.0.0.21 (Build 20090409)
Lightning Version 0.9 (Build 2008091718)

To Reproduce:

1. Install Lightning
2. Open Thunderbird
3. Click on "Calendar" in the bottom left corner of the window
4. Right click into the "Calendar" pane just below the small month-view.

What strikes me, is that not a single calendar is shown. Normally Lightning/Sunbird refuses to delete the calendar if it's the only one left IIRC. Right now, as seen in my screenshot, the main view is plain white. It does not show any grid as you would expect.

I installed Sunbird earlier today, and there it seems fine. As the only calendar I am using is a remote calendar (using WCAP), I can easily switch between Sunbird and Thunderbird.

I'm beginning to suspect that it may be a problem in a configuration file. I'll dig around a bit and see what I can find.

exhuma.twn (exhuma-web) wrote :

Oh.... I just realised that I in fact do have "Provider for Google Calendar 0.5" installed. Can't remember installing it ;)

exhuma.twn (exhuma-web) wrote :

I did now several fresh installs of lightning. All without success. I also removed "WCAP Enabler" and disabled the aforementioned Google addon. I had a look through the profiles folder and saw the files disappear properly when doing the uninstall. Sometimes applications leave configuration files hanging around when uninstalling. This seems to be not the case for TB addons. So I reckon that the configuration was properly wipes as well during the uninstall. Unless it's stored somewhere else.

Anyway..... After a few fresh installs, I'm still left with an empty calendar view :(

The issue was resolved using the extension stored in apt, doesn't use the
xpi downloaded from mozilla page.

sudo apt-get install lightning-extension

Please, can you close this bug

On Wed, May 6, 2009 at 9:50 AM, exhuma.twn <email address hidden> wrote:

> I did now several fresh installs of lightning. All without success. I
> also removed "WCAP Enabler" and disabled the aforementioned Google
> addon. I had a look through the profiles folder and saw the files
> disappear properly when doing the uninstall. Sometimes applications
> leave configuration files hanging around when uninstalling. This seems
> to be not the case for TB addons. So I reckon that the configuration was
> properly wipes as well during the uninstall. Unless it's stored
> somewhere else.
>
> Anyway..... After a few fresh installs, I'm still left with an empty
> calendar view :(
>
> --
> After upgrading to Ubuntu 9.04, I cannot create any new calendar
> https://bugs.launchpad.net/bugs/372230
> You received this bug notification because you are a direct subscriber
> of the bug.
>

John Vivirito (gnomefreak) wrote :

We know google provider is broken but since we dont provide it in repos you need to file bug with upstream author

Changed in lightning-sunbird (Ubuntu):
status: Incomplete → Invalid
exhuma.twn (exhuma-web) wrote :

As mosses wrote, uninstalling the manually installed xpi file and installing the "lightning-extension" package solved this problem for me! Even *with* the Google Provider installed and enabled!

So I can consider this issue "closed" as well.

Thanks for the quick help.

FD (fdouw) wrote :

I just ran across this bug; actually, I have been using Ubuntu 9.04 for a while now, but the bug is the same otherwise: no calendars are visible in Lightning and I cannot create new calendars either.

I am using Thunderbird version 2.0.0.23 (build 20090817) with Lightning 0.9 (build 2009040813) from the repositories; I also have libstdc++5 installed.

When I first noticed this bug, I was using Lightning from the repos without libstdc++5 installed; next, I tried Lighting from the Mozilla website, first without, then with, libstdc++5; finally I tried Lightning from the repos with libstdc++5.

I also noticed Provider for Google Calendar 0.5 was installed the last time I installed Lightning from the repos, the bug still remains even if I disable Provider for Google Calendar.

Changed in lightning-sunbird (Ubuntu):
status: Invalid → New
democodex (scott-stepuptravel) wrote :

this solved the bug for me.

uninstall lightning 0.9.
install libstdc++5 (synaptic package manager or 'sudo aptitude install libstdc++5')
reinstall lightning 0.9.

if that still doesn't solve it for you, then install google calendar manager add-on and that should do the trick if you use the XML remote calendar format.

http://groups.google.com/group/provider-for-google-calendar/browse_thread/thread/fa4633f7bf5b37d7?pli=1

FD (fdouw) wrote :

I have tried this again, just to be sure, but it still does not work. As I mentioned earlier, I have tried both the version from the Mozilla website and the version from the repositories; neither of those works, nor does it matter if I enable or disable the “Provider for Google Calendar” add-on.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers