Messaging menu extension interacts badly with lightning in precise making thunderbird unusable

Bug #933951 reported by Micah Gersten on 2012-02-17
180
This bug affects 35 people
Affects Status Importance Assigned to Milestone
lightning-extension (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
thunderbird (Ubuntu)
High
Chris Coulson
Precise
High
Chris Coulson

Bug Description

WORKAROUND: thunderbird -safe-mode, Disable messaging menu addon, restart thunderbird

ii thunderbird 11.0~b2+build2-0ubuntu1 Email, RSS and newsgroup client with integrated spam filter
ii xul-ext-lightning 1.3~b1+build1-0ubuntu1 Calendar Extension for Thunderbird

When I started Thunderbird after the beta 2 update, it would not display any of the main content, and I received a bunch of errors about my calendars. Disabling the messaging menu extension returned thunderbird to normal.

[Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]" nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///usr/lib/mozilla/extensions/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 624" data: no]

This is confirmed in a clean profile.

Exception from terminal:
enigmail.js: Registered components
-- Exception object --
+ QueryInterface (function) 3 lines
+ message (string) 'Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]'
+ result (number) 2153185302
+ name (string) 'NS_ERROR_XPC_GS_RETURNED_FAILURE'
+ filename (string) 'chrome://messenger/content/search.xml'
+ lineNumber (number) 109
+ columnNumber (number) 0
+ location (object) JS frame :: chrome://messenger/content/search.xml :: :: line 109
+ inner (object) null
+ data (object) null
+ initialize (function) 3 lines
*
Error: [Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]" nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///usr/lib/mozilla/extensions/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 624" data: no]

Micah Gersten (micahg) wrote :

Since it's reproducible in a clean profile, I'm marking it triaged.

description: updated
Changed in thunderbird (Ubuntu):
status: New → Triaged
description: updated
Micah Gersten (micahg) wrote :

Dropping to medium since this is trivially worked around.

Changed in thunderbird (Ubuntu):
importance: High → Medium
tags: added: precise regression-release
Micah Gersten (micahg) on 2012-02-17
description: updated
summary: - Messaging menu extension interacts badly with lightning and thunderbird
- in precise
+ Messaging menu extension interacts badly with lightning in precise
+ making thunderbird unusable
Jools Wills (jools) wrote :

How did you disable the messaging menu extension? the addons settings window doesn't work here either. (i commented on the duplicate by accident sorry).

Jools Wills (jools) wrote :

log : note the additional errors caused when choosing the addons menu.

-- Exception object --
+ QueryInterface (function) 3 lines
+ message (string) 'Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]'
+ result (number) 2153185302
+ name (string) 'NS_ERROR_XPC_GS_RETURNED_FAILURE'
+ filename (string) 'chrome://messenger/content/search.xml'
+ lineNumber (number) 109
+ columnNumber (number) 0
+ location (object) JS frame :: chrome://messenger/content/search.xml :: :: line 109
+ inner (object) null
+ data (object) null
+ initialize (function) 3 lines
*
Error: [Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]" nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///usr/lib/mozilla/extensions/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 624" data: no]
-- Exception object --
+ fileName (string) 'chrome://messenger/content/tabmail.xml'
+ lineNumber (number) 465
*
-- Stack Trace --
openTab("contentTab",[object Object])@chrome://messenger/content/tabmail.xml:465
openTab("contentTab",[object Object],"tab")@chrome://communicator/content/utilityOverlay.js:259
openContentTab("about:addons","tab","addons.mozilla.org")@chrome://communicator/content/utilityOverlay.js:287
openAddonsMgr()@chrome://messenger/content/mailCore.js:406
oncommand([object XULCommandEvent])@chrome://messenger/content/messenger.xul:1
-- Exception object --
+ fileName (string) 'chrome://messenger/content/tabmail.xml'
+ lineNumber (number) 465
*
-- Stack Trace --
openTab("contentTab",[object Object])@chrome://messenger/content/tabmail.xml:465
openTab("contentTab",[object Object],"tab")@chrome://communicator/content/utilityOverlay.js:259
openContentTab("about:addons","tab","addons.mozilla.org")@chrome://communicator/content/utilityOverlay.js:287
openAddonsMgr()@chrome://messenger/content/mailCore.js:406
oncommand([object XULCommandEvent])@chrome://messenger/content/messenger.xul:1
-- Exception object --
+ fileName (string) 'chrome://messenger/content/tabmail.xml'
+ lineNumber (number) 465
*
-- Stack Trace --
openTab("contentTab",[object Object])@chrome://messenger/content/tabmail.xml:465
openTab("contentTab",[object Object],"tab")@chrome://communicator/content/utilityOverlay.js:259
openContentTab("about:addons","tab","addons.mozilla.org")@chrome://communicator/content/utilityOverlay.js:287
openAddonsMgr()@chrome://messenger/content/mailCore.js:406
oncommand([object XULCommandEvent])@chrome://messenger/content/messenger.xul:1

Micah Gersten (micahg) on 2012-02-17
description: updated
description: updated
Micah Gersten (micahg) wrote :

Bumping back to high due to number of dupes.

Changed in thunderbird (Ubuntu Precise):
importance: Medium → High
assignee: nobody → Chris Coulson (chrisccoulson)

Same problem as comment #3. I can't even disable the problematic addon(s) because Thunderbird won't open any new tabs and all dialog windows it produces are empty as well. For all intents and purposes it is completely unusable now and I see no way to apply the workaround.

Jim (jimvernon) wrote :

Open a terminal. Type "thunderbird --safe-mode". When Thunderbird opens, go into the Add-on Manager and disable the Messaging Menu add-on.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0~b2+build2-0ubuntu2

---------------
thunderbird (11.0~b2+build2-0ubuntu2) precise; urgency=low

  * Add a missing file (LP: #933951)
 -- Chris Coulson <email address hidden> Fri, 17 Feb 2012 09:09:27 +0000

Changed in thunderbird (Ubuntu Precise):
status: Triaged → Fix Released
Chris Coulson (chrisccoulson) wrote :

Actually, this version fixes it:

thunderbird (11.0~b2+build2-0ubuntu3) precise; urgency=low

  * Add a missing file which caused Lightning to break (LP: #933951)
  * Trick the addon manager in to thinking that Lightning has been updated
    when upgrading
    - update debian/thunderbird.postinst.in

 -- Chris Coulson <email address hidden> Fri, 17 Feb 2012 09:09:27 +0000

But the fact this broke so badly (and doesn't recover without reinstalling lightning) actually appears to be a lightning bug.

Changed in lightning-extension (Ubuntu Precise):
status: New → Triaged
Elfy (elfy) wrote :

I don't have lightning installed at all here - had the same issue.

Bruno Girin (brunogirin) wrote :

Same as forestpiskie: I don't have Lightning installed at all and have the same issue, which I reported here: https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/934155

The issue has been fixed for me at least. Thanks much!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers