FTBFS: powerpc build fails (requires patch from thunderbird)

Bug #1025387 reported by Ben Collins on 2012-07-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightning-extension (Ubuntu)
High
Ben Collins
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

#error Target architecture was not detected as supported by Double-Conversion.

This error is fixed with a patch in thunderbird. I'll supply a debdifff once I get it compiling.

Ben Collins (ben-collins) wrote :

This debdiff fixes the build.

tags: added: patch
Micah Gersten (micahg) wrote :

The stable releases are staged in ppa:ubuntu-mozilla-security/ppa and will be pushed out with Thunderbird 14 (bug 1024564)

Changed in lightning-extension (Ubuntu Natty):
status: New → Fix Committed
Changed in lightning-extension (Ubuntu Oneiric):
status: New → Fix Committed
Changed in lightning-extension (Ubuntu Precise):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-extension - 1.6+build1-0ubuntu0.12.04.2

---------------
lightning-extension (1.6+build1-0ubuntu0.12.04.2) precise-security; urgency=low

  * New upstream stable release (CALENDAR_1_6_BUILD1) (LP: #1024564)

  [ Chris Coulson <email address hidden> ]
  * Fix LP: #995054 - Ensure the /usr/lib/thunderbird/extensions symlink
    exists on upgrade, which may not be the case when upgrading from a really
    old lightning version
    - add debian/lightning-extension.postinst

  [ Ben Collins <email address hidden> ]
  * Fix LP: #1025387 - FTBFS: powerpc build fails
    - add debian/patches/fix-dtoa-build-on-ppc.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Mon, 16 Jul 2012 15:03:32 -0500

Changed in lightning-extension (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-extension - 1.6+build1-0ubuntu0.11.04.2

---------------
lightning-extension (1.6+build1-0ubuntu0.11.04.2) natty-security; urgency=low

  * New upstream stable release (CALENDAR_1_6_BUILD1) (LP: #1024564)

  [ Chris Coulson <email address hidden> ]
  * Fix LP: #995054 - Ensure the /usr/lib/thunderbird/extensions symlink
    exists on upgrade, which may not be the case when upgrading from a really
    old lightning version
    - add debian/lightning-extension.postinst

  [ Ben Collins <email address hidden> ]
  * Fix LP: #1025387 - FTBFS: powerpc build fails
    - add debian/patches/fix-dtoa-build-on-ppc.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Mon, 16 Jul 2012 14:19:14 -0500

Changed in lightning-extension (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-extension - 1.6+build1-0ubuntu0.11.10.2

---------------
lightning-extension (1.6+build1-0ubuntu0.11.10.2) oneiric-security; urgency=low

  * New upstream stable release (CALENDAR_1_6_BUILD1) (LP: #1024564)

  [ Chris Coulson <email address hidden> ]
  * Fix LP: #995054 - Ensure the /usr/lib/thunderbird/extensions symlink
    exists on upgrade, which may not be the case when upgrading from a really
    old lightning version
    - add debian/lightning-extension.postinst

  [ Ben Collins <email address hidden> ]
  * Fix LP: #1025387 - FTBFS: powerpc build fails
    - add debian/patches/fix-dtoa-build-on-ppc.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Mon, 16 Jul 2012 14:36:32 -0500

Changed in lightning-extension (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Micah Gersten (micahg) on 2012-10-19
Changed in lightning-extension (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers