indicator-session no longer locks the screen when user switching

Bug #939518 reported by Marc Deslauriers on 2012-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Low
Unassigned
indicator-session (Ubuntu)
Low
Unassigned
lightdm (Ubuntu)
Low
Unassigned

Bug Description

Since indicator-session 0.3.91-0ubuntu1, the user session isn't locked properly when switching between users.

To reproduce:

1- Select different user from indicator-session
2- At lightdm screen, do ctrl-alt-F7 to return to user session
3- notice user session isn't locked

or

1- Select different user from indicator-session
2- At lightdm screen, log in as a different user
3- do ctrl-alt-F7 to switch to initial user
4- See the user's whole desktop for a couple of seconds before the lock dialog pops up

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: indicator-session 0.3.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Thu Feb 23 08:52:09 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
SourcePackage: indicator-session
UpgradeStatus: Upgraded to precise on 2012-01-03 (50 days ago)

Marc Deslauriers (mdeslaur) wrote :
Changed in indicator-session (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.92-0ubuntu1

---------------
indicator-session (0.3.92-0ubuntu1) precise; urgency=low

  * debian/patches/restore_session_lock.patch, debian/rules:
    - get the indicator to enforce locking again since we still have cases
      where locking is not done otherwise (lp: #939518)

  [ Martin Pitt ]
  * debian/control: Add alternative packagekit dependency, since this ought to
    work with either the aptdaemon pkcompat or packagekit itself.

  [ Ted Gould ]
  * New upstream release.
    * Make GUDev dependency optional for non-Linux kernels
    * Add accessibility strings on the icons (LP: #891861)
 -- Sebastien Bacher <email address hidden> Thu, 23 Feb 2012 19:42:06 +0100

Changed in indicator-session (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

Ok, I reverted the indicator-session commit in the package for now but ideally that would be fixed in lightdm or wherever it makes sense ... Robert, any idea about what needs fixing still?

Changed in indicator-session:
status: New → Fix Released
importance: Undecided → Low
Changed in lightdm (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers