Timed autologin feature not working

Bug #902852 reported by riffe on 2011-12-11
168
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Light Display Manager
High
Unassigned
Unity Greeter
Fix Released
Medium
Unassigned
lightdm (Ubuntu)
Medium
Robert Ancell
Precise
Medium
Unassigned
Quantal
Medium
Robert Ancell
unity-greeter (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

[Impact]
Not able to set an automatic login with a timeout on Ubuntu 12.04.1

[Test Case]
1. Enable automatic login in /etc/lightdm/lightdm.conf:
[SeatDefaults]
autologin-user=bob
autologin-user-timeout=10
2. Restart machine
3. Wait on greeter
Expected result:
Greeter automatically logs in as bob after 10 seconds
Observed result:
Remain on login screen, nothing happens after 10 seconds.

[Regression potential]
Other authentication may be affected. Tested with lightdm regression tests.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you copy your config there?

riffe (jriffe) wrote :

Here it is (very simple) :

[SeatDefaults]
greeter-session=unity-greeter
autologin-user=XXXX
autologin-user-timeout=9
user-session=ubuntu

I also tried with 9000 in case it would be expressed in ms.
And I tried to swap autologin-user and autologin-user-timeout, just in case.

No effect.

Sebastien Bacher (seb128) wrote :

what lightdm version do you use?

riffe (jriffe) wrote :

I've got an up-to-date ubuntu 11.10, so it is lightdm 1.0.6-0ubuntu1.2

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
riffe (jriffe) on 2012-04-28
description: updated
riffe (jriffe) wrote :

Still true in Precise

Marc Balmer (marc-wz6bkyh) wrote :

I found the problematic spot in the source and it seems straight forward to fix. But I am having some troubles with the toolchain, and with building the package from source...

Sebastien Bacher (seb128) wrote :

@Marc: great, do you need help to get it to build? if you don't want to bother maybe just explain what code needs to be fixed and in which way?

Changed in lightdm (Ubuntu):
importance: Undecided → Low

Am 29.05.12 11:42, schrieb Sebastien Bacher:
> @Marc: great, do you need help to get it to build? if you don't want to
> bother maybe just explain what code needs to be fixed and in which way?

I got it building in the meantime. I can somehow build the lightdm
binary package, and I am seeing where this is going now.

btw, you can also catch me on the #ubuntu irc channel

Marc,

Are you planning on proposing a fix for this with a merge prop? I can assist if you have questions, you can also find me on IRC, my nick is in my LP profile.

Sebastien Bacher (seb128) wrote :

@Marc: do you still work on that? Could you at least tell us where you found the issue?

Am 21.06.2012 um 14:32 schrieb Sebastien Bacher <email address hidden>:

> @Marc: do you still work on that?

Yes, I am, but I am AFK till next monday, i will come back to this

> Could you at least tell us where you
> found the issue?

Sure, once I returned ( next week)

>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/902852
>
> Title:
> lightdm.conf : autologin-user-timeout doesn t work
>
> Status in “lightdm” package in Ubuntu:
> Confirmed
>
> Bug description:
> The parameter autologin-user-timeout in lightdm.conf has no effect,
> and when an autologin is set there is no way to choose an alternative
> profile.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/902852/+subscriptions

No hurry, you didn't reply to the previous comments so I was unsure you were still around, thanks

riffe (jriffe) wrote :

@Sebastien : can you explain how the importance is decided (just want to understand, it is not an attempt to bargain) ?

To me this feature is really a must-have, especially in a domestic context with this two examples I have at home :
- HCPC with XBMC on autologin
- desktop with a young children oriented profile on autologin
but in both case, the abilty to choose a regular profile during a few seconds

Same thing in a professional context with self-service kiosks, even if I personnaly have no real experience of it.

Maarten Boekhold (boekhold) wrote :

Any update on the release of this fix as (seemingly) proposed by @Marc Balmer? I'm running lightdm 1.2.1-0ubuntu1.1 (just did a do-release-upgrade -d last night) on precise, and this isn't working yet...

I don't see how this bug can be considered "Low" importance; this is a serious break in functionality. Granted, breaking functionality seems to have become the standard operating procedure with Ubuntu as of late, but really, hope that's just a temporary problem.

I suspect the only current work-around is to use a different display manager, such as GDM or MDM, one that isn't broken.

Sebastien Bacher (seb128) wrote :

Hey Robert, could you have a look to this one?

Changed in lightdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Low → Medium
Robert Ancell (robert-ancell) wrote :

riffe, what do you mean by "when an autologin is set there is no way to choose an alternative profile."?

Changed in lightdm:
importance: Undecided → High
status: New → Fix Committed
Changed in lightdm (Ubuntu Quantal):
status: Confirmed → Triaged
Robert Ancell (robert-ancell) wrote :

Looks like it was never properly implemented in LightDM. I've fixed this for LightDM 1.3.5 and 1.2.3 and added regression tests to check this works. Unity Greeter (at least) needs to be updated to make this work too.

Changed in unity-greeter:
status: New → Triaged
importance: Undecided → Medium
Changed in unity-greeter (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
summary: - lightdm.conf : autologin-user-timeout doesn t work
+ Timed autologin feature not working
riffe (jriffe) wrote :

@Robert : guess you already got the answer, but I what I meant is

the timeout parameter has no effect, the autologin profile is activated immediately, and the only possibility to choose another profile is then to logout

Anthony (craigslistamc) wrote :

Will we be seeing this backported to those who are updating as ubuntu releases updates? Or will we have to wait till ubuntu catches up to 1.3.5?

Robert Ancell (robert-ancell) wrote :

Fixed in lightdm 1.4.0

Changed in lightdm:
status: Fix Committed → Fix Released
Changed in unity-greeter (Ubuntu Quantal):
status: Triaged → Fix Released
status: Fix Released → Triaged
Changed in lightdm (Ubuntu Quantal):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 12.10.4-0ubuntu5

---------------
unity-greeter (12.10.4-0ubuntu5) quantal; urgency=low

  * debian/patches/fix-timed-autologin.patch:
    - Fix timed login by paying attention to the signal from lightdm.
      Patch from upstream trunk. LP: #902852
  * debian/control:
    - Require lightdm 1.4.0 for their own fixes to timed autologin
 -- Michael Terry <email address hidden> Tue, 09 Oct 2012 10:32:05 -0400

Changed in unity-greeter (Ubuntu Quantal):
status: Triaged → Fix Released

Any chance in getting this solved in 12.04? Sometimes I wonder what the LTS stands for... :-(

Sebastien Bacher (seb128) wrote :

> Any chance in getting this solved in 12.04?

Yes, it was just fixed in quantal and nobody confirmed it work, it will be backported in time

> Sometimes I wonder what the LTS stands for... :-(

Sneaky comments are not really useful, they tend to be demotivating, if anything, for the people who work hard for free to resolve those issues

>> Any chance in getting this solved in 12.04?

> Yes, it was just fixed in quantal and nobody confirmed it work, it will be backported in time

I don't know what the procedure for "backporting" is, but maybe it could be backported first.

The reason you didn't get any confirmation might be that none of the people here use Quantal. At least that's what it looks like when reading all comments. If this problem would be solved for precise I bet you would get half a dozen confirmations within one day.

riffe (jriffe) wrote :

@seb128 :

ok it works in Quantal.

But, it doesn't have a feature we had before : the graphical vizualisation of the timer
To me this is not a must have, but it is still an important functionnal regression.

Were you waiting for confirmation before implementing it in Precise ?

Robert Ancell (robert-ancell) wrote :

This is fixed for precise in lightdm 1.2.3 and unity-greeter 0.2.9.

Changed in lightdm (Ubuntu Precise):
status: New → Fix Committed
Changed in unity-greeter (Ubuntu Precise):
status: New → Fix Committed
Changed in lightdm (Ubuntu Precise):
importance: Undecided → Medium
Changed in unity-greeter (Ubuntu Precise):
importance: Undecided → Medium
Changed in unity-greeter:
status: Triaged → Fix Released
description: updated
Sebastien Bacher (seb128) wrote :

(settings precise lines to "in progress" since that's the status the SRU team want for things in the queue, they move to fix commited once the SRU is in proposed then)

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → In Progress
Changed in lightdm (Ubuntu Precise):
status: Fix Committed → In Progress

Hello riffe, or anyone else affected,

Accepted lightdm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/lightdm/1.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lightdm (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Juha Aatrokoski (jha-kurp) wrote :

I installed liblightdm-gobject-1-0_1.2.3-0ubuntu1 and lightdm_1.2.3-0ubuntu1 on Precise with the following results:

* Timed autologin does not work at all with unity-greeter (though I see it's still marked as "In Progress").

* When switched to lightdm-gtk-greeter, the user is authenticated after the timeout but the login screen will still prompt for session selection and a push of the Login button. Also, no visual countdown/other display of the timeout.

* Timed autologin only works for the first time lightdm is started, it no longer works after logout from a session. (Immediate autologin should not work after logout, but timed autologin should.)

As such, version 1.2.3-0ubuntu1 does not in my opinion fix this bug on Precise. Will have to retest when the unity-greeter fix for Precise is available.

tags: added: verification-failed
removed: verification-needed

The update breaks autologin alltogether for me in Precise, both in unity-greeter and lightdm-gtk-greeter. No countdown, no autologin whatsoever...

[SeatDefaults]
user-session=ubuntu
greeter-session=lightdm-gtk-greeter
autologin-user=xyz
autologin-user-timeout=10

Colin Watson (cjwatson) wrote :

Hello riffe, or anyone else affected,

Accepted unity-greeter into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-greeter/0.2.9-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-greeter (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Juha Aatrokoski (jha-kurp) wrote :

Installed packages liblightdm-gobject-1-0_1.2.3-0ubuntu1, lightdm_1.2.3-0ubuntu1 and unity-greeter_0.2.9-0ubuntu1. Timed autologin works when using unity-greeter, but the following problems remain:

* Only works when lightdm service started, not after logout from a session.

* No visual countdown/other display of the timeout.

Sebastien Bacher (seb128) wrote :

> Timed autologin works when using unity-greeter, but the following problems remain

Thanks, setting to verification-done, the other issues should be adressed in different reports

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.2.3-0ubuntu1

---------------
lightdm (1.2.3-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - Correctly implement and test autologin timeouts (LP: #902852)
    - Move from QString::fromLocal8Bit to QString::fromUtf8 when converting from
      gchar
    - Support multiple simultaneous PAM prompts (LP: #972537)
    - Write utmp records for sessions
    - Add missing regression test script
  * debian/liblightdm-gobject-1-0.symbols:
    - Updated
  * debian/patches/05_utmp.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Wed, 21 Nov 2012 15:43:29 +1300

Changed in lightdm (Ubuntu Precise):
status: Fix Committed → Fix Released
John Eikenberry (jae) wrote :

Using the 1.2.1 packages (either 1.2.1-0ubuntu1 or 1.2.1-0ubuntu1.1) autologin was working fine. After upgrading to 1.2.3 it promptly stopped working. Config below. I reverted to the older 1.2.1 release to get it working again.

[SeatDefaults]
autologin-user=foo
autologin-user-timeout=1
greeter-session=lightdm-gtk-greeter
user-session=ubuntu

Matt Austin (mattaustin) wrote :

Confirmed that after upgrade to 1.2.3-0ubuntu1, autologin settings have no effect.

Downgrading to 1.2.1-0ubuntu1 gets autologin working again.

Ubuntu 12.04.2 i386.

AllenS (thehousecat) wrote :

Hi

I'm using x64 12.04 upgraded to the latest version from the repository. 1.2.3-0ubuntu1 is installed and auto login doesn't work when using autologin-user-timeout. If I comment out autologin-user-timeout then it will auto login (but of course it doesn't wait at the log in screen)

Config:
[SeatDefaults]
#user-session=ubuntu
user-session=XBMC
greeter-session=unity-greeter
autologin-user=xbmc
autologin-user-timeout=10

I don't know how to revert to an older version so I can't comment on that.

Thanks

Robert Ancell (robert-ancell) wrote :

Thomas, John, Matt, AllenS, see bug 1117893.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.9-0ubuntu1

---------------
unity-greeter (0.2.9-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - Backport better keyboard focus handling from upstream as new windows
      appear and disappear. This fixes keyboard navigation in dialogs
    - Don't write garbage data to state cache file
    - Make sure background alpha is never stuck at non-1.0 value, blocking
      login
    - When the default session is changed in lightdm.conf, don't still show the
      Ubuntu badge
    - Recognize the "kde-plasma" session as "kde" so it gets a properly branded
      icon in the greeter
    - Try to run unity_support_test for ubuntu for pre-caching the result in
      /tmp for further call while the user is typing his password
    - Support multiple prompts from PAM (LP: #972537)
    - Support timed login (LP: #902852)
  * debian/control:
    - Bump build-depends on liblightdm-gobject-1-dev
  * debian/patches/fix-focus.patch:
  * debian/patches/fix-hung-logging-in.patch:
  * debian/patches/recognize-kde-plasma.patch:
  * debian/patches/run_unity_support_test.patch:
  * debian/patches/show-changed-default-badge.patch:
  * debian/patches/state-file-garbage.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Wed, 21 Nov 2012 15:41:57 +1300

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
AllenS (thehousecat) wrote :

Hi Robert

That bug seems to be for lightdm-gtk-greeter. I'm using unity-greeter and timed login does not work.

Config:
[SeatDefaults]
#user-session=ubuntu
user-session=XBMC
greeter-session=unity-greeter
autologin-user=xbmc
autologin-user-timeout=10

When I comment out "autologin-user-timeout" auto login works: i.e. Ubuntu boots into the XBMC user session as the XBMC user. If I set "autologin-user-timeout=10" I see the log in screen for about a second and then the session logs in as the XMBC user into a Unity session.

This bug still exists in the latest updates fro precise.

Thanks

Juha Aatrokoski (jha-kurp) wrote :

AllenS: you can try setting autologin-session=XBMC to see if it fixes the wrong session problem. About the short timeout, I think that the timeout starts when lightdm starts, and it starts the greeter afterwards and on slower computers the greeter may not have enough time to get to presenting the login screen before the timeout is reached.

To let everyone interested know, I filed bug #1122890 about timed autologin not working after logout from a session. The missing visual indicator is not critical for me, so I won't be filing a bug about that.

AllenS (thehousecat) wrote :

Thanks Juha

I didn't notice there were two different options used for the session (user-session and autologin-session). Using autologin-session=XBMC works. I guess I didn't notice autologin-session because when you use autologin-user without autologin-user-timeout then the user-session gets used.

I'm happy this is fixed. Thanks.

Jean-Yves Avenard (jyavenard) wrote :

Well, despite all my attempts mentioned by various people here.

The only time I can get auto login to work is if I comment the autologin-user-timeout=xxx option.

Otherwise it stays forever on the login prompt

Ben Shadwick (benshadwick) wrote :

I'm seeing the same issue as jyavenard in KODIbuntu (formerly XBMC) 14.0 and 14.1 (based on Ubuntu 14.04.1 LTS), which is using lightdm 1.10.3.

Specifically, if I set autologin-user-timeout to any value other than zero, lightdm will never automatically log in.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.