/var/lib/lightdm files owned by invalid user after reinstall (directory should be clean when lightdm is removed)

Bug #887316 reported by Bill Danielson on 2011-11-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Low
Matt Fischer
Precise
Low
Unassigned

Bug Description

While I was trying out different display managers, I removed, then removed completely and then later reinstalled lightdm. This ended up changing the user id of lightdm. However, the dot files in /var/lib/lightdm were still owned by the old, now invalid user id and so lightdm could not read them. lightdm now did not start because it couldn't open its .Xauthority file. I fixed this by removing all the dot files in the /var/lib/lightdm directory and then letting lightdm recreate them. It looks like the "remove completely" option should remove the dot files in /var/lib/lightdm so they will be recreated with the correct userid if lightdm is reinstalled at a later date.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
TK (tkrishan) wrote :

This also happened to me on an upgrade from Oneiric to Precise Alpha2. I switched to GDM to get my system working at the time.

Purging lightdm did not work, as the originally reported, I had to manually delete the files in /var/lib/lightdm.

Bill Danielson (bigbrd) wrote :

A clarification....

In the original bug report I said:

It looks like the "remove completely" option should remove the dot files in /var/lib/lightdm so they will be recreated with the correct userid if lightdm is reinstalled at a later date.

I should have said (to be more clear):

It looks like the "remove completely" option should FIXED TO remove the dot files in /var/lib/lightdm so they will be recreated with the correct userid if lightdm is reinstalled at a later date.

I was suggesting a possible fix, not suggesting a workaround in the bug report.

Sebastien Bacher (seb128) wrote :

the directory should probably be cleaned by the maintainer scripts when lightdm is removed

Changed in lightdm (Ubuntu):
importance: Undecided → Low
summary: - /var/lib/lightdm files owned by invalid user after reinstall
+ /var/lib/lightdm files owned by invalid user after reinstall (directory
+ should be clean when lightdm is removed)
Matt Fischer (mfisch) on 2012-10-15
Changed in lightdm (Ubuntu):
assignee: nobody → Matt Fischer (mfisch)
status: Confirmed → In Progress
Matt Fischer (mfisch) on 2012-11-08
Changed in lightdm (Ubuntu):
status: In Progress → Fix Committed
Robert Ancell (robert-ancell) wrote :

Was fixed in 1.4.0-0ubuntu3

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers