Ubuntu

LightDM restarts after first login attempt

Reported by Jay S on 2011-10-14
88
This bug affects 17 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Low
Unassigned

Bug Description

When I initially boot or reboot my computer and am presented with the LightDM login screen, two strange things happen:

1) There are some weird graphical artifacts near the top of the screen that change as I type in my password.

2) After entering the password (correctly) and hitting enter, the LightDM screen disappears, my displays are turned off, and only moments later I'm presented with the login screen again. Logging in the second time is successful and I'm able to reach the desktop.

It seems like these might be part of the same problem. I can't say for sure whether this is consistent behavior because I only upgraded yesterday.

I'm using NVIDIA binary drivers with TwinView, Oneiric.

Jay S (topdownjimmy) wrote :

For what it's worth, this hasn't happened to me in a while.

Jay S (topdownjimmy) on 2011-10-30
Changed in lightdm:
status: New → Invalid
Phil Moorhouse (phil-moorhouse) wrote :

I'm having exactly the same issue using Nvidia TwinView and the recommended drivers (280.13 I think).

GeForce 310 on a Dell Vostro with 2x Dell 20" 1680x1050 displays. Using Oneiric 64-bit.

It happens on every login, top of the screen has strange artifacts that seem to grow and spread, first attempt goes to a blank screen, then returns you to the LightDM login screen. Second attempt takes you to the desktop successfully.

I'll try using the post-release updates driver and see if that makes a difference.

k0t (dr-kstin) wrote :

I have the same issue. Nvidia GT 440

The same problem on a new Ubuntu 11.10 installation. Using an Intel on-board graphic.

After booting you can enter anything and press enter which leads to a crash of the login screen. In the second time login is possible.

Why is this bug invalid?

Silas Lenz (silas-lenz) wrote :

I have exactly the same problem.
GTX 460 and Nvidia drivers
I'm can take some screenshots or help testing bugfixes if needed.

01:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: Giga-byte Technology Device 34fc
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at f8000000 (32-bit, non-prefetchable) [size=32M]
 Memory at d0000000 (64-bit, prefetchable) [size=128M]
 Memory at d8000000 (64-bit, prefetchable) [size=64M]
 I/O ports at e000 [size=128]
 [virtual] Expansion ROM at fa000000 [disabled] [size=512K]
 Capabilities: <access denied>
 Kernel driver in use: nvidia
 Kernel modules: nvidia_current, nouveau, nvidiafb

Changed in lightdm:
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

Could you add your lightdm.log to the bug after getting the issue?

Changed in lightdm:
importance: Undecided → Low
status: Confirmed → Incomplete
Silas Lenz (silas-lenz) wrote :

Sure.
The log is available here (and in the zip below):
http://paste.ubuntu.com/840683/
And some really bad images, and a even worse video of what happens when you log in.
http://dl.dropbox.com/u/4997718/lightdm.tar.gz

Sebastien Bacher (seb128) wrote :

The x-1.log in the tarball has

"Backtrace:
0: /usr/bin/X (xorg_backtrace+0x26) [0x460566]
1: /usr/bin/X (0x400000+0x64b7a) [0x464b7a]
2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f714098e000+0x10060) [0x7f714099e060]
3: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so (0x7f713b059000+0xe17d7) [0x7f713b13a7d7]
4: /usr/lib/xorg/modules/libwfb.so (wfbBlt+0x154) [0x7f713a3cd554]
5: /usr/lib/xorg/modules/libwfb.so (wfbOddTile+0x170) [0x7f713a3de600]
6: /usr/lib/xorg/modules/libwfb.so (wfbFill+0x54d) [0x7f713a3d2d9d]
7: /usr/lib/xorg/modules/libwfb.so (wfbPolyFillRect+0x1c4) [0x7f713a3d3574]
8: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so (0x7f713b059000+0x463baf) [0x7f713b4bcbaf]
9: /usr/bin/X (0x400000+0xde915) [0x4de915]
10: /usr/bin/X (miPaintWindow+0x1a0) [0x45b590]
11: /usr/bin/X (miWindowExposures+0xc2) [0x45b752]
12: /usr/bin/X (0x400000+0x13486d) [0x53486d]
13: /usr/bin/X (miHandleValidateExposures+0x68) [0x5651e8]
14: /usr/bin/X (UnmapWindow+0x240) [0x457370]
15: /usr/bin/X (DeleteWindow+0x2b) [0x4573cb]
16: /usr/bin/X (FreeClientResources+0xdc) [0x44ea4c]
17: /usr/bin/X (CloseDownClient+0x5a) [0x42f05a]
18: /usr/bin/X (0x400000+0x2fae7) [0x42fae7]
19: /usr/bin/X (0x400000+0x232fe) [0x4232fe]
20: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7f713f8ca30d]
21: /usr/bin/X (0x400000+0x235ed) [0x4235ed]
Segmentation fault at address (nil)"

the issue seems rather an nvidia driver one then a lightdm bug then...

affects: lightdm → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Shane L (torsten-berserker) wrote :

Having the exact same issue with fglrx driver via Additional Drivers in 12.04. Prior to installing the driver the problem was not existant.

dikkjo (dikkjo) wrote :

Hi everybody, I'm affected by this bug but I think the problem it's not related to the graphics drivers.
When I boot up my PC, during the BIOS phase my numlock key turns on, but as soon as grub pop up the numlock key turns off and from there it doesn't work anymore (also shiftlock, etc are not responding). When lightdm shows up still the control keys do nothing, then after lightdm restart everything returns to normal. Does anyone else experience the same problem with control keys?

kopiwe (kopiwe) wrote :

Not nvidia-graphics-drivers related. I have an Radeon HD6850 with fglrx drivers.

affects: nvidia-graphics-drivers (Ubuntu) → lightdm (Ubuntu)
kopiwe (kopiwe) wrote :

I have exactly the same bug. It also happens with a Radeon HD 6850 with fglrx drivers installed.

"1) There are some weird graphical artifacts near the top of the screen that change as I type in my password."
This happens to me aswell. Afther this, lightdm restarts or crashes with a black screen.

It also appears to be completely random, happens about 1/3 of the time I start up the computer.

Sidarth Dasari (sirsid) wrote :

I have nvidia graphics and I have this exact issue.
My pasted my lightdm.log here http://paste.ubuntu.com/1083887/

I find that just hittting enter at any point when the artifacts are present will cause lightdm to restart

Sidarth Dasari (sirsid) wrote :

Also, I noticed this error occurs even when autologin is enabled. The artifacts will remain at the top of the desktop, and the display crashes to the lightdm login screen if you press enter.
The issue only occurs about half the time

Loïc Favory (loic-favory) wrote :

I have the same bug whith NVIDIA [GeForce GTS 450] on ubuntu 12.04
Here is my lightdm.log : http://paste.ubuntu.com/1111624/

I use Nvidia Twinview with two samsung screens, the artifacts appear on the top left of my left screen.
I've got a black screen after the first log and it works nice after this.

Jorma Spitz (jormaspitz) wrote :

Same here... Doesn't matter if I do auto- or manual-login. First I thougt it's about hitting enter the first time, but it's not true. But it has to do something with the Keyboard. I just waited about 5 minutes bevore I touched Keyboard, and as soon as I start writeing it happend again...

lspci shows:
...
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1251 (rev a1)
...

Jorma Spitz (jormaspitz) wrote :

...but I don't have those weird graphical artifacts!

Ari Fogel (arifogel) wrote :

I have the exact same problem as the original poster. I am using Ubuntu 12.04 with nvidia proprietary binary drivers.

Ari Fogel (arifogel) wrote :

I should note that it MAY be nvidia related, since it does not happen when I use the open-source nouveau drivers.

gouki (tengyu) wrote :

I think this bug should relate to lightDM, after I switched to gdm, this bug gone and everything works fine.

And I have nvidia GTX460 video card with P67 motherboard(ASUS M4E)

eraserix (eraserix) wrote :

I don't have any artifacts, but lightdm (or X) crash on the first login try (successful or not). nvidia binary driver on ubuntu 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments