the upstart job is missing support for 'text' command

Bug #873334 reported by Nicolas Dechesne on 2011-10-13
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Medium
Unassigned
lightdm (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
plymouth (Ubuntu)
Low
Martin Pitt
Oneiric
Low
Unassigned

Bug Description

with gdm it was possible to add 'text' in the bootargs, and gdm.conf would detect that and would not start in this case. that was a convenient method to boot normally without the UI (at least on ARM platforms)

Sebastien Bacher (seb128) wrote :

Thank you for your bug reprot

That's how the issue was fixed in gdm by then:
http://bazaar.launchpad.net/~ubuntu-desktop/gdm/ubuntu/revision/99

We should probably apply that to the lightdm upstart job as well

Changed in lightdm (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
summary: - missing support for 'text' command
+ the upstart job is missing support for 'text' command
Changed in lightdm (Ubuntu Oneiric):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Nicolas Dechesne (ndec) wrote :

hum... i see. how can we have a non UI (e.g. single?) boot on ARM, then?

Sebastien Bacher (seb128) wrote :

Well, I don't say that we shouldn't fix it or add a "text" option, I'm just pointing it that we might need to be a bit smarted that the first commit I pointed there ;-)

Oliver Grawert (ogra) wrote :

looking at that gdm commit it simkly looks like an oversight that "text" isnt identical to single user mode at all.
i subscribed james so he can comment but i guess he didnt even remove the option to use "text" on cmdline on purpose, it just happened to be in the single user code chunk that was replaced.

Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

I put the updated lightdm upstart script into the packaging bzr. Upload to oneiric needs to wait for a bit, as there is another SRU currently being tested.

Changed in lightdm (Ubuntu Oneiric):
assignee: Martin Pitt (pitti) → nobody
Changed in lightdm (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Changed in plymouth (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Changed in lightdm (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: Triaged → Fix Committed
Changed in lightdm (Ubuntu Oneiric):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

I also put a corresponding fix into plymouth, to avoid keeping the plymouth splash around forever if "text" is given: http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/precise/plymouth/precise/revision/1412

Changed in plymouth (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
Changed in plymouth (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Low
Steve Langasek (vorlon) wrote :

Martin, I disagree with this change to the plymouth job and am reverting it. The changes to the lightdm job should take into account the need to stop plymouth even when booting with the 'text' option - the single user mode handling already does this, there's no reason text should be different.

BTW, the lightdm change could just as well be added to the if [ -n "$UPSTART_EVENTS" ] block, instead of creating a separate if [ -n "$JOB" ] block.

Changed in plymouth (Ubuntu):
status: Fix Committed → Invalid
Changed in plymouth (Ubuntu Oneiric):
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

Ah, thanks Steve, that's even easier.

Changed in lightdm (Ubuntu):
status: Fix Committed → In Progress
Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

lightdm fix updated in bzr.

Changed in lightdm (Ubuntu):
status: In Progress → Fix Committed
Changed in lightdm (Ubuntu Oneiric):
status: In Progress → Fix Committed

Hello Nicolas, or anyone else affected,

Accepted lightdm into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

Could you test if the fix work?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu2

---------------
lightdm (1.0.6-0ubuntu2) precise; urgency=low

  * Upload to precise.

lightdm (1.0.6-0ubuntu1) oneiric-proposed; urgency=low

  [ Martin Pitt ]
  * debian/lightdm.upstart: Put back check for "text" in kernel command line,
    for inhibiting automatic lightdm start. Check $JOB to still allow a manual
    "start lightdm" command to work. (LP: #873334)

  [ Robert Ancell ]
  * New upstream release:
    - Use lchown for correcting ownership of ~/.Xauthority instead of chown

lightdm (1.0.5-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    [1.0.5]
    - Relax AppArmor guest profile to allow compiz to start
    - Connect up VNC settings for width, height, depth
    [1.0.4]
    - Fix --enable-gtk-greeter=yes not working
    - Fix X sessions with arguments in Exec not working
    - Use previous session for automatic login or if greeter does not request
      one. (LP: #834515)
    - Correct ownership of ~/.Xauthority if upgrading from buggy version of
      LightDM that had it root owned. (LP: #871667)
    - Set default resolution of VNC to 1024x768, add settings for width, height,
      depth into lightdm.conf.
    - AppArmor profile: Fix broken gnome-keyring and dbus/gwibber, and quiesce
      annoying kernel audit messages for privileges that we definitively do not
      want to grant. (LP: #877736) (LP: #874635)
    - Set LOGNAME environment variable (LP: #875705)
    - Mark strings as translatable in GTK greeter (LP: #868613)
    [ 1.0.3]
    - Fix reference counting issue in ConsoleKit code
    - Really add the lightdm-guest-session-wrapper
    [ 1.0.2 ]
    - Fix daemon from blocking if Accounts Service does not exist
    - Fix greeter log file not being written
    - Don't set LANG environment variable if using Accounts Service.
    - Fix gdmflexiserver not working due to it not being in PATH
    - Don't authenticate the greeter user
    - Allow greeters to be disabled in configure flags
    - Fix over allocation of read buffer in greeter protocol
    - Make sure objects are cleaned up on exit
    - Fix minor memory leaks
    - Fix hugely oversized allocation in greeter buffer. Can trigger
      crashes when entering very long passwords.
  * debian/patches/00bzr_guest_session_wrapper.diff:
  * debian/patches/07_long_password_crash.patch:
  * debian/patches/08_correct_ck_ref.patch:
    - Applied upstream
  * New upstream release.
 -- Martin Pitt <email address hidden> Thu, 10 Nov 2011 07:19:12 +0100

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
Xavier Boudet (x-boudet) wrote :

Successfully tested on Panda Board.
Thanks

Martin Pitt (pitti) on 2011-11-10
tags: added: verification-donee
removed: verification-needed
tags: added: verification-done
removed: verification-donee
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu1

---------------
lightdm (1.0.6-0ubuntu1) oneiric-proposed; urgency=low

  [ Martin Pitt ]
  * debian/lightdm.upstart: Put back check for "text" in kernel command line,
    for inhibiting automatic lightdm start. Check $JOB to still allow a manual
    "start lightdm" command to work. (LP: #873334)

  [ Robert Ancell ]
  * New upstream release:
    - Use lchown for correcting ownership of ~/.Xauthority instead of chown

lightdm (1.0.5-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    [1.0.5]
    - Relax AppArmor guest profile to allow compiz to start
    - Connect up VNC settings for width, height, depth
    [1.0.4]
    - Fix --enable-gtk-greeter=yes not working
    - Fix X sessions with arguments in Exec not working
    - Use previous session for automatic login or if greeter does not request
      one. (LP: #834515)
    - Correct ownership of ~/.Xauthority if upgrading from buggy version of
      LightDM that had it root owned. (LP: #871667)
    - Set default resolution of VNC to 1024x768, add settings for width, height,
      depth into lightdm.conf.
    - AppArmor profile: Fix broken gnome-keyring and dbus/gwibber, and quiesce
      annoying kernel audit messages for privileges that we definitively do not
      want to grant. (LP: #877736) (LP: #874635)
    - Set LOGNAME environment variable (LP: #875705)
    - Mark strings as translatable in GTK greeter (LP: #868613)
    [ 1.0.3]
    - Fix reference counting issue in ConsoleKit code
    - Really add the lightdm-guest-session-wrapper
    [ 1.0.2 ]
    - Fix daemon from blocking if Accounts Service does not exist
    - Fix greeter log file not being written
    - Don't set LANG environment variable if using Accounts Service.
    - Fix gdmflexiserver not working due to it not being in PATH
    - Don't authenticate the greeter user
    - Allow greeters to be disabled in configure flags
    - Fix over allocation of read buffer in greeter protocol
    - Make sure objects are cleaned up on exit
    - Fix minor memory leaks
    - Fix hugely oversized allocation in greeter buffer. Can trigger
      crashes when entering very long passwords.
  * debian/patches/00bzr_guest_session_wrapper.diff:
  * debian/patches/07_long_password_crash.patch:
  * debian/patches/08_correct_ck_ref.patch:
    - Applied upstream
  * New upstream release.
 -- Robert Ancell <email address hidden> Wed, 02 Nov 2011 11:37:43 -0400

Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Fathi Boudra (fboudra) on 2013-06-07
Changed in linaro-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions