Ubuntu

Can't switch user from a locked screen (no gdmflexiserver binary in $PATH)

Reported by Chris Coulson on 2011-10-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Michael Terry
Oneiric
High
Michael Terry

Bug Description

It is not possible to switch user from the gnome-screensaver lock dialog when using lightdm. Although lightdm provides its own gdmflexiserver implementation, it's not in the default $PATH, so gnome-screensaver doesn't find it and hides the option to switch user.

Apparently, this was meant to be worked around by adding /usr/lib/lightdm to the default $PATH:

<seb128> mterry, hey
--> mdeslaur (~mdeslaur@ubuntu/member/mdeslaur) has joined #ubuntu-desktop
<seb128> mterry, do you have time for a lightdm bug today? ;-)
<mterry> seb128, sure
<seb128> mterry, the gdmflexiserver path hack still doesn't work...
 mterry, that breaks user switching on the lock screen
<mterry> seb128, guh
 seb128, bug number?
<seb128> I knew you were going to love that :p
 mterry, it was IRC reported but I can file a bug if you want
 let me check if there is one
<-- thisfred has quit (Quit: Ex-Chat)
<mterry> seb128, so to reproduce, I lock my screen and try to switch users?
<seb128> mterry, well basically you uninstall gdm or move its gdmflexiserver away, (restart gnome-screensaver?), then try to lock your screen
 mterry, you should get no "switch user" button
<-- mhr3 has quit (Quit: Ex-Chat)
<seb128> mterry, the code is basically looking if gdmflexiserver is in the path, but it's not
--> mhr3 (~<email address hidden>) has joined #ubuntu-desktop
<mterry> seb128, this is without lightdm?
<seb128> mterry, no, that's with lightdm
* mterry wonders why gdmflexiserver isn't in the path
<-- glatzor_ has quit (Ping timeout: 240 seconds)
--> thisfred (~<email address hidden>) has joined #ubuntu-desktop
<seb128> mterry, because lightdm install it in /usr/lib/lightdm and your path hack seems to not work (my guess)
 mterry, remember you added code to add /usr/lib/lightdm to the PATH
 which is somewhat hackish ;-)
<mterry> seb128, I remember. But it was working...
<seb128> well doing a "strings /proc/$(pidof gnome-session)/environ | grep PATH" shows it's not in the path
 mterry, yeah, I blame it on robert_ancell he probably broke it :p

Changed in lightdm (Ubuntu Oneiric):
importance: Undecided → High
status: New → Triaged
Martin Pitt (pitti) wrote :

lightdm (1.0.1-0ubuntu3) oneiric; urgency=low

  * debian/patches/05_gdmflexiserver_not_in_PATH.patch:
    - Make sure to insert our own utility path into PATH after PAM
      sets PATH, not before. This ensures gdmflexiserver is present
      in PATH and can be found by gnome-screensaver, gnome-shell, etc.

 -- Michael Terry <email address hidden> Wed, 05 Oct 2011 09:05:31 -0400

Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Michael Terry (mterry)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers