Language selector broken in Ubuntu

Bug #868346 reported by Gunnar Hjalmarsson on 2011-10-05
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
accountsservice (Ubuntu)
Medium
Gunnar Hjalmarsson
Oneiric
Medium
Unassigned
lightdm (Ubuntu)
Medium
Gunnar Hjalmarsson
Oneiric
Medium
Unassigned

Bug Description

If you enable the language selector in lightdm-gtk-greeter, the initial value is incorrectly based on the LANG environment variable instead of the current language, and whatever option you select, the session language is still the previously saved user language.

Gunnar Hjalmarsson (gunnarhj) wrote :

The linked proposed branch fixes the issue. I discussed the merge proposal with Martin Pitt on IRC, and we agreed that this bug is not release critical but appropriate for an Oneiric SRU.

In the meantime a lightdm version with the proposed fix is available in my PPA: https://launchpad.net/~gunnarhj/+archive/misc

Changed in lightdm (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
Changed in accountsservice (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: New → In Progress
summary: - Wrong initial value in language selector
+ Language selector broken in Ubuntu
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

A couple of weeks ago it was possible to use the language chooser, even if it was buggy. My original proposed branch fixed the most striking bug at the time. However, as a result of 04_dmrc_set_LANG_only.patch in 1.0.1-0ubuntu4, the language chooser in the LightDM version that was shipped with the 11.10 release can't be used in Ubuntu at all.

The updated MP results in a decent language chooser IMO. A build with the now proposed branch is available in my PPA to facilitate testing: https://launchpad.net/~gunnarhj/+archive/misc

In the proposed branch the language chooser is disabled by default. Considering the proposed improvements, I think it would be better if the chooser was enabled by default, so people would find it more easily. (Please note that we are only talking about lightdm-gtk-greeter, not the default LightDM greeter.)

The accountsservice MP makes the language options appear sorted. Besides suggesting that both the branches are merged and uploaded to Precise, in accordance with the previous discussion mentioned in comment #1 I suggest that they are also uploaded to lightdm-proposed and accountsservice-proposed in Oneiric.

Gunnar Hjalmarsson (gunnarhj) wrote :

The lightdm MP was just updated, since translations of the language chooser labels has been added to the branch.

Robert, I haven't tested on any non-Ubuntu platform, but I think this MP may well be applied upstream.

Martin Pitt (pitti) wrote :

I committed the accountsservice patch to debian git, so we can sync next time.

Changed in accountsservice (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Uploaded accountsservice to oneiric-proposed queue, as a prerequisite for the lightdm patch.

Changed in accountsservice (Ubuntu Oneiric):
status: New → Fix Committed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks, Martin!

Robert: We need your eyes on the lightdm MP. Or is there anybody else who might review it, if you are loaded with other things?

Sebastien Bacher (seb128) wrote :

Robert is away travelling until monday but I will ping him next week about that

Changed in accountsservice (Ubuntu):
importance: Undecided → Medium
Changed in accountsservice (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in lightdm (Ubuntu):
importance: Undecided → Medium
Changed in lightdm (Ubuntu Oneiric):
importance: Undecided → Medium

Hello Gunnar, or anyone else affected,

Accepted accountsservice into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I installed the amd64 build of the oneiric-proposed package. The list of language-options is now sorted, and it works as expected together with the lightdm branch.

Adolfo Jayme (fitojb) on 2011-10-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu Oneiric):
status: New → Confirmed
Fabián Rodríguez (magicfab) wrote :

I tested this in an updated VM:
- Added the PPA
- INstalled the lightdm-gtk-greeter package
- Applied updates
- Enabled the language selector in the configuration file (set show-language-selector=true in /etc/lightdm/lightdm-gtk-greeter.conf)

I still don't see the language selector in the login screen. I am not sure lightdm-gtk-greeter installation was enough to switch to it, am I missing something ?

Gunnar Hjalmarsson (gunnarhj) wrote :

Fabián,

Probably you also need to edit at the bottom of /etc/lightdm/lightdm.conf.

  #greeter-session=unity-greeter
  greeter-session=lightdm-gtk-greeter

If "Pre-released updates" is checked in Software Sources, and you applied updates after installing from my PPA, the binaries from PPA may have been overwritten. I have uploaded an updated source to PPA, and it's currently building.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.14-1git1ubuntu1

---------------
accountsservice (0.6.14-1git1ubuntu1) oneiric-proposed; urgency=low

  * debian/patches/0009-language-tools.patch:
    Sort the list of language options, which makes a difference for the
    language chooser in LightDM (LP: #868346).
 -- Gunnar Hjalmarsson <email address hidden> Thu, 20 Oct 2011 15:54:00 +0200

Changed in accountsservice (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu4

---------------
lightdm (1.0.6-0ubuntu4) precise; urgency=low

  [ Gunnar Hjalmarsson ]
  * debian/lightdm-gtk-greeter-ubuntu.conf and
    debian/patches/09_show_lang_chooser_option.patch:
    - Disclose the option to enable the language chooser.
  * debian/patches/10_available_languages.patch:
    - If available, show a list of installed translations in the
      language chooser instead of a 'locale -a' list (LP: #868346).
    - Use nl_langinfo() to get language and country names for the
      language chooser labels.
    - Translate language and country names.
    - Handle @variants properly.
  * debian/patches/11_set_language_in_accountsservice.patch:
    - Save item that is selected from the language chooser also when
      AccountsService is in use (LP: #868346).
 -- Robert Ancell <email address hidden> Tue, 22 Nov 2011 12:41:43 +1100

Changed in lightdm (Ubuntu):
status: In Progress → Fix Released
tags: added: verification-needed
removed: verification-done
Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Hello Gunnar, or anyone else affected,

Accepted lightdm into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Gunnar Hjalmarsson (gunnarhj) wrote :

I downloaded lightdm 1.0.6-0ubuntu1.2 from oneiric-proposed and installed and run it successfully.

Gunnar Hjalmarsson (gunnarhj) wrote :

The language selector in lightdm-gtk-greeter works fine now.

debian and ubuntu version of accountsservice are the same, can the Precise task be set to 'fix released' or is there a pending update ?

tags: added: verification-done
removed: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2011-11-24 09:24, Jean-Baptiste Lallement wrote:
> debian and ubuntu version of accountsservice are the same, can the
> Precise task be set to 'fix released' or is there a pending update ?

I think the latter is true.
http://anonscm.debian.org/gitweb/?p=collab-maint/accountsservice.git;a=commitdiff;h=549ce02e1dbc24d2ff7c95737062202c44f529e3

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.15-2

---------------
accountsservice (0.6.15-2) unstable; urgency=low

  [ Gunnar Hjalmarsson ]
  * 0009-language-tools.patch: Sort the list of language options, for the
    language chooser in LightDM (LP: #868346).

  [ Martin Pitt ]
  * 0002-create-and-manage-groups-like-on-a-ubuntu-system.patch: Use "sudo"
    group instead of "admin", for Debian/sudo compatibility. However, keep
    recognizing "admin" as administrator, too. (LP: #893842)
 -- Martin Pitt <email address hidden> Fri, 25 Nov 2011 08:28:18 +0100

Changed in accountsservice (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.0.6-0ubuntu1.2

---------------
lightdm (1.0.6-0ubuntu1.2) oneiric-proposed; urgency=low

  [ Gunnar Hjalmarsson ]
  * debian/lightdm-gtk-greeter-ubuntu.conf and
    debian/patches/09_show_lang_chooser_option.patch:
    - Disclose the option to enable the language chooser.
  * debian/patches/10_available_languages.patch:
    - If available, show a list of installed translations in the
      language chooser instead of a 'locale -a' list (LP: #868346).
    - Use nl_langinfo() to get language and country names for the
      language chooser labels.
    - Translate language and country names.
    - Handle @variants properly.
  * debian/patches/11_set_language_in_accountsservice.patch:
    - Save item that is selected from the language chooser also when
      AccountsService is in use (LP: #868346).
 -- Gunnar Hjalmarsson <email address hidden> Wed, 23 Nov 2011 12:15:03 +0100

Changed in lightdm (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in accountsservice (Ubuntu Oneiric):
assignee: nobody → emmanuel ngailo (ngailoemanuel)
Changed in accountsservice (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → emmanuel ngailo (ngailoemanuel)
Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → emmanuel ngailo (ngailoemanuel)
Changed in lightdm (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → emmanuel ngailo (ngailoemanuel)
Gunnar Hjalmarsson (gunnarhj) wrote :

Vandalism reverted.

Changed in accountsservice (Ubuntu):
assignee: emmanuel ngailo (ngailoemanuel) → Gunnar Hjalmarsson (gunnarhj)
Changed in accountsservice (Ubuntu Oneiric):
assignee: emmanuel ngailo (ngailoemanuel) → nobody
Changed in lightdm (Ubuntu):
assignee: emmanuel ngailo (ngailoemanuel) → Gunnar Hjalmarsson (gunnarhj)
Changed in lightdm (Ubuntu Oneiric):
assignee: emmanuel ngailo (ngailoemanuel) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers