Ubuntu

boot hangs waiting for lightdm after purging gdm (wrong default-display-manager)

Reported by Tuukka Hastrup on 2011-10-01
104
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
lightdm (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

I've installed Oneiric beta2 and at some point installed and purged gdm. After that, boot will hang waiting for lightdm to start, which never happens. This is because /etc/X11/default-display-manager ends up saying "lightdm" whereas /etc/init/lightdm.conf accepts "/usr/bin/lightdm" or "/usr/sbin/lightdm". The user sees the splash screen messages "Waiting for up to 60 more seconds for network configuration" and "Booting system without full network configuration".

However, the fix is to edit the contents of /etc/X11/default-display-manager to read "/usr/sbin/lightdm".

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 1.0.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Sat Oct 1 19:56:46 2011
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Tuukka Hastrup (tuukkah) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
MarkS (mark-marksyms) wrote :

Can confirm that the fix in the original bug report fixes things for me as well.

Changed in lightdm (Ubuntu):
importance: Undecided → High
summary: - boot hangs waiting for lightdm after purging gdm
+ boot hangs waiting for lightdm after purging gdm (wrong default-display-
+ manager)
Changed in lightdm (Ubuntu Oneiric):
milestone: none → ubuntu-11.10

I propose to change default display manager check as i described in comment #5 in bug #828576.
Thanks Tuukka Hastrup for pointing me to this bug.

Martin Pitt (pitti) wrote :

This doesn't seem all that easy to reproduce (i. e. getting into the state where /etc/X11/default-display-manager says just "lightdm")? Anyway, this is primarily an upgrade issue and does not affect a clean install, so it can be fixed in an SRU.

Changed in lightdm (Ubuntu Oneiric):
milestone: ubuntu-11.10 → none
Tuukka Hastrup (tuukkah) wrote :

Re #5 how to reproduce with a normal Ubuntu installation:
1. apt-get install gdm
2. Choose gdm as the default display manager when prompted.
3. apt-get remove gdm
4. cat /etc/X11/default-display-manager

This should just say "lightdm" and following boots should fail until the file content is changed to "/usr/sbin/lightdm".

Jaakan Shorter (jaakanshorter) wrote :

Upgrading from Mythbuntu 11.04 to 11.10 x64 is the easiest way to reproduce this bug, since lightdm is now the default.

I love it when a fix is so simple...

Kim d'Audretsch (kimda) wrote :

Thank you Tuukka. I've had the same problem with lightdm not loading and had to drop to a shell to start lightdm manually until I found this solution.

Sebastien Bacher (seb128) wrote :

So it seems gdm is buggy there, the prerm sets the default to "lightdm" rather the to "/usr/sbin/lightm", lightdm has a similar bug since its script is copied from gdm...

Changed in gdm (Ubuntu Oneiric):
importance: Undecided → High
Changed in gdm (Ubuntu):
importance: Undecided → High
Changed in gdm (Ubuntu Oneiric):
status: New → Incomplete
Changed in gdm (Ubuntu):
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Confirmed
Changed in gdm (Ubuntu Oneiric):
status: Incomplete → Confirmed
status: Confirmed → Triaged
Changed in gdm (Ubuntu):
status: Confirmed → Triaged
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Triaged
Robert Ancell (robert-ancell) wrote :

Won't fix for Oneiric as the risk of changing the scripts is too high and the type of users hitting this bug can probably fix it manually. The fix will be to copy the scripts from KDM and XDM which handle uninstalls correctly.

Changed in gdm (Ubuntu Oneiric):
status: Triaged → Invalid
Changed in lightdm (Ubuntu Oneiric):
status: Triaged → Invalid
Changed in gdm (Ubuntu Oneiric):
status: Invalid → Won't Fix
Changed in lightdm (Ubuntu Oneiric):
status: Invalid → Won't Fix
Robert Ancell (robert-ancell) wrote :

What exactly happens:

In GDM, when uninstalling it sets /etc/X11/default-display-manager to the first available display manager *package name*. It should set it to the full path to the display manager executable.

In LightDM, when uninstalling it doesn't change /etc/X11/default-display-manager, so it is set to "/usr/sbin/lightdm" which is no longer installed. It should set it to the full path to the first available display manager executable.

Id2ndR (id2ndr) wrote :

In saucy lightdm should depend on a greater like lightdm-gtk-greeter for example: uninstalling lightdm and installing ubuntu-desktop meta-package made DM end just after showing the cursor.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions