Ubuntu

random login without common admin user permissions

Reported by Doug McMahon on 2011-09-30
72
This bug affects 10 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Critical
Robert Ancell

Bug Description

This has shown up starting with daily from 09/27 where happened often, currently on install using daily from 0/29 updated where it happened just once so far out of 6 or so restarts

Symptoms are:
synaptic will fail to start from desktop icon
nm-applet fails to start, shows no connection (but i am connected
external drives can't be mounted
a restart and or shutdown from session indicator will fail
update-manager will not check for updates
In all the above I have no permission to do so

~/.xession-errors is owned by root - attached

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Fri Sep 30 02:52:25 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110929)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

Had to copy out .xsession -errors, couldn't attach directly, no permission?
-rw------- 1 root root 28457 2011-09-30 03:07 /home/doug/.xsession-errors

description: updated
Sebastien Bacher (seb128) wrote :

thank you for your bug report but that's not a gsd issue, maybe a lightdm one?

affects: gnome-settings-daemon (Ubuntu) → lightdm (Ubuntu)
Doug McMahon (mc3man) wrote :

I think it is lightdm , the root owned ~/.xsession-errors points there.

While very prevalent on 09.27 image, have only seen once early in a 09.29 install & never on a 09.30 so am going to mark invalid, will reopen if it starts up again

Changed in lightdm (Ubuntu):
status: New → Invalid
Doug McMahon (mc3man) on 2011-10-01
Changed in lightdm (Ubuntu):
status: Invalid → New
Doug McMahon (mc3man) wrote :

Got this once today on a 09/30 install, can't find a way to duplicate yet
Am attaching .xsession, similar to previous one except I own this one

Doug McMahon (mc3man) wrote :

This was not fixed with the new lightdm

May be related to this error - bug 865858
  am going to try with packages as mentioned here Bug 865358

Also to note - this never occurs with gdm as the DM

Doug McMahon (mc3man) wrote :

While it took several restarts same thing with the packages from raof, though in this case a new crasher - _sbin_plymouthhd.0 though same ssymptons
Am attaching xsession-errors

Sebastien Bacher (seb128) wrote :

could you add your lightdm.conf log?

Doug McMahon (mc3man) wrote :

I see a lightdm.conf file & a lightdm.log, no lightdm.conf log, will attach log

Doug McMahon (mc3man) wrote :

Also can get in a unity-2d login, attaching xsession

Doug McMahon (mc3man) wrote :

For comparison a lightdm.log on a good login (unity3d

Sebastien Bacher (seb128) wrote :

yeah, sorry it was a typo, lightdm.log is the right one

Doug McMahon (mc3man) wrote :

Maybe just here/, though I've seen others report some of the symptoms & there is the check_gl_texture_size crashed with SIGSEGV in __libc_start_main() crash which usually accompanies this when using the current gnome-desktop packages
The roaf packages prevent the crash but not this bug

To see I downgraded the raof packages, gnome-desktop3-data ; libgnome-desktop-3-2 & waited for a re-occurrence
Over the course of 2 hrs of normal use did an occasional log out/in and or restart
Eventually the crash happened though did take quite some time

With the repo gnome-desktop packages when this occurred the check_gl crash was logged - screen will show
To note on screen the user menu is missing & if I was using nm-applet it would show no connection available
All the other effects/symptoms are also as orig. reported

Doug McMahon (mc3man) wrote :

I see there is another new lightdm today, lightdm (1.0.0-0ubuntu4) to 1.0.1-0ubuntu1 will give it a try and maybe a fresh install with tomorrows image

Doug McMahon (mc3man) wrote :

New lightdm, same thing, only took a couple of logouts. Also in screen meant to mention the date/time is also missing

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Robert, could you look if the logs are useful, it seems similar to bug #851345

Changed in lightdm (Ubuntu):
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

The logs don't show anything unexpected, but it does appear to have the same symptoms as in bug 851345. Doug, can you check if the lightdm process is running after the problem occurs and if dmesg shows it has crashed?

Doug McMahon (mc3man) wrote :

Will attach the requested info - lightdm is running, just not 'for me'

Doug McMahon (mc3man) wrote :

dmesg shows no crash - only lightdm entry -
[ 15.847591] type=1400 audit(1317875553.504:16): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm-guest-session-wrapper" pid=926 comm="apparmor_parser"

I can basically tell this is going to ocuur when from login screen instead of a couple of sec.s to desktop I get 3 or 4 flashes of the screen, then the desktop as described

Am wondering if this just may be some issue with my hardware, local or in general? Asking because have seen very few reports of similar behavior
This has been seen with fresh installs starting with images of the 27th, continuing with 29th, 02th, & 04th. Previous to that no problems for whole dev.

Doug McMahon (mc3man) wrote :

Ignore that comment about "for me", my ignorance, didn't recollect seeing rooot for lightdm in ps before
Anyway here is what's running on a good login -

root 967 0.2 0.1 41188 3808 ? Ssl 00:59 0:00 lightdm
root 1022 6.2 1.2 55140 38932 tty7 Ss+ 00:59 0:02 /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
lightdm 1366 0.2 0.1 98096 4952 ? S<l 00:59 0:00 /usr/bin/pulseaudio --start --log-target=syslog
lightdm 1389 0.0 0.0 13292 2560 ? S 00:59 0:00 /usr/lib/pulseaudio/pulse/gconf-helper
doug 1808 0.0 0.0 4448 804 pts/0 S+ 01:00 0:00 grep --color=auto lightdm

Doug McMahon (mc3man) wrote :

I guess now that I opened my eyes that when this happens lightdm isn't running, just X, sorry about the excess comments...

Omer Akram (om26er) wrote :

Me too I can reproduce it on two different machines.. the session this problem happens also does not have the sound, alt+sysrq+k will fully halt the system that session + the above started problems, its critical IMO.

Changed in lightdm (Ubuntu):
milestone: none → ubuntu-11.10
importance: High → Critical
Doug McMahon (mc3man) wrote :

I'm almost 100% sure this started with the ubuntu upgrade from lightdm (0.9.7-0ubuntu1)to lightdm (1.0.0-0ubuntu1)
running the 0.9.7 (w/ it's dep of plymouth (0.8.2-2ubuntu26) 1/2 of a day here - no occurrences yet

Doug McMahon (mc3man) wrote :

As an update Here -
While this occurred with some degree of regularity with installs from 09//27, 09/29. 10/02. & 10/04 with lightdm but not gdm,
- on a fresh 10/09 install it has not
I've used it more than enough in various ways to feel that it quite likely will not re-occur
Anyone else who was seeing this may want to try a current image and or the release this week & see how they fare

description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers