greeter doesn't start "failed to load session file"

Bug #842194 reported by Martin Pool on 2011-09-05
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Low
Unassigned

Bug Description

As of today, lightdm on oneiric doesn't show a login screen. I have verified the greeters are installed so this is different to bug 816646. The most likely lines in the log seem to be

  Failed to load session file /usr/share/xgreeters/.desktop: No such file or directory
  Failed to start greeter
  Stopping display

I'm just left at a text screen with various stair-stepped log messages.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 0.9.3-0ubuntu8
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Tue Sep 6 08:32:54 2011
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
SourcePackage: lightdm
UpgradeStatus: Upgraded to oneiric on 2011-08-23 (12 days ago)

Martin Pool (mbp) wrote :
Martin Pool (mbp) wrote :

ok, installing unity-greeter seems to have got it going.

Sebastien Bacher (seb128) wrote :

seems similar to bug #850941

Robert Ancell (robert-ancell) wrote :

In this case lightdm should quit, and the failsafe X mechanisms should kick in (i.e. fix your configuration).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

There's the case for picking an available greeter so you always get something, though this must be an external policy to lightdm as different greeters might have different security levels. If we change lightdm in Ubuntu to load the "default" greeter, then the packaging system can control which greeter this is with a symlink.

Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Matt C (proteus400) wrote :

Use case:
Installing Ubuntu onto a Samsung Large screen TV with embedded PC, 2.5GB flash disk only (not big enough for full Ubuntu 11.10).

Installed from ubuntu minimal, installed ubuntu-standard and ubuntu-desktop with --no-install-recommends (due to lack of disk space on this device).

lightdm doesn't start, vt.handoff=7 splash cause the user to experience a blank screen with 'no signal' on boot.

Log shows:
   DEBUG: Failed to load session file /usr/share/xgreeters/lightdm-gtk-greeter.desktop: No such file or directory;
   DEBUG: Failed to start greeter

Had to install unity-greeter package manually. Then it all works.

Is this a recommended package that should be a required package?

tags: added: quantal
Benjamin Schmid (benbuntu) wrote :

Same issue here with on upgraded quantal from precise lubuntu-core install. Suddenly stopped working. Reinstall of lightdm-gtk-greeter or webkit-greeter does not help. I resorted myself into installing gdm as an addon replacement for lightdm as I was unable to spot root source of this problem.

Pavel (ppv) wrote :

Installing Precise from debootstrap, then kubuntu-desktop with APT::Install-Recommends "false"; then lightdm, lightdm-kde-greeter, xorg, linux-image-generic causes the similar problem with lightdm.
[+0.21s] DEBUG: Failed to load session file /usr/share/xgreeters/default.desktop: No such file or directory
In /usr/share/xgreeters I have lightdm-kde-greeter.desktop but the file /etc/lightdm/lightdm.conf does not exist! I will have to create it manually and to write there something like:
"[SeatDefaults]
greeter-session=lightdm-gtk-greeter"
I think it should solve the problem.
It is interesting that there is no package owns the /etc/lightdm/lightdm.conf file (if is has been generated automatically). Why is it created when recommends installation is switched on and has not been created automatically during the installation without recommends? What is responsible for generating the /etc/lightdm/lightdm.conf file?

Pavel (ppv) wrote :

The file /etc/lightdm/ligtdm.conf is being created while running postinst script from lightdm-{kde,gtk}-greeter package. The script needs the /usr/lib/lightdm/lightdm-set-defaults binary. This binary is owned by lightdm package so it is necessary to install lightdm package before or at the same time with lightdm-{kde,gtk}-greeter. If lightdm package was installed after one of the lightdm-greeter packages, you may run "dpkg-reconfigure lightdm-kde-greeter" or "dpkg-reconfigure lightdm-gtk-greeter" (depending on the greeter package you have installed) to generate the proper /etc/lightdm/ligtdm.conf file. This method helped me to solve the problem.

Robert Ancell (robert-ancell) wrote :

Modifying /etc/lightdm/lightdm.conf from packages and/or using lightdm-set-defaults was the old method of configuring greeters.

All packages should now install a configuration snippet into /usr/share/lightdm/lightdm.conf.d/ - this ensures the configuration always matches what is installed.

Only sysadmin specific overrides should be in /etc/lightdm/lightdm.conf and /etc/lightdm/lightdm.conf.d/ - if you did not create this file yourself it should be deleted.

Changed in lightdm (Ubuntu):
status: Triaged → Fix Released
Robert Ancell (robert-ancell) wrote :

Closing this bug. While you can always generate invalid configuration the conf.d support means this should not be possible without specific modification by a sysadmin. If invalid configuration occurs the correct behaviour is for lightdm to exit with error and a system level tool to handle this (i.e. warn / prompt the user to fix the configuration).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers