Oneiric live CD boots to login screen

Bug #819609 reported by Erick Brunzell on 2011-08-02
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
lightdm (Ubuntu)
High
Canonical Desktop Team
Oneiric
High
Canonical Desktop Team

Bug Description

I'm testing the Oneiric Alpha3 release candidate (20110801-i386) and find that the live CD always boots to the login screen displaying either Guest or other. The user must select other, then type ubuntu, press enter, then leave password blank and press enter again.

I was unsure as whether to file this against lightdm or casper so I guessed :^)

BTW this behavior is consistent whether I boot from the hidden boot menu selecting Try Ubuntu or if I let the boot menu pass and just select Try Ubuntu from the standard menu.

Minor issue to be sure but I know from experience that some users will not be aware how to boot the live desktop.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 0.9.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
CasperVersion: 1.272
Date: Tue Aug 2 03:29:45 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110801)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Erick Brunzell (lbsolost) wrote :
tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

As far as instructing someone how to login this is better than the above:

Select other, then type ubuntu, then click on login, leave the password blank and click on login again.

That's more consistent than using the enter key.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

IMHO we could just mention this in the release notes for Alpha 3.

Paolo Rotolo (paolorotolo) wrote :

I can confirm this bug on Ubuntu, Xubuntu and Mythbuntu Alpha 3.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

It looks like a regression of bug 797669

tags: added: regression-release
Changed in lightdm (Ubuntu):
importance: Undecided → High
Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Jean-Baptiste Lallement (jibel) wrote :

The file /etc/lightdm/lightdm.conf is not created.

Changed in lightdm (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Confirmed → Triaged
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in casper (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.273

---------------
casper (1.273) oneiric; urgency=low

  [ Mario Limonciello ]
  * scripts/casper: Add support for SAS controllers now that 575297 is fixed.
    (LP: #819564)

  [ Stéphane Graber ]
  * lightdm no longer ships with /etc/lightdm/lightdm.conf in its package.
    Updating 15autologin casper hook to create one when missing. (LP: #819609)
 -- Stephane Graber <email address hidden> Tue, 02 Aug 2011 17:47:10 -0400

Changed in casper (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in lightdm (Ubuntu Oneiric):
status: Triaged → Invalid
Paolo Sammicheli (xdatap1) wrote :

Confirmed. It's solved in Ubuntu Desktop i386 (20110803) image

Charlie Kravetz (charlie-tca) wrote :

This bug really is not fixed for Xubuntu. Due to numerous issues with configuration files for lightdm, there is no standard at this time. bug #799754 has not been resolved and Xubuntu live session will not auto-login as of 2011-08-03.2 desktop images.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in lightdm (Ubuntu Oneiric):
status: Invalid → Triaged

I'm closing this report as the main problem is fixed for Ubuntu but still remains in derivatives. This is tracked in LP: #819624

Changed in lightdm (Ubuntu Oneiric):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers