Ubuntu

lightdm doesn't use gnome-settings-daemon system xrandr configurations

Reported by Sébastien Bernard on 2011-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
lightdm (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
unity-greeter (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

I'm using my 24" screen in portrait mode (rotate left 90). I used the use as default on gnome screen panel to make the rotation permanent.
gdm the information ok. lightdm does not and present the greeting screen in landscape mode.
kdm fails too to retain the correct screen orientation.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 0.4.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-4.5-generic 3.0.0-rc6
Uname: Linux 3.0.0-4-generic x86_64
Architecture: amd64
Date: Mon Jul 18 10:28:54 2011
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Sébastien Bernard (sbernard) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's because the lightdm greeter doesn't use gnome-settings-daemon

Changed in lightdm (Ubuntu):
importance: Undecided → Wishlist
summary: - lightdm fails to retain xrand information
+ lightdm doesn't use gnome-settings-daemon system xrandr configurations
Changed in lightdm (Ubuntu):
status: New → Confirmed
importance: Wishlist → Low
Changed in lightdm:
status: New → Confirmed
Changed in unity-greeter (Ubuntu Oneiric):
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

unity-greeter (0.0.2-0ubuntu4) oneiric; urgency=low

  * debian/patches/update_to_trunk.patch: updated to current trunk
    - tweaks to the greeter interface
    - use gnome-settings-daemon with a limited of options
    - doesn't start gvfs on the greeter

Changed in unity-greeter (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Robert Ancell (robert-ancell) wrote :

Closing the lightdm components of this bug as invalid as this is the responsibility of the greeter.

Changed in lightdm:
status: Confirmed → Invalid
Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers