Lightdm don't ask password if select user by mouse click or pressing Enter key.

Bug #811524 reported by Dmitry Marin on 2011-07-16
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Critical
Unassigned

Bug Description

If select "other..." and mannually type username all ok.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 0.4.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic i686
Architecture: i386
Date: Sat Jul 16 17:58:51 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcEnviron:
 PATH=(custom, user)
 LANG=ru_RU.utf8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: Upgraded to oneiric on 2011-07-03 (13 days ago)

Dmitry Marin (corvax-corvax) wrote :
Till Kamppeter (till-kamppeter) wrote :

I have the problem, too. After clicking my user name the user selection window disappears and lightdm freezes showning only the background image. This requires switching to a text console for stopping lightdm and then starting gdm:

sudo stop lightdm
sudo start gdm

Probably one could also start lightdm again at this point and then manually enter user name and password via "Other ..." as the original poster tells.

Changed in lightdm (Ubuntu):
importance: Undecided → High
importance: High → Critical
milestone: none → oneiric-alpha-3
Mauricio Pretto (pretto) wrote :

I just installed OO today daily-live 20110719 x64 and have the same problem report on comment #2
select my user (no password asked) start loading the systems but never get a interface

Mauricio Pretto (pretto) wrote :

I have installed gdm, and I have the same problem

ok. this problem is solved if you install unity-greeter and use greeter-theme=unity in lightdm.conf

Mauricio, did you set gdm as your default manager? if not use in a terminal dpkg-reconfigure gdm

Till Kamppeter (till-kamppeter) wrote :

joaquin miranda iglesias rábade, I tried what you have written in comment #5 (unity-greeter), but it does not work for me. lightdm behaves as before, not asking for the password.

did you remove the # in lightdm.conf?

im sorry, the # in greeter-theme=unity ? (in lightdm.conf) *

Yes, it has a line containing only

default-greeter-theme=unity

without #.

Works now.

I have now a line

greeter-theme=unity

So default-greeter-theme is broken, as this should define the greeter theme if there is no active greeter-theme entry.

The login screen looks great now!

yep, it is the greeter-theme line that you have to uncomment. I'm glad it worked for you. the login screen need some improvement, but is really great!

Changed in lightdm (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2011-08-01
Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers