After xubuntu upgrade or installation, default session on greeter must be xubuntu

Bug #806408 reported by Jean-Baptiste Lallement on 2011-07-06
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Medium
Unassigned
xubuntu-default-settings (Ubuntu)
Medium
Xubuntu Developers

Bug Description

upgrade from up to date Xubuntu 11.04 to 11.10 on AMD64

The upgrade went fine, but after reboot and logging in, the session doesn't start.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 0.4.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic x86_64
Architecture: amd64
Date: Wed Jul 6 12:34:25 2011
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: Upgraded to oneiric on 2011-07-06 (0 days ago)

WORKAROUND:
Users must select a session when logging in the first time. If no session is selected, the user will see the Ubuntu wallpaper, and nothing else. In this case, go to a tty using Ctrl+Alt+F2, login, and type

sudo service lightdm restart

Now the user can login again, and select the session.

Jean-Baptiste Lallement (jibel) wrote :
tags: added: iso-testing
Changed in lightdm (Ubuntu):
importance: Undecided → High
assignee: nobody → Xubuntu Developers (xubuntu-dev)
Jean-Baptiste Lallement (jibel) wrote :

lighdm logs, syslog and Xorg log

Jean-Baptiste Lallement (jibel) wrote :

last lines of the lightdm log
+14.76s] DEBUG: Greeter start session gnome
[+14.76s] DEBUG: Preparing 'gnome' session for user ubuntu
[+14.76s] WARNING: Failed to load session file : No such file or directory:
[+15.22s] DEBUG: Process 1075 closed communication channel
[+15.22s] DEBUG: Process 1075 exited with return value 0
[+15.22s] DEBUG: Greeter quit
[+15.22s] DEBUG: pam_close_session -> System error
[+15.22s] DEBUG: pam_setcred(PAM_DELETE_CRED) -> System error
[+15.22s] DEBUG: Ending ConsoleKit session 0ea4e853e8c337893cd244ea00000004-1309951768.416550-747441001

Lionel Le Folgoc (mrpouit) wrote :

> [+14.76s] DEBUG: Preparing 'gnome' session for user ubuntu
> [+14.76s] WARNING: Failed to load session file : No such file or directory:

Is it really the correct log file? Because it seems lightdm tried to launch a gnome session, which of course doesn't exist...

Jean-Baptiste Lallement (jibel) wrote :

Yes it is.

Jean-Baptiste Lallement (jibel) wrote :

And if I switch to gdm instead of lightdm it starts a Xubuntu session.

Jean-Baptiste Lallement (jibel) wrote :

Actually, the entry selected on the greeter has no label and I didn't notice that xubuntu was not selected by default. The session starts fine if xubuntu is selected.

Lowering importance.

Changed in lightdm (Ubuntu):
importance: High → Medium
status: New → Confirmed
summary: - Xubuntu session doesn't start after upgrade to 11.10
+ After xubuntu upgrade, default session on greeter must be xubuntu
Charlie Kravetz (charlie-tca) wrote :

This also occurrs on every installation, both i386 and amd64. If the user does not select Xubuntu Session at first login, the user is given a blank Ubuntu wallpaper and can not do anything. They must then go to a tty and login, restart lightdm, login again, and choose a session.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

summary: - After xubuntu upgrade, default session on greeter must be xubuntu
+ After xubuntu upgrade or installation, default session on greeter must
+ be xubuntu
description: updated
Lionel Le Folgoc (mrpouit) wrote :

Until Bug #799754 is fixed, I can't override the default config with the xubuntu one, and set the xubuntu session by default.

Changed in lightdm (Ubuntu):
assignee: Xubuntu Developers (xubuntu-dev) → nobody
Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in xubuntu-default-settings (Ubuntu):
assignee: nobody → Xubuntu Developers (xubuntu-dev)
Sebastien Bacher (seb128) wrote :

is that fixed with:

" [ Didier Roche ]
  * Cherry-pick from upstream:
    - lightdm-set-defaults enables tweaking the default session and chosen
      greeter for lightdm. This is useful for derivatives waiting to not ship
      the whole configuration file of lightdm
    - refreshed translations"

?

Charlie Kravetz (charlie-tca) wrote :

It is not fixed on the images dated 2011-08-12. The session defaults to Xfce, and it still takes 12 steps to reset so the user can try to get logged into the correct Xubuntu session.

Charlie Kravetz (charlie-tca) wrote :

This is now fixed with the images dated 2011-08-14. Thanks for fixing this annoying bug.

Changed in xubuntu-default-settings (Ubuntu):
status: Triaged → Fix Released
Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers