lightdm needs something like gdm-set-default-session

Bug #806064 reported by Stéphane Graber on 2011-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Didier Roche
Oneiric
High
Didier Roche

Bug Description

Some derivatives like Edubuntu allow users to choose what default session they want to use.

For Edubuntu 11.10 we'll ship with unity by default but ask the user if they want to use the "fallback gnome session" as their default session (so they get something similar to a gnome 2.x ).

Our packages currently call gdm-set-default-session (a tool written by Didier Roche) to change the default session and properly revert it once the package is removed.

Not having it in lightdm breaks one of Edubuntu's install path so it's critical we get it back by the next alpha or we'll have to switch back to gdm (I'd really like to avoid that option ...).

Thanks

Changed in lightdm (Ubuntu Oneiric):
importance: Undecided → High
milestone: none → oneiric-alpha-3
Martin Pitt (pitti) on 2011-07-15
Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in lightdm (Ubuntu Oneiric):
importance: High → Critical
importance: Critical → High
Martin Pitt (pitti) wrote :

Just discussed on IRC. Summary:

 - We'll make the internal defaults DTRT, and not ship with any conffile
 - xubuntu-default-settings can then ship their own /etc/lightdm/lightdm.conf, preferably as a non-conffile though.
 - Default session can be set with providing a /usr/share/xsessions/default.desktop symlink instead of a configuration file. This was originally agreed in https://launchpad.net/ubuntu/+spec/desktop-o-cd-localization as a way to circumvent changing the conffile, but if it's not going to be a conffile any more, this is not actually required any more. It would still be nice to have for desktop-o-cd-localization, as the default.desktop symlink can also be implemented in gdm.

Martin Pitt (pitti) wrote :

This is now pretty much a duplicate of bug 799754.

Changed in lightdm (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
tags: added: iso-testing
Changed in lightdm (Ubuntu Oneiric):
assignee: Robert Ancell (robert-ancell) → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

This is fixed in 0.9.3-0ubuntu2

Changed in lightdm (Ubuntu Oneiric):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers