Sources Xsession.d but doesn't setup required env vars

Bug #800192 reported by Loïc Minier on 2011-06-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: lightdm

hey

ssh-agent wasn't started for me anymore, this was because Xsession.d scripts couldn't source OPTIONFILE=/etc/X11/Xsession.options because it wasn't set in the environment.

As a workaround, I've added the above to my ~/.xprofile.

Cheers,

papukaija (papukaija) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 798277, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in lightdm (Ubuntu):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 0.4.0-0ubuntu6

---------------
lightdm (0.4.0-0ubuntu6) oneiric; urgency=low

  * debian/Xsession:
    - Set required variables to make Xsession.d scripts work (LP: #800192)
 -- Robert Ancell <email address hidden> Mon, 27 Jun 2011 00:03:12 +1000

Changed in lightdm (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers