lightdm crashed with SIGSEGV in g_main_context_dispatch()

Bug #795050 reported by berg on 2011-06-09
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: lightdm

After updates yesterday I got this problem.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: lightdm 0.3.7-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic-pae 2.6.39
Uname: Linux 2.6.39-3-generic-pae i686
Architecture: i386
Date: Thu Jun 9 10:40:58 2011
ExecutablePath: /usr/bin/lightdm
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427)
ProcCmdline: lightdm
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 PATH=(custom, no user)
 LANG=pt_BR.UTF-8
SegvAnalysis:
 Segfault happened at: 0x804bb73: mov 0x20(%eax),%eax
 PC (0x0804bb73) ok
 source "0x20(%eax)" (0xaaaaaaca) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: lightdm
StacktraceTop:
 ?? ()
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: lightdm crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: Upgraded to oneiric on 2011-06-08 (1 days ago)
UserGroups: disk

berg (berg-foss) wrote :
visibility: private → public
Jean-Baptiste Lallement (jibel) wrote :

I confirm this issue on an up to date Oneiric. I got bug 795062 at the same time.

Changed in lightdm (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

I have not experienced the crash described here, but I have experienced a similar crash on login after selecting lightdm over gdm during yesterday's update (lightdm crashed with SIGSEGV in g_child_watch_dispatch()), which I reported as bug 795324. That bug is currently private. (Since it is a crash in a display manager, which implements a login screen, I am concerned about disclosure of sensitive information.)

I wonder if my bug 795324 is actually a duplicate of Jean-Baptiste Lallement's (inaccessible to me, thus presumably private) bug 795062. I have subscribed him to bug 795324 so he can determine this.

Robert Ancell (robert-ancell) wrote :

I can't follow any of these bug links, they're all page not found. weird
bug 795323 exists
bug 795324 is page not found
bug 795325 exists

@Robert Ancell
I think 404 (page not found) errors are normal for private bugs to which one doesn't have access, these days. See bug 434733 in Launchpad itself. I'd like to keep bug 795324 private until there is good reason to think it doesn't contain sensitive login information from my machine (at least CoreDump.gz would have to be processed and removed first, I think). But I have just subscribed you to it, so you should be able to access it now. If you still can't access the page, please let me know, and I'll look into it further. As for bug 795062, I can't subscribe you to it (or even access it myself), as it's Jean-Baptiste Lallement's presumably private bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 0.3.7-0ubuntu2

---------------
lightdm (0.3.7-0ubuntu2) oneiric; urgency=low

  * debian/control:
    - Add ${python:Depends} and required dependencies for
      lightdm-greeter-example-python-gtk package (LP: #787409)
  * debian/patches/01_handle_all_signals.patch:
    - Correctly handle signals from external processes (LP: #789389)
  * debian/patches/02_process_exit.patch:
    - Fix crash when child processes quit (LP: #795050)
 -- Robert Ancell <email address hidden> Fri, 10 Jun 2011 16:24:56 +1000

Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
Robert Ancell (robert-ancell) wrote :

OK, I think I have a fix for this. I've pushed it to Oneiric. If you want to test faster:
$ debcheckout lightdm
$ cd lightdm
$ bzr-buildpackage
$ sudo dpkg -i ../*0.3.7-0ubuntu2*.deb

I think it's an existing bug that got made worse with a recent glib change.

I had mentioned two bugs in https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/795050/comments/4. There is now more information about both.

Bug 795324 is now public, and still occurs with lightdm 0.3.7-0ubuntu2 (see https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/795324/comments/5 and bug 795324's private duplicate bug 796521). Consequently, bug 795324 is apparently different from this bug, as this bug is now fixed.

Jean-Baptiste Lallement's bug 795062, which is also now public and clearly separate from bug 795324, is also separate from this bug (it's a crash in gnome-power-manager, not lightdm itself), though potentially related since it occurs with lightdm as the display manager, but not with gdm as the display manager. However, even if the fixes recently introduced to lightdm have stopped that crash from occurring, I think it still indicates a flaw somewhere in gnome-power-manager which should be investigated and fixed if possible.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers