xauth broken after logging in with lightdm

Bug #795046 reported by Scott Moser on 2011-06-09
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Medium
Unassigned
lightdm (Ubuntu)
Medium
Robert Ancell
Oneiric
Medium
Robert Ancell

Bug Description

Binary package hint: lightdm

After logging in with lightdm, xauth dies like:
xauth: timeout in locking authority file /var/run/lightdm/authority/2

strace of xauth shows:
open("/var/run/lightdm/authority/2-c", O_WRONLY|O_CREAT|O_EXCL, 0600) = -1 EACCES (Permission denied)
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
nanosleep({2, 0}, 0x7fff144a1270)

$ sudo sh -c 'find /var/run/lightdm | xargs ls -ld'
drwx--x--x 3 root root 60 2011-06-09 00:42 /var/run/lightdm
drwx--x--x 2 root root 80 2011-06-09 09:43 /var/run/lightdm/authority
-rw------- 1 root root 44 2011-06-09 09:42 /var/run/lightdm/authority/0
-rw------- 1 smoser smoser 44 2011-06-09 09:43 /var/run/lightdm/authority/2

I don't think it matters, but I'm unable to login with "Ubuntu", so I selected "recovery-console" in the lightdm session menu for this test. The problem also occurs when selecting "sawfish" (those are the only 2 I tried).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: lightdm 0.3.7-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
Architecture: amd64
Date: Thu Jun 9 09:40:42 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: Upgraded to oneiric on 2010-11-15 (205 days ago)

Scott Moser (smoser) wrote :
Robert Ancell (robert-ancell) wrote :

Interesting, it appears xauth is trying to write into /var/run/lightdm/authority/, which does not have write permissions for non root (for obvious reasons). So this might be seen as a bug in xauth. See bug 685194 for the request to be able to use ~/.Xauthority as an authority file which would bypass this issue.

Changed in lightdm (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in lightdm:
importance: Undecided → Medium
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
Changed in lightdm:
status: New → Triaged
Robert Ancell (robert-ancell) wrote :

Looking at xauth in GDM it writes into /var/run/gdm/auth-for-USER-HASH/, so another option is to put the auth files in a writable directory.

tags: added: iso-testing
Martin Pitt (pitti) on 2011-07-08
Changed in lightdm (Ubuntu Oneiric):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Fixed in 0.4.4

Changed in lightdm:
status: Triaged → Fix Released
Andreas Schultz (aschultz) wrote :

this bug impacts ssh session from a lightdm session to somewhere else, the ssh session start is hard blocked (not even ^C will abort it) for about 30seconds due to the xauth breakage

i think this warants a Importance of high

sample output:
$ ssh vlx018
Warning: No xauth data; using fake authentication data for X11 forwarding.

Sebastien Bacher (seb128) wrote :

the new version is in oneiric

Changed in lightdm (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers