After upgrade and reboot, the lightdm display manager does not start

Bug #1770965 reported by Simon Pepping on 2018-05-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Canonical Desktop Team
ubuntu-release-upgrader (Ubuntu)
High
Unassigned

Bug Description

Upon the upgrade, lightdm-kde-greeter was removed as it has become obsolete. That leaves the user with a system that hangs.

I rebooted using system-recovery, and installed lightdm-gtk-greeter using aptitude. However, this greeter was not enabled in lightdm.conf. Also, the greeter was not configured with the background image for this release. I had to do these actions manually. Only then did lightdm start properly and with a nice background.

For most users this problem will leave the system unusable forever, and should therefore be avoided. The obsolete greeter should be replaced with a suitable greeter.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.17
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: KDE
Date: Sun May 13 16:30:51 2018
InstallationDate: Installed on 2013-02-05 (1922 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: No upgrade log present (probably fresh install)
VarLogDistupgradeAptlog:
 Log time: 2018-05-13 12:28:57.668250
 Starting pkgProblemResolver with broken count: 0
 Starting 2 pkgProblemResolver with broken count: 0
 Done

Simon Pepping (spepping) wrote :
Simon Pepping (spepping) wrote :

The 2nd paragraph should start as: "To fix the problem I rebooted...

Simon Pepping (spepping) wrote :

It turns out that the problem is caused by lightdm: When its configuration points to a not-installed greeter, it fails to load. It is unfortunate that this bug raises its head upon release upgrade, which obseletes the kde greeter.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Invalid
Simon Pepping (spepping) wrote :

I will keep this bug open. It is a release critical bug since it causes the user to have an unusable system after upgrade.

If the lightdm configuration has the lightdm-kde-greeter configured as the greeter and if the user lets the upgrade remove the now obsolete lightdm-kde-greeter, the lightdm configuration should be modified to have no greeter configured. This will cause lightdm to use its internal greeter, and the user has a usable system and can take it from there.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Invalid → New
Brian Murray (brian-murray) wrote :

Could you please add your upgrade log files? You can find them in /var/log/dist-upgrade/. I'm particularly interested in main.log but the others may be handy too. Thanks in advance.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
importance: Undecided → Critical
tags: added: artful2bionic
Simon Pepping (spepping) wrote :
Brian Murray (brian-murray) wrote :

"It turns out that the problem is caused by lightdm: When its configuration points to a not-installed greeter, it fails to load." <- It'd be good if this were fixed in lightdm.

Changed in lightdm (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Confirmed
importance: Critical → High
Changed in lightdm (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Brian Murray (brian-murray) wrote :

The fix for bug 1775660 may end up fixing the ubuntu-release-upgrader task in this bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers