Black screen after login

Bug #1757975 reported by Jasmijn on 2018-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Undecided
Unassigned

Bug Description

I had a working version on ubuntu 16.04, but while running software-updater to update packages I suddenly got a GNU GRUB screen. It turned out that it was trying to run the 4.4.0-116 kernel, but there was no initrd.img for this kernel. So I selected an older kernel (97) and was able to boot, but got a black screen after login. I could login to tty1 and run dpkg --configure -a, which succeeded in installing the 116 kernel. Now I can boot my computer again, but I still get the black screen after login so I can only use tty1. All software is up to date, but I think there is something wrong with the graphics drivers. I am unable to start lightdm, but also with gdm3 it doesn't work (in this case, I'm returned to the login screen after login). I've tried purging and reinstalling many packages, but nothing worked so far. Please help!

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: lightdm 1.18.3-0ubuntu1.1
ProcVersionSignature: Ubuntu 4.4.0-116.140-generic 4.4.98
Uname: Linux 4.4.0-116-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Thu Mar 22 08:39:49 2018
InstallationDate: Installed on 2016-03-26 (725 days ago)
InstallationMedia: Ubuntu 14.04.4 LTS "Trusty Tahr" - Release amd64 (20160217.1)
SourcePackage: lightdm
UpgradeStatus: Upgraded to xenial on 2017-10-12 (161 days ago)

Jasmijn (jasmijn) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers