lightdm hangs, windows freeze, lightdm restart helps most of the times.

Bug #1515711 reported by Xtien on 2015-11-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Undecided
Unassigned

Bug Description

Since a few days, when I use Android Studio, my screens freeze. Nothing works. With alt-crtrl-F2 I log in to a shell window, restart lightdm, then it works. Except on the last freeze, now I had to restart the computer. When restarting lightdm, a popup said "system in low graphics res, cannot detect your settings".

I have reported the but to Android Studio developers. But a program, even a big one like an IDE, should not be able to crash my computer.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: lightdm 1.14.2-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.19.0-33.38-generic 3.19.8-ckt7
Uname: Linux 3.19.0-33-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1.7
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Nov 12 18:22:33 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-10-02 (41 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Xtien (xtien) wrote :
Xtien (xtien) wrote :

Downgrading to Android Studio 1.4RC3 solved the issue. The problem is in AS, apparently, but still, an application should not be able to hang up the whole computer.

I did notice that when AS hangs, I can continue to use firefox and other apps, until I hit an icon in the Unity bar. Then the system hangs as a whole.

Xtien (xtien) wrote :

Downgrading solved part of the issue. Android Studio manages to keep one CPU busy for 100% for up to five minutes, during which tme other programs stop responding too. But then, when AS stops using that CPU, all is back to normal. For fifteen minutes or so. I don't think Android Studio should be capable of hanging up my UI by using just one CPU.

Xtien (xtien) wrote :

I have upgraded to Ubuntu 15.10, bug is still there.

Xtien (xtien) wrote :

I am still experiencing this issue. Not just with Android Studio, it also happened when loading a file in Gedit. CPU2 goes to 100% and stays there, while Gedit or AS stops responding. In the System Monitor "Processes" tab, no processes are taking more than 1 or 2% of a CPU. The process that froze has 0%, but >600Mb memory usage. The process unfreezes typically after 5 minutes. Almost always it's cpu2, once it was 9, occasionally it's cpu3.
I have a 6core cpu, 16G of memory.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers