Don't work autologin after update lightdm

Bug #1484083 reported by DeadMetaler on 2015-08-12
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
lightdm (Ubuntu)
High
Unassigned
user-setup (Ubuntu)
High
Unassigned

Bug Description

Don't work autologin after update lightdm

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lightdm 1.15.2-0ubuntu2
ProcVersionSignature: Ubuntu 4.1.0-3.3-lowlatency 4.1.3
Uname: Linux 4.1.0-3-lowlatency x86_64
ApportVersion: 2.18-0ubuntu6
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Aug 12 14:20:00 2015
InstallationDate: Installed on 2015-04-23 (110 days ago)
InstallationMedia:

SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

DeadMetaler (dead-666) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

Could someone attach /var/log/lightdm/lightdm.log after this occurs? Thanks.

DeadMetaler (dead-666) wrote :
Changed in lightdm (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Changed in lightdm:
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

Can you also attach /etc/lightdm/lightdm.conf - I need to see if it's been properly configured for autologin.

DeadMetaler (dead-666) wrote :

[SeatDefaults]
autologin-guest=false
autologin-user=deadmetaler
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-setup-script=/usr/bin/numlockx on

Robert Ancell (robert-ancell) wrote :

Ah, the problem you have there is the "autologin-session". That option was previously unimplemented. The value you have there is the default for "pam-autologin-service". If you delete the line autologin-session it should work fine.

Could the others who have marked this bug as affecting them please confirm if you have the same option set. Also, was this set manually or is something else setting it?

Robert Ancell (robert-ancell) wrote :

Now I re-read the log I can see the error being reported:
[+0.02s] DEBUG: Seat seat0: Failed to find session configuration lightdm-autologin
[+0.02s] DEBUG: Seat seat0: Can't find session 'lightdm-autologin'

DeadMetaler (dead-666) wrote :

Yes. It's working after deleting this line.

Manualy added only
greeter-setup-script=/usr/bin/numlockx on

All of anything other was present in lightdm.conf by default.

vmc (vmclark) wrote :

Using xubuntu-wily removing the line "autologin-session=lightdm-autologin". Now autologin works

But, that line is still in xubuntu-trusty and it always worked. ?!

Robert Ancell (robert-ancell) wrote :

Turns out this setting is being set at the installer (ubiquity).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubiquity (Ubuntu) → user-setup (Ubuntu)
Changed in user-setup (Ubuntu):
status: New → Confirmed
Changed in user-setup (Ubuntu):
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

And it turns out it's actually the user-setup package that contains this code (it's pulled into ubiquity).

no longer affects: lightdm
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
Changed in user-setup (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.15.3-0ubuntu1

---------------
lightdm (1.15.3-0ubuntu1) wily; urgency=medium

  * New upstream release:
    - Drop Xorg option -sharevts. It's no longer required for non-seat0 X
      servers since xorg-server release 1.16.
  * debian/patches/autologin-session-workaround.patch:
    - Workaround faulty setting from user-setup package (LP: #1484083)

 -- Robert Ancell <email address hidden> Mon, 17 Aug 2015 10:39:27 +1200

Changed in lightdm (Ubuntu):
status: Triaged → Fix Released
jerrylamos (jerrylamos) wrote :

This is Ubuntu Unity which had the autologin failure in spite of install specifying autologin and settings autologin as well.

As in Post #11 now fixed, just commented out the line.

Problem occurred this week with fresh install of Wily .iso daily build.
Also occurred on my laptop with just Wily updates.

Forcing login also caused massive multiple xserver resets which screwed up wallpaper. Wallpaper was fine, no idea why just logging in caused xserver resets much more complex than settings wallpaper does.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package user-setup - 1.48ubuntu6

---------------
user-setup (1.48ubuntu6) wily; urgency=medium

  * Update autologin LightDM confgiguration to used [Seat:*] sections instead of
    deprecated [SeatDefaults]
  * Fix autologin LightDM confgiguration to not set innapropriate setting
    autologin-session to an invalid value (LP: #1484083)

 -- Robert Ancell <email address hidden> Tue, 18 Aug 2015 17:00:03 +1200

Changed in user-setup (Ubuntu):
status: Triaged → Fix Released
Kev Bowring (flocculant) wrote :

Xubuntu Wily Daily

Choose autologin during install.

System doesn't autologin.

/etc/lightdm.conf is populated only with

[Seat:*]

completing the conf with user-session and autologin-user to suit and it works properly.

Ubuntu MATE Wily Daily

Choose autologin during install.

System doesn't autologin.

/etc/lightdm.conf is populated only with

[Seat:*]

completing the conf with user-session and autologin-user to suit and it works properly.

Kev Bowring (flocculant) wrote :

Xubuntu Wily

editing /usr/share/lightdm/lightdm.conf.d/60-xubuntu.conf with the autologin details works

Ubuntu Wily Daily

Choose autologin during install.

System doesn't autologin.

/etc/lightdm.conf is populated only with

[Seat:*]

completing the conf with user-session and autologin-user to suit and it works properly.

Kev Bowring (flocculant) wrote :

re-reported at bug 1498544

Scott Emmons (lscotte) on 2017-09-03
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers