Cannot open my session graphically in Lu 14.04 PPC

Bug #1400967 reported by Fritz Hudnut
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

I am having a problem on my iBook G4 running Lu 14.04.1 . . . after running a recent update/upgrade with only 3 or 4 items listed, "dbus" was one I remember . . . screen went black . . . tried to do something in TTY console to "restart" . . . then wound up shutting down. On reboot the lightdm window loads, when I add my user password, the screen goes black, then the lightdm window loads again . . . . Using "guest" to log in gets me into a GUI that works . . . but I can't log in as the original admin/user.

Booted into "recovery" and ran through the dpkg & fsck & network enabling . . . a few times, there were numerous errors that showed up . . . the user login problem was not fixed . . . .

Pursuing this issue on the launchpad "questions" forum has given me some things to try out, including creating a new user, which I can log into and "sudo" with . . . the original user will not log into GUI, only a TTY. I would like to be able to use the original admin user account, as the default account.

F
---
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: powerpc
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2014-10-27 (44 days ago)
InstallationMedia: Lubuntu 14.04.1 LTS "Trusty Tahr" - Release powerpc (20140722.2)
Package: lightdm 1.10.1-0ubuntu1
PackageArchitecture: powerpc
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.13.0-40.69-powerpc-smp 3.13.11.10
Tags: trusty
Uname: Linux 3.13.0-40-powerpc-smp ppc
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True

Revision history for this message
Fritz Hudnut (este-el-paz) wrote : Dependencies.txt

apport information

tags: added: apport-collected trusty
description: updated
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Fritz, and thanks for your report.

From what you say, I doubt this is a lightdm bug. It rather sounds like something has been messed up in your home directory.

One way (certainly not the only one) to deal with it follows.

Assuming that your username is fritz, log in via a TTY and run these commands:

sudo mv /home/fritz /home/fritz.old
sudo mkdir /home/fritz
sudo cp -rT /etc/skel/ /home/fritz
sudo chown -R fritz:fritz /home/fritz

That creates a fresh home folder, while the old contents is kept in /home/fritz.old. Then you should be able to log in as your user, and can move contents from /home/fritz.old to /home/fritz as you see fit.

Please let us know if that helps.

Changed in lightdm (Ubuntu):
status: New → Incomplete
Revision history for this message
Fritz Hudnut (este-el-paz) wrote :

@Gunnar:

Thanks kindly for the reply, looks like a bit before you posted here, Manfred H on "answers" offered what might be a similar suggestion . . . since he has patiently been working with me for awhile on this problem I tried it first, and it seems to have fixed the problem . . . I'm typing this back in my original user account.

"Try logging in as the new user and issue the terminal command

sudo chown -R fritzhud:fritzhud /home/fritzhud/.gvfs
sudo chown fritzhud:fritzhud /home/fritzhud/.Xauthority
sudo chown fritzhud:fritzhud /home/fritzhud/.hcwd

and then try loggin in as fritzhud again."

Now I'll be moving on to seeing if "suspend" can be fixed for PPC 14.04 . . . . : - 0

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Ok, good. Closing this bug then.

Changed in lightdm (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers