Live image boots into black screen

Bug #1297799 reported by Jan Rathmann on 2014-03-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
Ubuntu Kylin
High
Unassigned
lightdm (Ubuntu)
High
Unassigned

Bug Description

Today I tried to do a test installation of Trusty with the current daily live image (via USB stick), but it booted into a black screen after the Plymouth boot animation (the Ubuntu lettering + logo) was shown. The last thing I see during the boot is a short appearence of a mouse cursor, but then everything stays blank (usually an Ubiquity window would appear here to let me choose language and between installing ubuntu or trying out the live image). This behaviour is reproducible. If the screen is black, switching to VTs via Ctr + Alt + F1-F6 works and VTs are usable.

I can workaround the black screen if I press F2 early during boot and choose "Try Ubuntu without installing". Then the desktop comes up properly (and I am sending this report from a live image started this way).

The last image I used to do a test installation was 20140309, where this bug was absent.

I am not sure if Lightdm is actually responsible for the bug, but it seemed to be the best package choice for this bug because the bug occurs when Lightdm should come up.

Kind regards,
Jan

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lightdm 1.9.13-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CasperVersion: 1.339
CurrentDesktop: Unity
Date: Wed Mar 26 10:59:04 2014
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140325.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Jan Rathmann (kaiserclaudius) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1297799

tags: added: iso-testing
Changed in lightdm (Ubuntu):
status: New → Confirmed
Jack Yu (jackyu) on 2014-03-27
Changed in ubuntukylin:
milestone: none → trusty-final-freeze
importance: Undecided → High
Ma Jun (maclin.jun) on 2014-03-27
tags: added: ubuntukylin

It renders the system temporarily or permanently unusable.

Changed in lightdm (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Jan Rathmann (kaiserclaudius) wrote :

Couldn't reproduce the bug anymore with today's daily image (20140330), so it might have been fixed.

shijing (shijing) wrote :

today's daily image (20140409), it have been fixed.

Ma Jun (maclin.jun) on 2014-04-10
Changed in ubuntukylin:
status: New → Fix Released
Brian Murray (brian-murray) wrote :

Based off the reporter's comment I am setting this to Fix Released.

Changed in lightdm (Ubuntu):
importance: Critical → High
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers