Lightdm doesn't give any error message when .XAutority is owned by root

Bug #1268283 reported by PEIGNOT Kévin on 2014-01-12
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Unassigned

Bug Description

(Orignal problem at the end)

I understood the problem : As I had to sudo startx previously, .XAutority was owned by root. So Lightdm wasn't able to log me in. But Lightdm doesn't display any error message explaining why it can't log me in, as there was previously in GDM.

HOW to reproduce : made root the owner of the .XAutority file at the root of your personal home, then try to login via Lightdm. It doesn't display any message but it doesn't log you.

---------------------Original problem :------------------------

So here is what happened : To test if an old bug with menus is still present in Trusty I updated to it, but it went very wrong (no screen at all, I filed this bug by going to recovery mode and FailsafeX). So I tried installing Trusty "from scratch", but I kept my /home. I used the same ID and Password during the installation as I do each reinstall. Reinstall corrected the problem of no screen : I was on lightdm login screen. Then, impossible to log me in : It tried and immediately go back to login screen. I changed the password from tty1 but same problem. But I can open the guest session (from which I make this bug report).

What I expected : To be able to login from lightdm as I do each time I have to reinstall the system.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: lightdm 1.9.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-1.16-generic 3.13.0-rc7
Uname: Linux 3.13.0-1-generic x86_64
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jan 12 11:50:36 2014
InstallationDate: Installed on 2014-01-12 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140111)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

PEIGNOT Kévin (kpeignot) wrote :
summary: - AFter reinstall of Trusty, Lightdm can'tlog me in my session
+ After reinstall of Trusty, Lightdm can't log me in my session

I understood what happened : As I had to start X (startx) on my session previously, my .XAutority file was owned by root not myself. I understood that after reinstalling 13.10. So I removed .XAutority and it worked. But I think there should be an error message as there was previously in GDM

Changed in lightdm (Ubuntu):
status: New → Invalid
status: Invalid → Opinion
summary: - After reinstall of Trusty, Lightdm can't log me in my session
+ Lightdm doesn't give any error message when .XAutority is owned by root
tags: added: regression
description: updated
Changed in lightdm (Ubuntu):
status: Opinion → Invalid
status: Invalid → New
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

just ran into this myself a few days ago when updating to bionic. It was pure luck that I discovered the problem and fix.

tags: added: bionic
Changed in lightdm (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers