Lightdm doesn't launch Plasma on Kubuntu Trusty anymore

Bug #1257760 reported by Rohan Garg on 2013-12-04
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kde-workspace (Ubuntu)
Critical
Kubuntu Developers
lightdm (Ubuntu)
Undecided
Unassigned
lightdm-kde (Ubuntu)
Critical
Unassigned

Bug Description

When trying to start the KDE Desktop using lightdm on a Live Kubuntu CD, lightdm fails to start the session.

[Steps to reproduce]
* Download the latest Kubuntu Trusty ISO
* Click on "Try Kubuntu"
* Plasma fails to come up

Lightdm Log :
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.9.4, UID=0 PID=5237
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Registered seat module surfaceflinger
[+0.00s] DEBUG: Adding default seat
[+0.00s] DEBUG: Seat: Starting
[+0.00s] DEBUG: Seat: Creating user session
[+0.09s] DEBUG: Seat: Failed to find session configuration ubuntu
[+0.09s] DEBUG: Seat: Can't find session 'ubuntu'
[+0.09s] DEBUG: Seat: Creating greeter session
[+0.09s] DEBUG: Seat: Failed to find session configuration default
[+0.09s] DEBUG: Seat: Failed to create greeter session

Rohan Garg (rohangarg) on 2013-12-04
summary: - Lightdm doesn't work on Kubuntu Trusty anymore
+ Lightdm doesn't launch Plasma on Kubuntu Trusty anymore
Robert Ancell (robert-ancell) wrote :

This is because the lightdm has removed lightdm-set-defaults - now you should provide configuration into /usr/share/lightdm/lightdm.conf.d (patches attached)

Robert Ancell (robert-ancell) wrote :
Changed in lightdm (Ubuntu):
status: New → Invalid
Robert Ancell (robert-ancell) wrote :

I haven't tested these patches but this is essentially what you should do - please ping me if you have any problems.

Robert Ancell (robert-ancell) wrote :
Changed in kde-workspace (Ubuntu):
importance: Undecided → Critical
Changed in lightdm-kde (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Changed in kde-workspace (Ubuntu):
status: New → Triaged
tags: added: patch
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1257760

tags: added: iso-testing
Changed in kde-workspace (Ubuntu):
assignee: nobody → Kubuntu Developers (kubuntu-dev)
Jonathan Riddell (jr) wrote :

Thanks, uploaded

Changed in lightdm-kde (Ubuntu):
status: Triaged → Fix Released
Changed in kde-workspace (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers