[touch] /usr/sbin/lightdm-session calls non-existent xrdb

Bug #1236317 reported by Jean-Baptiste Lallement
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Fix Released
Medium
Robert Ancell

Bug Description

On touch (mako build 83:20131005) the following error is displayed in /home/phablet/.xsession-errors
/usr/sbin/lightdm-session: 36: /usr/sbin/lightdm-session: xrdb: not found

xrdb is in x11-xserver-utils which is not installed on touch images.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: lightdm 1.7.17-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Mon Oct 7 13:37:34 2013
InstallationDate: Installed on 2013-09-03 (33 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
MarkForUpload: True
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Changed in lightdm (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Robert Ancell (robert-ancell) wrote :

This is run from the file /etc/X11/Xsession.d/30x11-common_xresources which is in the x11-common package. Either this package should depend on xrdb, or it should handle xrdb not being installed.

affects: lightdm (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
tags: added: rls-s-incoming
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

it already should handle this:

# If xrdb (from xbase-clients) is installed, merge system-wide X resources.
# Then merge the user's X resources, if the options file is so configured.
if [ -d "$SYSRESOURCES" ] && type xrdb >/dev/null 2>&1; then
  RESOURCEFILES=$(run-parts --list $SYSRESOURCES)
  if [ -n "$RESOURCEFILES" ]; then
    for RESOURCEFILE in $RESOURCEFILES; do
      xrdb -merge $RESOURCEFILE
    done
  fi
fi

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

I don't understand why this has been reassigned to xorg because the error is clearly in lightdm source. And more precisely in

j-lallement@sark:/tmp/lightdm-1.7.18⟫ grep -nr xrdb *
debian/lightdm-session:36: xrdb -nocpp -merge "$file"
debian/lightdm-session:42: xrdb -nocpp -merge "$xresourcefile"

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

heh, good point, moving back

affects: xorg (Ubuntu) → lightdm (Ubuntu)
Revision history for this message
Robert Ancell (robert-ancell) wrote :

huh, whoops.

Changed in lightdm (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Changed in lightdm (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.8.0-0ubuntu1

---------------
lightdm (1.8.0-0ubuntu1) saucy; urgency=low

  * debian/lightdm-session:
    - Handle xrdb, setxkbmap and xmodmap not being installed (LP: #1236317)
 -- Robert Ancell <email address hidden> Wed, 09 Oct 2013 15:53:56 +1300

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers