Login often fails

Bug #1228570 reported by Till Kamppeter on 2013-09-21
60
This bug affects 21 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Critical
Unassigned
unity (Ubuntu)
Critical
Unassigned
xorg (Ubuntu)
Critical
Unassigned

Bug Description

I am using the Lenovo Thinkpad Twist with Saucy and the standard Unity desktop. Often when I log in, after entering the password the screen gets black and within one second I am back in LightDM. I have to enter my password three or four times until getting a successful login. Logging in right after reboot works more often. Logging into the guest account always works.

There are no messages in .xsession-errors. /var/log/syslog adds the following lines after pressing Enter after entering the password until LightDM re-appearing:

First failed attempt:

Sep 21 13:28:05 till-twist colord: device removed: xrandr-LVDS1
Sep 21 13:28:05 till-twist colord: Profile removed: icc-212ca362d5002958378e8fefb0ad7943
Sep 21 13:28:05 till-twist colord: Profile removed: icc-f5a7781aa544aba4d0654c67690ec8d4
Sep 21 13:28:05 till-twist colord: Profile removed: icc-42cf0f25cbd914f2177438317b72f222
Sep 21 13:28:05 till-twist NetworkManager[1705]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.139': no such name
Sep 21 13:28:05 till-twist acpid: client 7242[0:0] has disconnected
Sep 21 13:28:05 till-twist acpid: client connected from 7493[0:0]
Sep 21 13:28:05 till-twist acpid: 1 client rule loaded
Sep 21 13:28:05 till-twist dbus[574]: [system] Activating service name='org.freedesktop.systemd1' (using servicehelper)
Sep 21 13:28:05 till-twist dbus[574]: [system] Successfully activated service 'org.freedesktop.systemd1'
Sep 21 13:28:06 till-twist colord: Device added: xrandr-LVDS1
Sep 21 13:28:06 till-twist colord: Profile added: icc-212ca362d5002958378e8fefb0ad7943
Sep 21 13:28:06 till-twist colord: Automatic metadata add icc-f5a7781aa544aba4d0654c67690ec8d4 to xrandr-LVDS1
Sep 21 13:28:06 till-twist colord: Profile added: icc-f5a7781aa544aba4d0654c67690ec8d4
Sep 21 13:28:06 till-twist colord: Profile added: icc-42cf0f25cbd914f2177438317b72f222

Second failed attempt:

Sep 21 13:34:42 till-twist colord: device removed: xrandr-LVDS1
Sep 21 13:34:42 till-twist colord: Profile removed: icc-212ca362d5002958378e8fefb0ad7943
Sep 21 13:34:42 till-twist colord: Profile removed: icc-f5a7781aa544aba4d0654c67690ec8d4
Sep 21 13:34:42 till-twist colord: Profile removed: icc-42cf0f25cbd914f2177438317b72f222
Sep 21 13:34:42 till-twist NetworkManager[1705]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.160': no such name
Sep 21 13:34:42 till-twist NetworkManager[1705]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.160': no such name
Sep 21 13:34:43 till-twist acpid: client 7493[0:0] has disconnected
Sep 21 13:34:43 till-twist acpid: client connected from 7737[0:0]
Sep 21 13:34:43 till-twist acpid: 1 client rule loaded
Sep 21 13:34:43 till-twist dbus[574]: [system] Activating service name='org.freedesktop.systemd1' (using servicehelper)
Sep 21 13:34:43 till-twist dbus[574]: [system] Successfully activated service 'org.freedesktop.systemd1'
Sep 21 13:34:43 till-twist colord: Device added: xrandr-LVDS1
Sep 21 13:34:43 till-twist colord: Profile added: icc-212ca362d5002958378e8fefb0ad7943
Sep 21 13:34:43 till-twist colord: Automatic metadata add icc-f5a7781aa544aba4d0654c67690ec8d4 to xrandr-LVDS1
Sep 21 13:34:43 till-twist colord: Profile added: icc-f5a7781aa544aba4d0654c67690ec8d4
Sep 21 13:34:43 till-twist colord: Profile added: icc-42cf0f25cbd914f2177438317b72f222

Third failed attempt:

Sep 21 13:34:53 till-twist whoopsie[1969]: online
Sep 21 13:35:43 till-twist colord: device removed: xrandr-LVDS1
Sep 21 13:35:43 till-twist colord: Profile removed: icc-212ca362d5002958378e8fefb0ad7943
Sep 21 13:35:43 till-twist colord: Profile removed: icc-f5a7781aa544aba4d0654c67690ec8d4
Sep 21 13:35:43 till-twist colord: Profile removed: icc-42cf0f25cbd914f2177438317b72f222
Sep 21 13:35:43 till-twist NetworkManager[1705]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.175': no such name
Sep 21 13:35:43 till-twist NetworkManager[1705]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.175': no such name
Sep 21 13:35:44 till-twist acpid: client 7737[0:0] has disconnected
Sep 21 13:35:44 till-twist acpid: client connected from 7948[0:0]
Sep 21 13:35:44 till-twist acpid: 1 client rule loaded
Sep 21 13:35:45 till-twist dbus[574]: [system] Activating service name='org.freedesktop.systemd1' (using servicehelper)
Sep 21 13:35:45 till-twist dbus[574]: [system] Successfully activated service 'org.freedesktop.systemd1'
Sep 21 13:35:45 till-twist colord: Device added: xrandr-LVDS1
Sep 21 13:35:45 till-twist colord: Profile added: icc-212ca362d5002958378e8fefb0ad7943
Sep 21 13:35:45 till-twist colord: Automatic metadata add icc-f5a7781aa544aba4d0654c67690ec8d4 to xrandr-LVDS1
Sep 21 13:35:45 till-twist colord: Profile added: icc-f5a7781aa544aba4d0654c67690ec8d4
Sep 21 13:35:45 till-twist colord: Profile added: icc-42cf0f25cbd914f2177438317b72f222

And this gets added to /var/log/syslog when the login succeeds starting from after pressing Enter after entering the password until the desktop being ready to use:

Sep 21 13:37:45 till-twist colord: device removed: xrandr-LVDS1
Sep 21 13:37:45 till-twist colord: Profile removed: icc-212ca362d5002958378e8fefb0ad7943
Sep 21 13:37:45 till-twist colord: Profile removed: icc-f5a7781aa544aba4d0654c67690ec8d4
Sep 21 13:37:45 till-twist colord: Profile removed: icc-42cf0f25cbd914f2177438317b72f222
Sep 21 13:37:45 till-twist dbus[738]: [system] Activating service name='org.freedesktop.systemd1' (using servicehelper)
Sep 21 13:37:45 till-twist dbus[738]: [system] Successfully activated service 'org.freedesktop.systemd1'
Sep 21 13:37:46 till-twist colord: Device added: xrandr-LVDS1
Sep 21 13:37:46 till-twist gnome-session[3222]: Gtk-WARNING: Theme parsing error: gtk-widgets.css:1605:38: '' is not a valid color name
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Successfully made thread 3409 of process 3409 (n/a) owned by '1000' high priority at nice level -11.
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Supervising 4 threads of 2 processes of 2 users.
Sep 21 13:37:46 till-twist gnome-session[3222]: Gtk-WARNING: Theme parsing error: gtk-widgets.css:1605:38: '' is not a valid color name
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Successfully made thread 3448 of process 3409 (n/a) owned by '1000' RT at priority 5.
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Supervising 5 threads of 2 processes of 2 users.
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Successfully made thread 3453 of process 3409 (n/a) owned by '1000' RT at priority 5.
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Supervising 6 threads of 2 processes of 2 users.
Sep 21 13:37:46 till-twist bluetoothd[905]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/HFPAG
Sep 21 13:37:46 till-twist bluetoothd[905]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/HFPHS
Sep 21 13:37:46 till-twist bluetoothd[905]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSource
Sep 21 13:37:46 till-twist bluetoothd[905]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSink
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Successfully made thread 3472 of process 3472 (n/a) owned by '1000' high priority at nice level -11.
Sep 21 13:37:46 till-twist rtkit-daemon[2457]: Supervising 7 threads of 3 processes of 2 users.
Sep 21 13:37:46 till-twist pulseaudio[3472]: [pulseaudio] pid.c: Daemon already running.
Sep 21 13:37:46 till-twist dbus[738]: [system] Activating service name='org.freedesktop.locale1' (using servicehelper)
Sep 21 13:37:46 till-twist dbus[738]: [system] Successfully activated service 'org.freedesktop.locale1'
Sep 21 13:37:46 till-twist colord: Profile added: icc-75d60d950fd529eb4eb5d13774694db0
Sep 21 13:37:46 till-twist colord: Profile added: icc-0c800749ecb3e100c49f4d0032efb574
Sep 21 13:37:46 till-twist colord: Automatic metadata add icc-ddef9b1134614d611689ddc660185c5e to xrandr-LVDS1
Sep 21 13:37:46 till-twist colord: Profile added: icc-ddef9b1134614d611689ddc660185c5e
Sep 21 13:37:46 till-twist dbus[738]: [system] Activating service name='org.freedesktop.UDisks2' (using servicehelper)
Sep 21 13:37:46 till-twist udisksd[3607]: udisks daemon version 2.1.0 starting
Sep 21 13:37:46 till-twist dbus[738]: [system] Successfully activated service 'org.freedesktop.UDisks2'
Sep 21 13:37:46 till-twist udisksd[3607]: Acquired the name org.freedesktop.UDisks2 on the system message bus

Till Kamppeter (till-kamppeter) wrote :

I have now tried 5 subsequent logins with XBMC as desktop, they all succeeded, so it is very probable that it is a problem of Unity.

Changed in unity (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-13.10
Till Kamppeter (till-kamppeter) wrote :

It seems that the login problems mainly happen when switching between Mir and standard X, proceeding as described on https://wiki.ubuntu.com/Mir/Installing, section "Removing unity-system-compositor"/"Temporarily", especially when deactivating Mir, returning to standard X. Additional reboots, or selecting an alternative session instead of standard Ubuntu/Unity, like XBMC, helps to get logged in again.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Chris Fox (desertfox) wrote :

I've got the same problem in Ubuntu 13.04. After login, I get a blank screen for about a second, then it goes back to lightdm. Removing either .ICEauthority or .Xauthority solves the problem. The problem reappears (to me) seemingly random, so not necessarily after each successful login.

Stephen M. Webb (bregma) wrote :

Ever since a recent update I get this problem after using an X client remotely over ssh. It seems they may be (incorrectly) overwriting the ~/.Xauthority file, preventing the local X server from starting on the next login.

The X server failing to start because a remote application has been run is not a Unity problem. Perhaps an xlib problem?

Till Kamppeter (till-kamppeter) wrote :

I am also logging into my Thinkpad Twist via SSH (with "-X" option to be able to use X apps) and indeed this influences whether I can log in. If I am able to log in directly on my laptop's screen, I am able to log in again and again as long as I do not log in via SSH. If I log in via SSH from another machine while I am logged in on the laptop's own screen and then log out on the laptop's screen I cannot log in again on the laptop's screen. To be able to log in again, I have to log out of the SSH session and log in again via SSH, after that I can log in again on the laptop's screen.

My .Xauthority file is most probably the culprit. The laptop's screen is DISPLAY :0, the SSH session has DISPLAY :10 (see DISPLAY variable in terminal). The .Xauthority file has up to three lines. Most is unreadable binary data, all contain "till-twist" (the host name of the laptop) near the beginning, some binary bytes, a number, some more binary bytes, "MIT-MAGIC-COOKIE-1", and more binary bytes. In a healthy (I can log in from the laptop's native screen) .XAuthority all lines have different numbers, usually 0, 10, 11 in arbitrary order, or there are only two lines, also with different numbers out of 0, 10, and 11. A broken (I cannot log in) .Xauthority contains two lines with the number 10 and one with 11.

Changed in xorg (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
milestone: none → ubuntu-13.10
Stephen M. Webb (bregma) wrote :
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in xorg (Ubuntu):
status: Confirmed → Invalid
Till Kamppeter (till-kamppeter) wrote :
Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
tags: added: patch
Owen Williams (ywwg) wrote :

Any chance of a backport to 13.04?

Can it be that this is the same as bug 1234400?

I also have this problem on 13.04.

Changed in lightdm (Ubuntu):
milestone: ubuntu-13.10 → saucy-updates

According to Robert Ancell the attached patch is applied in 13.10.

Changed in lightdm (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers