lightdm --test-mode fails immediately

Bug #1226544 reported by Sean Davis
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Fix Released
High
Robert Ancell
lightdm (Ubuntu)
Fix Released
High
Robert Ancell

Bug Description

When attempting to run lightdm --test-mode, a window is shown for a split second and then closes. I have xserver-xephyr installed, this happens with either lightdm-gtk-greeter and unity-greeter.

lightdm 1.7.15-0ubuntu1
lightdm-gtk-greeter 1.6.1+133+97~ubuntu13.10.1 (from daily build)
unity-greeter 13.10.2-0ubuntu1
xserver-xephyr 2:1.14.2.901-2ubuntu4

I have attached lightdm.log from ~/.cache/lightdm/log

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: lightdm 1.7.15-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
Uname: Linux 3.11.0-7-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.12.1-0ubuntu4
Architecture: amd64
Date: Tue Sep 17 07:00:33 2013
InstallationDate: Installed on 2013-09-14 (2 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130914)
LightdmConfig:
 [SeatDefaults]
 greeter-session=unity-greeter
 user-session=xubuntu
MarkForUpload: True
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Sean Davis (bluesabre) wrote :
Revision history for this message
Sean Davis (bluesabre) wrote :

unity-greeter log

Revision history for this message
Sean Davis (bluesabre) wrote :

lightdm-gtk-greeter log

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Revision history for this message
Robert Ancell (robert-ancell) wrote :

The bug appears to be LightDM 1.7 tries to write the Xauthority to a system location even when it is in test mode

Changed in lightdm (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in lightdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
status: Triaged → In Progress
Changed in lightdm:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:lightdm at revision 1791, scheduled for release in lightdm, milestone Unknown

Changed in lightdm:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.7.16-0ubuntu1

---------------
lightdm (1.7.16-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Fix ConsoleKit support broken in 1.7.5
    - Fix --test-mode (LP: #1226544)
    - Add support for running Surfaceflinger sessions
 -- Robert Ancell <email address hidden> Thu, 19 Sep 2013 17:42:48 -0400

Changed in lightdm (Ubuntu):
status: In Progress → Fix Released
Changed in lightdm:
milestone: none → 1.7.16
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers