Installing gnome-session-flashback also installs Unity

Bug #1222155 reported by Fred
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Attempting to install gnome-session-flashback on Ubuntu GNOME will try to install Unity.

This is because
gnome-session-flashback depends on gnome-panel
which recommends indicator-applet-complete
which recommends indicator-keyboard
which depends on liblightdm-gobject-1-0
which recommends lightdm
which recommends unity-greeter
which recommends lightdm-remote-session-uccsconfigure
which depends on unity

Suggested fixes:
- Does indicator-keyboard really need to build against lightdm?

Alternative:
- We could have liblightdm-gobject-1.0 not recommend lightdm but indicator-keyboard is the only unusual rdepends of liblightdm-gobject-1.0.

ubuntu-gnome@ubuntu-gnome:~$ sudo apt-get install gnome-session-flashback
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  account-plugin-facebook account-plugin-flickr account-plugin-google
  account-plugin-twitter alacarte appmenu-qt appmenu-qt5 bamfdaemon compiz
  compiz-core compiz-gnome compiz-plugins-default freerdp-x11 friends
  friends-dispatcher friends-facebook friends-twitter geoclue
  geoclue-ubuntu-geoip gir1.2-accounts-1.0 gir1.2-ebook-1.2
  gir1.2-ebookcontacts-1.2 gir1.2-edataserver-1.2 gir1.2-gconf-2.0
  gir1.2-messagingmenu-1.0 gir1.2-panelapplet-4.0 gir1.2-signon-1.0
  gnome-applets gnome-applets-data gnome-control-center-datetime
  gnome-control-center-signon gnome-control-center-unity gnome-media
  gnome-panel gnome-panel-data gnome-power-manager gnome-screensaver
  gnome-session-fallback gstreamer0.10-gconf hud indicator-applet-complete
  indicator-appmenu indicator-bluetooth indicator-datetime indicator-keyboard
  indicator-messages indicator-power indicator-printers indicator-session
  indicator-sound libaccount-plugin-1.0-0 libaccount-plugin-generic-oauth
  libaccount-plugin-google libaccounts-qt5-1 libaudio2 libbamf3-2
  libcolumbus0-0 libcolumbus0-0-common libcompizconfig0 libdbusmenu-qt2
  libdbusmenu-qt5 libdecoration0 libfreerdp-plugins-standard libfreerdp1
  libfriends0 libglew1.8 libglewmx1.8 libgnome-media-profiles-3.0-0
  libhud-client2 liblightdm-gobject-1-0 libmetacity-private0a libmng1
  libmysqlclient18 libnux-4.0-0 libnux-4.0-common libpam-freerdp
  libpanel-applet-4-0 libpocketsphinx1 libqt4-dbus libqt4-declarative
  libqt4-network libqt4-script libqt4-sql libqt4-sql-mysql libqt4-xml
  libqt4-xmlpatterns libqt53d5 libqt5core5 libqt5dbus5 libqt5gui5
  libqt5location5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5qml5
  libqt5quick5 libqt5sensors5 libqt5sql5 libqt5sql5-sqlite libqt5test5
  libqt5v8-5 libqt5webkit5 libqt5widgets5 libqt5xml5 libqtcore4 libqtgui4
  libsignon-extension1 libsignon-plugins-common1 libsignon-qt5-1
  libsphinxbase1 libunity-core-6.0-7 libunity-gtk2-parser0
  libunity-gtk3-parser0 libunity-misc4 libunity-webapps0 libwnck-common
  libwnck22 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0
  libxcb-render-util0 libxcb-sync0 lightdm lightdm-remote-session-freerdp
  lightdm-remote-session-uccsconfigure metacity metacity-common mysql-common
  nux-tools python-gconf python3-feedparser python3-lxml qdbus qtchooser
  remote-login-service signon-keyring-extension signon-plugin-oauth2 signon-ui
  signond sphinx-voxforge-hmm-en sphinx-voxforge-lm-en
  thin-client-config-agent unity unity-asset-pool unity-greeter
  unity-gtk-module-common unity-gtk2-module unity-gtk3-module
  unity-lens-applications unity-lens-files unity-lens-friends unity-lens-music
  unity-lens-photos unity-lens-video unity-scope-audacious
  unity-scope-calculator unity-scope-chromiumbookmarks unity-scope-clementine
  unity-scope-colourlovers unity-scope-devhelp unity-scope-firefoxbookmarks
  unity-scope-gdrive unity-scope-gmusicbrowser unity-scope-gourmet
  unity-scope-guayadeque unity-scope-home unity-scope-manpages
  unity-scope-musicstores unity-scope-musique unity-scope-openclipart
  unity-scope-texdoc unity-scope-tomboy unity-scope-video-remote
  unity-scope-virtualbox unity-scope-yelp unity-scope-zotero
  unity-scopes-master-default unity-scopes-runner unity-services
  unity-webapps-service
Suggested packages:
  tomboy gnome-netstatus-applet deskbar-applet cpufrequtils desktop-base nas
  glew-utils libqt4-declarative-folderlistmodel libqt4-declarative-gestures
  libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer
  libqt4-dev qt4-qtconfig python-gnome2-doc python3-lxml-dbg qt4-default
  qt5-default audacious clementine gmusicbrowser guayadeque musique
The following NEW packages will be installed:
  account-plugin-facebook account-plugin-flickr account-plugin-google
  account-plugin-twitter alacarte appmenu-qt appmenu-qt5 bamfdaemon compiz
  compiz-core compiz-gnome compiz-plugins-default freerdp-x11 friends
  friends-dispatcher friends-facebook friends-twitter geoclue
  geoclue-ubuntu-geoip gir1.2-accounts-1.0 gir1.2-ebook-1.2
  gir1.2-ebookcontacts-1.2 gir1.2-edataserver-1.2 gir1.2-gconf-2.0
  gir1.2-messagingmenu-1.0 gir1.2-panelapplet-4.0 gir1.2-signon-1.0
  gnome-applets gnome-applets-data gnome-control-center-datetime
  gnome-control-center-signon gnome-control-center-unity gnome-media
  gnome-panel gnome-panel-data gnome-power-manager gnome-screensaver
  gnome-session-fallback gnome-session-flashback gstreamer0.10-gconf hud
  indicator-applet-complete indicator-appmenu indicator-bluetooth
  indicator-datetime indicator-keyboard indicator-messages indicator-power
  indicator-printers indicator-session indicator-sound libaccount-plugin-1.0-0
  libaccount-plugin-generic-oauth libaccount-plugin-google libaccounts-qt5-1
  libaudio2 libbamf3-2 libcolumbus0-0 libcolumbus0-0-common libcompizconfig0
  libdbusmenu-qt2 libdbusmenu-qt5 libdecoration0 libfreerdp-plugins-standard
  libfreerdp1 libfriends0 libglew1.8 libglewmx1.8
  libgnome-media-profiles-3.0-0 libhud-client2 liblightdm-gobject-1-0
  libmetacity-private0a libmng1 libmysqlclient18 libnux-4.0-0
  libnux-4.0-common libpam-freerdp libpanel-applet-4-0 libpocketsphinx1
  libqt4-dbus libqt4-declarative libqt4-network libqt4-script libqt4-sql
  libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqt53d5 libqt5core5
  libqt5dbus5 libqt5gui5 libqt5location5 libqt5network5 libqt5opengl5
  libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5sensors5 libqt5sql5
  libqt5sql5-sqlite libqt5test5 libqt5v8-5 libqt5webkit5 libqt5widgets5
  libqt5xml5 libqtcore4 libqtgui4 libsignon-extension1
  libsignon-plugins-common1 libsignon-qt5-1 libsphinxbase1 libunity-core-6.0-7
  libunity-gtk2-parser0 libunity-gtk3-parser0 libunity-misc4 libunity-webapps0
  libwnck-common libwnck22 libxcb-icccm4 libxcb-image0 libxcb-keysyms1
  libxcb-randr0 libxcb-render-util0 libxcb-sync0 lightdm
  lightdm-remote-session-freerdp lightdm-remote-session-uccsconfigure metacity
  metacity-common mysql-common nux-tools python-gconf python3-feedparser
  python3-lxml qdbus qtchooser remote-login-service signon-keyring-extension
  signon-plugin-oauth2 signon-ui signond sphinx-voxforge-hmm-en
  sphinx-voxforge-lm-en thin-client-config-agent unity unity-asset-pool
  unity-greeter unity-gtk-module-common unity-gtk2-module unity-gtk3-module
  unity-lens-applications unity-lens-files unity-lens-friends unity-lens-music
  unity-lens-photos unity-lens-video unity-scope-audacious
  unity-scope-calculator unity-scope-chromiumbookmarks unity-scope-clementine
  unity-scope-colourlovers unity-scope-devhelp unity-scope-firefoxbookmarks
  unity-scope-gdrive unity-scope-gmusicbrowser unity-scope-gourmet
  unity-scope-guayadeque unity-scope-home unity-scope-manpages
  unity-scope-musicstores unity-scope-musique unity-scope-openclipart
  unity-scope-texdoc unity-scope-tomboy unity-scope-video-remote
  unity-scope-virtualbox unity-scope-yelp unity-scope-zotero
  unity-scopes-master-default unity-scopes-runner unity-services
  unity-webapps-service
0 upgraded, 182 newly installed, 0 to remove and 0 not upgraded.
Need to get 72.4 MB of archives.
After this operation, 229 MB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-session-flashback (not installed)
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
CasperVersion: 1.336
Date: Sat Sep 7 14:18:29 2013
LiveMediaBuild: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130903)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Reassigning to indicator-keyboard since this looks like the first place to check.

description: updated
summary: - gnome-session-flashback suffers dependency hell
+ Installing gnome-session-flashback also installs Unity
affects: gnome-panel (Ubuntu) → indicator-keyboard (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.7.15-0ubuntu1

---------------
lightdm (1.7.15-0ubuntu1) saucy; urgency=low

  [ Jeremy Bicha ]
  * Have liblightdm-gobject-1.0 suggest not recommend lightdm
    (LP: #1222155)

  [ Michael Terry ]
  * Set XDG_VTNR=1 as a fallback if using SeatUnity without a functioning
    compositor or working VT switching, so that logind will recognize the VT
    as active.
 -- Michael Terry <email address hidden> Wed, 11 Sep 2013 11:27:51 -0400

Changed in lightdm (Ubuntu):
status: New → Fix Released
Jeremy Bicha (jbicha)
no longer affects: indicator-keyboard (Ubuntu)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers