lightdm crashed with SIGSEGV in quit_timeout_cb()

Bug #1207935 reported by Fabio Della Lena
44
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Fix Released
Medium
Unassigned
1.2
Fix Released
Medium
Unassigned
lightdm (Ubuntu)
Fix Released
Medium
Robert Ancell
Precise
Fix Released
Medium
Unassigned

Bug Description

..

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: lightdm 1.7.8-0ubuntu1
Uname: Linux 3.11.0-031100rc3-generic x86_64
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Wed Jul 31 00:29:44 2013
ExecutablePath: /usr/sbin/lightdm
InstallationDate: Installed on 2011-07-23 (738 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
LightdmConfig:
 [SeatDefaults]
 greeter-session=unity-greeter
 user-session=ubuntu
 autologin-user=
MarkForUpload: True
ProcCmdline: lightdm
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SegvAnalysis:
 Segfault happened at: 0x40e47d: movl $0x0,0x20(%rax)
 PC (0x0040e47d) ok
 source "$0x0" ok
 destination "0x20(%rax)" (0xaaaaaaaaaaaaaaca) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: lightdm
StacktraceTop:
 ?? ()
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: lightdm crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: Upgraded to saucy on 2013-07-10 (19 days ago)
UserGroups:

Revision history for this message
Fabio Della Lena (fdellalena) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 quit_timeout_cb (process=0x1668970, process@entry=<error reading variable: value has been optimized out>) at process.c:254
 g_timeout_dispatch (source=source@entry=0x1690700, callback=<optimized out>, user_data=<optimized out>) at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:4443
 g_main_dispatch (context=0x1664fc0) at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3058
 g_main_context_dispatch (context=context@entry=0x1664fc0) at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3634
 g_main_context_iterate (context=0x1664fc0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3705

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in lightdm (Ubuntu):
importance: Undecided → Medium
summary: - lightdm crashed with SIGSEGV in g_main_context_dispatch()
+ lightdm crashed with SIGSEGV in quit_timeout_cb()
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in lightdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
status: Confirmed → Triaged
Changed in lightdm:
status: New → Fix Released
importance: Undecided → Medium
milestone: none → 1.8.1
Changed in lightdm (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.8.1-0ubuntu1

---------------
lightdm (1.8.1-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Fix crash where Process objects are accessed after unref (LP: #1207935)
 -- Robert Ancell <email address hidden> Thu, 10 Oct 2013 20:34:13 +1300

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
Changed in lightdm (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → Medium
tags: added: verification-done
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Fabio, or anyone else affected,

Accepted lightdm into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lightdm/1.2.3-0ubuntu2.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.2.3-0ubuntu2.7

---------------
lightdm (1.2.3-0ubuntu2.7) precise; urgency=medium

  * debian/patches/15_gsources.patch:
    - Correctly remove GSources on finalize (LP: #1431654)

lightdm (1.2.3-0ubuntu2.6) precise; urgency=medium

  * debian/patches/09_close_pipes.patch:
    - Close pipes correctly (LP: #1190344)
  * debian/patches/10_conf_section_name.patch:
    - Correct section name in default users.conf (LP: #1069218)
  * debian/patches/11_quit_timeout.patch:
    - Destroy quit timeout when a process object is destroyed - fixes a crash
      where a deleted Process object might be accessed after a timeout
      (LP: #1207935)
  * debian/patches/12_layout_no_x11.patch:
    - Handle not getting an X connection when attempting to get X layouts
      (LP: #1235915)
  * debian/patches/13_introspection_makefile.patch:
    - Fix introspection build with newer versions of g-ir-scanner
  * debian/patches/14_compile_warnings.patch:
    - Fix compile warnings
 -- Robert Ancell <email address hidden> Tue, 17 Mar 2015 14:21:43 +1300

Changed in lightdm (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Chris J Arges (arges) wrote : Update Released

The verification of the Stable Release Update for lightdm has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers