lightdm does not start on boot since change to use plymouth-ready (precise)

Bug #1188131 reported by aj duncan on 2013-06-06
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Lightdm fails to start on boot up, resulting in a blank screen.

Lightdm can be started manually from tty1, for example, after the machine has been booted up.

If the default browser is set to gdm, then gdm starts up on boot.

This problem first arose immediately after upgrade to 3.2.0-45-generic (from 3.2.0-44) in Ubuntu 12.04.2 LTS

I have tried, to no avail,

1. Moving etc/X11/xorg.conf to a backup
2. uninstalling unity-greeter, lightdm, lightdm-gobject-1-0
3. deleting /etc/lightdm and /var/lib/lightdm
4. rebooting and reinstalling unity-greeter, lightdm, lightdm-gobject-1-0
5. Adding the line "sleep 2" immediately before "exec lightdm" in /etc/init/lightdm.conf
6. Checking that /etc/X11/default-display-manager says "/usr/sbin/lightdm"

After reinstalling all the above it was necessary to change ownership of .Xauthority from root to my userid, to
allow lightdm to accept a password. After this lightdm still works but still does not start up on boot.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lightdm 1.2.3-0ubuntu2.1
ProcVersionSignature: Ubuntu 3.2.0-45.70-generic-pae 3.2.44
Uname: Linux 3.2.0-45-generic-pae i686
ApportVersion: 2.0.1-0ubuntu17.2
Architecture: i386
Date: Thu Jun 6 11:35:30 2013
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: Upgraded to precise on 2012-04-29 (403 days ago)

aj duncan (a-duncan) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Lindsay (fmouse) wrote :

I can confirm this bug, but have tried several stored kernels going back to 3.2.0-29-generic and the problem doesn't seem to be related to the kernel version. I note that a new version of lightdm came out several days ago and perhaps the problem is there.

As a fairly acceptable workaround for this problem, enable /etc/rc.local and add the following lines to it:

/sbin/start lightdm
exit $?

The workaround works perfectly, thanks.

I forgot to mention in the bug report that I had tried previous
kernel versions, which didn't work for me either.

On 06/06/13 20:47, Lindsay wrote:
> I can confirm this bug, but have tried several stored kernels going back
> to 3.2.0-29-generic and the problem doesn't seem to be related to the
> kernel version. I note that a new version of lightdm came out several
> days ago and perhaps the problem is there.
>
> As a fairly acceptable workaround for this problem, enable /etc/rc.local
> and add the following lines to it:
>
> /sbin/start lightdm
> exit $?
>

This seems to be caused by the following change in lightdm upstart configuration (introduced in 1.2.3-0ubuntu2.1):

$ diff init.working/lightdm.conf init.broken/lightdm.conf
14,15c14
< and (drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1
< or stopped udev-fallback-graphics))
---
> and plymouth-ready)

Sebastien Bacher (seb128) wrote :

thanks for your bug report, some similar issues are being discussed on the SRU bug, do you have a /etc/init/plymouth-splash.conf?

summary: - lightdm does not start on boot
+ lightdm does not start on boot since change to use plymouth-ready
+ (precise)
Changed in lightdm (Ubuntu):
importance: Undecided → High
Changed in lightdm (Ubuntu Precise):
importance: Undecided → High

Yes, I have /etc/init/plymouth-splash.conf

Its contents are:

description "Userspace bootsplash"

start on (started plymouth
           and (graphics-device-added PRIMARY_DEVICE_FOR_DISPLAY=1
                or drm-device-added PRIMARY_DEVICE_FOR_DISPLAY=1
                or stopped udev-fallback-graphics))

exec /bin/plymouth show-splash

On 10/06/13 08:53, Sebastien Bacher wrote:
> thanks for your bug report, some similar issues are being discussed on
> the SRU bug, do you have a /etc/init/plymouth-splash.conf?
>
> ** Summary changed:
>
> - lightdm does not start on boot
> + lightdm does not start on boot since change to use plymouth-ready (precise)
>
> ** Changed in: lightdm (Ubuntu)
> Importance: Undecided => High
>
> ** Also affects: lightdm (Ubuntu Precise)
> Importance: Undecided
> Status: New
>
> ** Changed in: lightdm (Ubuntu Precise)
> Importance: Undecided => High
>

Lindsay (fmouse) wrote :

I can confirm Tomasz Miąsko's observation. I changed the startup stanza in lightdm.conf to:

start on ((filesystem
           and runlevel [!06]
           and started dbus
           and (drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1
                or stopped udev-fallback-graphics))
           or runlevel PREVLEVEL=S)

and lightdm starts as expected.

Lindsay (fmouse) wrote :

See these pages:

   https://launchpad.net/ubuntu/+source/lightdm/1.6.0-0ubuntu2.1

   http://www.ubuntuupdates.org/package/core/raring/main/proposed/plymouth

It looks as if changes to lightdm.conf have outstripped changes to plymouth.

Steve Langasek (vorlon) wrote :

On Thu, Jul 11, 2013 at 09:25:52PM -0000, Lindsay wrote:
> See these pages:

> https://launchpad.net/ubuntu/+source/lightdm/1.6.0-0ubuntu2.1

> http://www.ubuntuupdates.org/package/core/raring/main/proposed/plymouth

> It looks as if changes to lightdm.conf have outstripped changes to
> plymouth.

No. plymouth 0.8.8-0ubuntu6.1 is also in raring-updates. If you're seeing
problems with lightdm startup, check that you don't have missing or modified
upstart jobs for the plymouth package ('debsums -s -e plymouth').

Robert Ancell (robert-ancell) wrote :

Closing assumed fixed.

Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
Changed in lightdm (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers