Login screen sometimes fails to appear when booting computer

Bug #1173231 reported by Bruno Girin on 2013-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Undecided
Unassigned

Bug Description

When booting my laptop, the screen alternates between the Ubuntu logo and a black screen a couple of times before showing the login screen. Occasionally, the login screen does not appear and a black screen with just the mouse cursor appears instead.

I'm not sure whether this is a lightdm problem or a race condition during boot or any other issue but I'm happy to debug if someone can give me pointers on how to investigate the problem.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: lightdm 1.6.0-0ubuntu2.1
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Fri Apr 26 16:04:26 2013
InstallationDate: Installed on 2013-03-24 (32 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
LightdmConfig:
 [SeatDefaults]
 user-session=ubuntu
 greeter-session=unity-greeter
MarkForUpload: True
SourcePackage: lightdm
UpgradeStatus: Upgraded to raring on 2013-03-24 (32 days ago)

Bruno Girin (brunogirin) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Jason Gerard DeRose (jderose) wrote :

We're seeing this issue on various System76 products. A few patterns we've spotted:

1) It happens more frequently on systems that boot very quickly (fast CPU, fast SSD)

2) On the same system, it seems to happen more often if in UEFI mode than in BIOS mode (perhaps because the UEFI boot is just faster)

3) It never seems to happen when you use auto-login (we use auto-login for automated reboot tests, so I'm quite confident this only occurs with manual login)

Jason Gerard DeRose (jderose) wrote :

Ah, I think this is a duplicate of this:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/982889

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers