Quantal-LTS-stack: Showing low-resolution screen on shutdown/reboot

Bug #1086345 reported by Stefan Bader on 2012-12-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
James M. Leddy
Precise
Critical
Unassigned
libdrm (Ubuntu)
Undecided
Unassigned
Precise
Critical
Maarten Lankhorst
lightdm (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Hardware is an Hashwell SDP with an Intel SSD. Fresh install from 12.04.1 alternate image, then added the quantal-lts kernel and the x-stack (ppa:ubuntu-x-swat/q-lts-backport, pulled via xserver-xorg-lts-quantal meta package). Monitor is connected to VGA.

With the new stack graphics on VGA does actually work and the system snaps from the grub-efi prompt to lightdm in a blink (2s at most which probably can be attributed to the Intel SSD). Everything is fine and the system definitely is running in a high resolution mode.

However when shutting down or rebooting, the system drops into a screen telling me it is running in low-resolution mode instead of showing plymouth (or the terminal). The system will continue to shut down or reboot even without pressing the ok button, but it can be done for a bit and then would show the next screen about how to resolve the issue. I was not quick or daring enough to go on from the second screen.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: plymouth 0.8.2-2ubuntu30
ProcVersionSignature: Ubuntu 3.5.0-20.31~hswv4-generic 3.5.7
Uname: Linux 3.5.0-20-generic x86_64
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
Date: Tue Dec 4 12:44:55 2012
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120822.4)
Lsusb:
 Bus 001 Device 002: ID 0b39:cd02 Omnidirectional Control Technology, Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
MachineType: Intel Corporation Shark Bay Client platform
MarkForUpload: True
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-20-generic root=UUID=b77c2e0f-0611-4b74-9319-0c5c92b55a69 ro quiet splash
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-20-generic root=UUID=b77c2e0f-0611-4b74-9319-0c5c92b55a69 ro quiet splash
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/05/2012
dmi.bios.vendor: Intel Corporation
dmi.bios.version: HSWLPTU1.86C.0086.R00.1208052028
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Flathead Creek Crb
dmi.board.vendor: Intel Corp.
dmi.board.version: 1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 3
dmi.chassis.vendor: Intel Corporation
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnIntelCorporation:bvrHSWLPTU1.86C.0086.R00.1208052028:bd08/05/2012:svnIntelCorporation:pnSharkBayClientplatform:pvr0.1:rvnIntelCorp.:rnFlatheadCreekCrb:rvr1:cvnIntelCorporation:ct3:cvr0.1:
dmi.product.name: Shark Bay Client platform
dmi.product.version: 0.1
dmi.sys.vendor: Intel Corporation

Stefan Bader (smb) wrote :
Steve Langasek (vorlon) wrote :

plymouth can't run because the console is still in use by an X server - not the usual one, but the one launched by /etc/init/failsafe-x.conf because the lightdm job exited abnormally. Maybe this is a bug in the X server itself, or maybe it's a bug in lightdm. Reassigning.

affects: plymouth (Ubuntu) → lightdm (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

attach /var/log/Xorg.0.log.old after reboot, which should show if it has crashed during shutdown

Stefan Bader (smb) wrote :

Here you go...

Timo Aaltonen (tjaalton) wrote :

yep, the xserver exited normally, so it's not that..

Tim Chen (timchen119) wrote :

We got some haswell platforms here and met same issues.

It keeps showing the warning
plymouthd: intel_bufmgr_gem.c:2783: drm_intel_bufmgr_gem_init: Assertion `0' failed.
in the log,
however there's no such code in the libdrm-ltsq2.

Track it a bit It seems that libdrm-ltsq-intel1 didn't replaced libdrm-intel1
then I repack libdrm from the quantal's branch for precise ,
and it fixed the issue. the logo did appear again.

I'm thinking maybe there should be a plymouth lts version which links to libdrm-ltsq2 or those libdrm-ltsq2 version should replace all the old version of libdrm.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in libdrm (Ubuntu):
milestone: none → ubuntu-12.04.2
assignee: nobody → Maarten Lankhorst (mlankhorst)
importance: Undecided → Critical
Changed in lightdm (Ubuntu):
status: Confirmed → Invalid
Changed in libdrm (Ubuntu):
status: New → In Progress
Maarten Lankhorst (mlankhorst) wrote :

Either a bug in plymouth, or libdrm. Thanks for finally giving me data to back up my suspicion that renaming was a bad idea.

There are 2 possible paths forward:
- Plymouth always using the 'dumb' api, if available. This will probably need a new version of plymouth, however, and only has been the default on raring.
- Drop libdrm renaming, and just upload a new libdrm version. The only reason to put it in was for making plymouth pick up on the old libdrm anyway.

The third option, renaming plymouth, is nearly impossible without changing a LOT of packages.

Eventually we'll need to do the former, but I think for now we don't want to do that since it's only been the default in raring. As such I believe we should wait until the raring release before we do that, since I'm not comfortable just uploading a complete new version of plymouth this late in the cycle.

Colin Watson (cjwatson) on 2013-01-18
Changed in lightdm (Ubuntu Precise):
status: New → Invalid
Changed in libdrm (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Maarten Lankhorst (mlankhorst)
milestone: none → ubuntu-12.04.2
Changed in libdrm (Ubuntu):
status: In Progress → Invalid
importance: Critical → Undecided
assignee: Maarten Lankhorst (mlankhorst) → nobody
milestone: ubuntu-12.04.2 → none

Hello Stefan, or anyone else affected,

Accepted libdrm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libdrm/2.4.39-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libdrm (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
importance: Undecided → High
importance: High → Critical
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

worked fine here

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdrm - 2.4.39-0ubuntu0.1

---------------
libdrm (2.4.39-0ubuntu0.1) precise-proposed; urgency=low

  * Copy libdrm from quantal. (LP: #1086345)
 -- Maarten Lankhorst <email address hidden> Fri, 18 Jan 2013 16:30:10 +0100

Changed in libdrm (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers