Ubuntu

lightdm doesn't load correctly on Ubuntu 12.10

Reported by zubozrout on 2012-10-13
384
This bug affects 81 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 12.10 doesn't load correctly because lightdm shows only a mouse pointer and a blinking command-line cursor.
I don't know if this is only Ubuntu 12.10 specific bug, because a similar error appeared on my friend's computer back in 2011 on Ubuntu 11.10. However, switching to a command line and restarting lightdm solves the problem per instance. Also rebooting the device solves it, but also only for the specific boot. Another reboot ends with the same "black screen with a working mouse pointer and a blinking cursor".

I am using Asus Zenbook ux32vd (Intel HD Graphics 4000 + not used Nvidia GT620M - Optimus technology).

Tags: 232 Edit Tag help
zubozrout (zubozrout) wrote :

Ok, so with the latest boot I ended up with a similar screen but this time only cursor was visible on a blank black screen. However I can still temporarily solve it by restarting lightdm process.

zubozrout (zubozrout) wrote :

The possible solution for this is to apt-get purge lightdm pakage and then install it again. However, I am not sure if this will work permanently yet. I will disable the bug later this week if all goes well. The probable reason for this may be some bad configuration that didn't work with the latest lightdm release. If so, it does not affect the final release.

zubozrout (zubozrout) wrote :

I am disappointed I can't close the bug. The problem still persists. The reinstallation of lightdm package affected only first 3 boots after the procedure, but it no longer seems to make any effect.
In addition, I've noticed that my mouse pointer is not only visible on virtual terminal 7, but also on every other terminals. How could that be so? However, I can't use the mouse on vt1 through 6.

I now assume everything works correctly except the fact I can't see anything (only a cursor) and the cursor is visible on all virtual terminals independently.

I can login in lightdm even though I don't see anything, even after unity loads. (lightdm, xorg, compiz - those all works, but for some reason I've got almost blank screen on vt7).

To get my screen working I have to either kill lightdm and then start it again, or login through lightdm I don't see and then kill the gnome-session.

Shamil (shamil-si) wrote :

Exactly same happens to me. Sometimes the lightdm able to load properly, but 90% persent of boots it goes black terminal screen weth mouse cursor. In roder to resolve this I going to terminal (alt+f1) and 'sudo restart lightdm'. Only then the login screen apears.

I've Dell XPS 14 Ultrabook (l421x) with Nvidia 630M (Optimus) and Intel HD4000. No nvidia proprietary drivers used and nouveau drivers are blacklisted. So only Intel is in use. btw when it works I've no other issues. (except of Nvidia optimus of course, but hit is a different issue).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Robert (web-ubuntu) wrote :

Same problem here (12.10 64Bit).

Restarting lightdm didn't work for me. All I got was this black screen with a blinking cursor. To get to a working desktop anyway, I (temporarily) switched to gdm by doing:

1. [alt+f1]
2. $ sudo apt-get install gdm
3. restart machine. when gdm loginscreen comes up, select ubuntu (instead of system defaults).

To switch back to ligthdm, when its working again, you can run:

$ sudo dpkg-reconfigure lightdm

Charles Profitt (cprofitt) wrote :

Try modifying your /etc/init/lightdm.conf to the following (adding the sleep 2 line):

# LightDM - light Display Manager
#
# The display manager service manages the X servers running on the
# system, providing login and auto-login services
#
# based on gdm upstart script

description "LightDM Display Manager"
author "Robert Ancell "

start on ((filesystem
and runlevel [!06]
and started dbus
and (drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1
or stopped udev-fallback-graphics))
or runlevel PREVLEVEL=S)

stop on runlevel [016]

emits login-session-start
emits desktop-session-start
emits desktop-shutdown

script
if [ -n "$UPSTART_EVENTS" ]
then
# Check kernel command-line for inhibitors, unless we are being called
# manually
for ARG in $(cat /proc/cmdline); do
if [ "$ARG" = "text" ]; then
plymouth quit || :
stop
exit 0
fi
done

[ ! -f /etc/X11/default-display-manager -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/bin/lightdm" -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/lightdm" ] || { stop; exit 0; }

if [ "$RUNLEVEL" = S -o "$RUNLEVEL" = 1 ]
then
# Single-user mode
plymouth quit || :
exit 0
fi
fi
sleep 2
exec lightdm
end script

post-stop script
if [ "$UPSTART_STOP_EVENTS" = runlevel ]; then
initctl emit desktop-shutdown
fi
end script

Robert (web-ubuntu) wrote :

Adding the "sleep 2" doesnt work.

Lightdm started once, but not again after.

dozsi (dozsabalint) wrote :

Adding the "sleep 2" is working for me! When i comment out the "sleep 2" line, lightdm won't starting again. Then the "sudo /etc/init.d/lightdm restart" helps me.

marcus (marcus256) wrote :

Have a very similar (probably same) problem on my fresh Ubuntu 12.10 installation. My system boots form an SSD drive, and it's using nvidia-current-updates (GeForce 9600 card).

It looks as if things work OK sometimes when I reboot, or I can manually just start lightdm from a ctrl+alt+F5 terminal.

dozsi (dozsabalint) wrote :

marcus: same problem here. I also have an SSD (Samsung 128GB). Booting from HDD: everything is ok!

Robert (web-ubuntu) wrote :

I also have a SSD Drive (Intel 320). Not sure if that is connected to this bug.
I increased the sleep time to 5 to see what happens. All I got was still a black screen...

marcus (marcus256) wrote :

To summarize my system (what I think might affect the boot process up until lightdm):

- 64-bit Ubuntu 12.10
- Boot from 60 GB SSD (have mounted "/"on it)
- I have an HDD with 1 NTFS partiotion & 1 ext4 partition mounted (in /mnt/...)
- I use GNOME shell rather than Unity (but still lightdm, not gdm)
- CPU is AMD Athlon x2 4850e
- I have three OS:es in my GRUB menu (Ubuntu 12.10 + Win XP + Ubuntu 10.10)

I have not spent enough time to see any pattern in when the boot process works or not. It seems to be about 50% chance that a boot will succeed or not (if not, I end up with the console + blinking cursor right before lightdm should have started).

dozsi (dozsabalint) wrote :

before October 19:
 - 64-bit Ubuntu 12.10 (updated from Ubuntu 12.10 beta-2)
 - Boot from 750GB HDD
 - Intel Core i5 Sandy Bridge CPU
 - Intel HD3000 VGA
 - LightDM is working well

after October 19:
 - 64-bit Ubuntu 12.10 (fresh install)
 - Boot from 128GB SSD
 - Intel Core i5 Sandy Bridge CPU
 - Intel HD3000 VGA
 - LightDM does not always start

zubozrout (zubozrout) wrote :

@dozsi:
On my device it was opposite. I updated from 12.04 to 12.10 and lightdm stopped working.
Now I run a fresh installation of Ubuntu 12.10 and it works great.

dozsi (dozsabalint) wrote :

@zubozrout
I reinstalled the Ubuntu with Unetbootin instead of "Startup Disk Creator" and everything is ok!

zubozrout (zubozrout) wrote :

@dozsi:
That is weird :)
I wonder whether it was luck or if there is a difference when installing Ubuntu loaded from a live USB created with Unetbootin or Startup Disk Creator. In my case, I used the default SDC and it works well.

dozsi (dozsabalint) wrote :

@zubozrout:
:)
The Startup Disk Creator is crashing after installing bootloader...

Agent24 (tda7000) wrote :

I also have this problem.

I just did a fresh install of Ubuntu 12.10 using the Mini ISO and installed only base system and the Lubuntu Minimal task.

marcus (marcus256) wrote :

I tried the "sleep 2" trick, and it seems much more stable now (haven't had a single hick-up yet). Doesn't seem like a real solution though.

On another note - I don't see the plymouth screen (not on boot and not on shut-down). On boot-up, I only see a console log-in prompt, and on shut-down I see the textual shut-down log.

Ken Weiner (kweiner) wrote :

I also have this same problem. I did a fresh install of Ubuntu 12.10 from a DVD on a System76 laptop.

Juergen Menge (juergenmenge) wrote :

I have the same problem after upgrading Ubuntu 12.04 to 12.10 on a Lenovo Thindpad T430.
Inserting "sleep 2" helped.

Patrick Sébastien (11h11) wrote :

Same problem here only happening with my SSD. I am sure there's a better way to fix this issue (sleep 2 fix the problem, but i am now loosing 11 minutes and 2 seconds per year).

jbeezo (jbeezo) wrote :

Same problem on my new machine after a fresh 12.10 install.
MB: MSI Z77A-G43
CPU: i5-3570K
GPU: Onboard Intel HD 4000
SSD: Patriot Inferno (SF-1222)

On my laptop (Aspire 5750 w/i7-2630QM using onboard graphics) with an upgrade from 12.04 to 12.10, also using an SF-1222 based SSD, I'm NOT seeing the issue.

Donjan Rodic (bryonak) wrote :

Same bug here, booting from an OCZ Vertex 3 SSD, 10 out of 10 starts drop me to a irresponsive prompt + mouse cursor (restart lightdm from another virtual console works).
The dirty workaround via sleep (1 second for me) gives a lightdm login prompt 10/10 times, so far. But apart from increasing OS boot time by roughly 50% ( ;) ), this just doesn't feel like the proper way to do it...

Thiago Morato (thiagomorato) wrote :

sorry guys, I do not speak English, but I'll make my first post, on my machine zenbook ux31e also happens that problem, but I noticed a problem with preload, apt-get install preload, removed and stopped giving these problems, can you tell me if on their PCs have this program installed. Again sorry for my english.

jbeezo (jbeezo) wrote :

Further to post #24, since I'm already using gnome-shell as my primary DE, the workaround (more of an alternative than a workaround) I employed was to switch to gdm.
$ sudo dpkg-reconfigure gdm

I lost the pretty login, but gained a working Lockscreen. Lockscreen was also failing to do anything when selected while logged in with lightdm.

Alex Gontmakher (gsasha-gmail) wrote :

Same here (Lenovo Thinkpad Carbon X1)

Cee Gee (cynicalgargoyle) wrote :

It seems like a lot of these issues are on comps with SSD. I have an SSD as well. I experience this issue.

Other things that work,
Moving the mouse around until the cursor changes for input text, clicking and entering my password = allows me to log in.

Pressing the power button, then hitting the enter key shuts down the computer.

Cee Gee (cynicalgargoyle) wrote :

Just restarted after making that "sleep 2" change and it seemed to work. Splash screen no longer shows up, but lightDM starts flawlessly.

Simone Campanoni (simo-xan) wrote :

Same problem here (Lenovo Thinkpad Carbon X1).
It seems to be a race condition in lightDM. Maybe that's why it happens more often for SSD (SSD are much faster than HDD).

Mathieu Laurent (mla) wrote :

Same problem for me, since the upgrade to 12.10 (Asus Zenbook UX31E)

Alex Kon (alkon) wrote :

Same problem here with similar specs.

12.10 (64bit), Intel I7 Ivy Bridge with HD4000, 64GB SSD.

If I play around with the keyboard (random keys) long enough lightdm sometimes eventually appears.

Completely new install with full updates.

pablo klijnjan (pabloklijnjan) wrote :

Same problem here, also SSD drive.
Full specs:

- Lenovo e520 with 8G ram
- SSD Crucial m4 128
- Ubuntu 12.10 64 Bit, clean install

Ubuntu 12.04 was working perfectly on this regard.

John Brondum (johnbrondum) wrote :

I have the same issue on a Lenovo T530 (with a normal old disk) - I have also seen them well after start-up, where the laptop screen will suddenly switch to "black screen with text and mouse pointer", while my external monitor remains as before (see bug 1077516)

panmari (panmari) wrote :

Same here (Lenovo X1 Carbon, SSD). Issue started with update to 12.10, never had an issue with 12.04. Inserting sleep 2 seems to fix it

Kristopher (kristopher-h) wrote :

Seems the issue was not solved after adding the sleep line after all. Sometimes it works sometimes not. Tried increasing sleep as well, but same result. Back to starting lightdm manually when it is not working....

Gavin Graham (gavingraham) wrote :

It certainly looking like some kind of race condition when SSDs are involved. Adding a "sleep x" command doesn't help no matter how many seconds I tell it to sleep for.
Also starting lightdm manually (instead of using the init script) more often fails than succeeds. This confirms for me that it isn't just a script problem, rather, it looks as if it is somewhere in the Xorg binaries or a deeper script somewhere I suppose.

Agent24 (tda7000) wrote :

If it's a race condition with SSDs why did I have the problem on an old Celeron machine with an ancient ATA-33 hard drive?

Alex Kon (alkon) wrote :

@Agent24: Old HDD's are also susceptible to "race" condition bugs. It just means one process is loading faster than another in a multi-process system. If one process requires another as a precondition to run correctly then the necessary checks should be made in the code.

renato (rbermudes) wrote :

Same problem here with a clean install xubuntu 12.10 running kernel 3.5.0-18-generic.

Dell XPS 15 L502X
SSD crucial m4 256gb
16GB Ram
Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz
[GeForce GT 540M] working only with bumblebee

Gavin Graham (gavingraham) wrote :

After a surprising 5 successful restarts with 'sleep 6' added into /etc/init/lighdm.conf file, I thought that some recent updates might have fixed it. I've kept an eye on the updates that were being applied and they don't look to be related but hey, the proof was in the pudding - five successful restarts.

I then commented out the 'sleep 6' and Lightdm is back to being a recalcitrant and not starting. Adding 'sleep 6' back in got it going again.

I suspect that after my hybrid HDD starts caching again that it will break due to some race condition.

For me previously, it sometime wont even start when I execute 'sudo lightdm' from the command-line. When it fails after trying to manually start it, I have a series of about 20 "Error writing to daemon: Broken pipe" messages appear on the console.

I've attached my /var/log/lightdm/x-0-greeter.log file. It looks as if the broken pipe message may have some relationship to DBUS.

Gavin Graham (gavingraham) wrote :

Ok all, I've done some digging around it Lightdm is trying to start before UDEV reports the graphics devices as being ready. Please see #969489

By adding 'and stopped udevtrigger to lightdm.conf has fixed the issue for me.

/etc/init/lightdm.conf:

start on ((filesystem
           and runlevel [!06]
           and started dbus
 #Added the following line
           and stopped udevtrigger
           and (drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1
                or stopped udev-fallback-graphics))
          or runlevel PREVLEVEL=S)

There is opinion that UDEV needs the full path to 'card0' but I suggest that for those with more than one graphics card (eg. Optimus) that a race condition could happen if your nVidia appears first. I don't know yet if this is possible though, someone with a better understanding than me of UDEV would have to comment on that.

Either way, I'm inclined to mark this ticket as a duplicate of #969489 as it is an older ticket with more substance. This ticket has a lot more heat so can I suggest that you all head over to the other ticket and mark it as affecting you?

powerarmour (powerarmour) wrote :

Same issue with me on Ubuntu 12.10 with the following hardware :-

Intel Core i3-3225 (w/HD 4000)
8GB Corsair Vengeance DDR3-1866
ASRock H77M-ITX motherboard
Corsair F40 40GB SSD

On most cold boots now LightDM is failing to start, and will just display the standard display reconfigure message (which obviously doesn't actually do anything other than boot you to a terminal)

I have to start LightDM manually 'sudo lightdm' and once it's initialised everything is fine again, and I can even reboot the system and LightDM will usually start (occasionally it will still fail on a reboot).

Giuseppe Fierro (gspe) wrote :

Same issue with me on Ubuntu 12.10.

I can't understand why this bug hasn't hight priority.
It's very frustrating when you want to show the power of Ubuntu to your friends and the system doesn't start.
It's very very annoying

Thanks

Eric Young (elouisyoung) wrote :

This is absolutely a race condition. I am currently solving the issue with a "sleep 1" before exec lightdm.
Someone please fix the actual code and push an update.

Karma Dorje (taaroa) wrote :

@Eric Young

Remember, this bug report is a duplicate of bug #969489.
Comment here only if you think the duplicate status is wrong.

Steffen Sindzinski (stesind) wrote :

I have the same problem but btrfs as filesystem on a normal hard disk. The btrfs overhead seems to slow down the boot and lightdm is respawning once then exiting. Switching to btrfs raid 0 seems to fix but I want raid 1 or no raid at all.

Babar (babarhaq) wrote :

#7 (sleept 2) worked for me on lenovo x230 ubuntu 12.10

Uriel Fanelli (uriel-fanelli) wrote :

Hello, seems the problem falls back from the X windows server. I just generated a new xorg.conf using X -configure and saving the output file in /etc/X11/xorg.conf, and then magically it started working with any dm.

Before there was no xorg.conf at all inside the folder.

Worked for me with a HP G62 double board intel/ATI.

Julian Lim (intelux) on 2013-05-08
tags: added: 232
Pierre van Male (vmalep) wrote :

This apparently fixed the problem for me (at least on the next reboot...):

sudo apt-get remove --purge lightdm
sudo apt-get install lightdm ubuntu-desktop

Cheers,
Pierre

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions