LightDM doesn't handle Lock Screen or Switch Session for GNOME Shell 3.5

Bug #1042907 reported by Jeremy Bicha on 2012-08-28
140
This bug affects 31 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
High
gnome-shell (Ubuntu)
Low
Unassigned
lightdm (Ubuntu)
Medium
Unassigned

Bug Description

With GNOME Shell 3.5.90, gnome-shell depends on GDM or at least some GDM methods for the lock screen and user switching functionality. With GDM installed and using LightDM, it's possible to log into GNOME Shell. The Switch Session button doesn't do anything. If you lock the screen, you won't be able to unlock it.

It would be great if LightDM could support this so we don't have to try to find an ugly hack to work around it. It would need to work in at least unity-greeter, but it would be cool if the KDE & GTK greeters would work too as they're being shipped by Kubuntu & Xubuntu.

I pushed the gnome-shell packaging updates to https://code.launchpad.net/~ubuntu-desktop/gnome-shell/ubuntu

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: lightdm 1.3.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-13.13-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
CheckboxSubmission: 201084ed41ea7548f8becd47fa4d1e6c
CheckboxSystem: c541d13ea4f205f2fd751f76ed21105b
Date: Tue Aug 28 14:50:44 2012
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Robert Ancell (robert-ancell) wrote :

I'm not going to provide this interface in LightDM due to:
- All other DMs will have the same problem
- The interface is GDM specific
- (as I understand it) It allows a session process to run PAM calls remotely to authenticate. This is questionable security and opposes the design we have in LightDM for the login screen to be the lock screen.
- The interface is not trivial

So the solution as I see it is we will have to patch gnome-shell to handle not running inside GDM. The options are probably.

1. Not entering lock screen if the GDM interface is not present. This means no lock screen but is logical (no point locking if you know you can't unlock).
2. If the GDM interface is not present then falling back to the old gnome-screensaver method of unlocking. This means running the PAM calls yourself to authenticate. You can't authenticate as anyone but yourself and it's always been a bit of a hack (PAM generally assumes root access, the modules handle running as non-root for this case specifically).

Changed in lightdm (Ubuntu):
status: New → Won't Fix
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in gnome-shell:
importance: Unknown → High
status: Unknown → New
Jeremy Bicha (jbicha) wrote :

I'm lowering the severity of this bug since gnome-shell 3.5.91-0ubuntu1 now won't refuse to unlock if LightDM is used.

It will however make your screen appear locked but you won't need a password to unlock it, so that's still a bug but not as critical. Discussion is still continuing on the GNOME bug.

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
importance: High → Low
status: Fix Released → Triaged
Fred (eldmannen+launchpad) wrote :

Okay, what about the dependency on xserver-xephyr?

Jeremy Bicha (jbicha) wrote :

Fred, gdm recommends xserver-xephyr; you can uninstall it afterwards if you don't want it.

Daniel Holbert (dholbert) wrote :

> It will however make your screen appear locked but you won't
> need a password to unlock it, so that's still a bug but not as critical.

IMHO that's still pretty critical. (Way higher than "Low", IMHO)

In an office environment, it's pretty important to be able to lock your screen when you step away from your desk -- otherwise, a casual passerby can just walk up and have full, logged-in access to your machine (and your unencrypted home directory), and that's Pretty Bad.

Leander Koornneef (bugs-h) wrote :

I agree with Daniel here. Not being able to lock the screen is a rather critical bug, in my opinion. Can we at least expect this to be sorted out before the release of Quantal?

Anders Kaseorg (andersk) on 2012-09-18
tags: added: regression-release
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.5.92-0ubuntu1

---------------
gnome-shell (3.5.92-0ubuntu1) quantal; urgency=low

  * New upstream RC release.
    - If GDM is not running, gnome-screensaver is used for screen
      locking (LP: #1042907)
    - Message tray is now keyboard accessible with Super+M
    - And many more fixes
  * debian/control.in: Bump minimum mutter
  * debian/patches/90_dont-lock-without-gdm.patch:
    - Dropped, improved fix applied in new version
 -- Jeremy Bicha <email address hidden> Wed, 19 Sep 2012 11:12:56 -0400

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-shell:
status: New → Fix Released

At the moment of writing this comment the fix does not seem to work for me.

I use lightdm and gnome-shell.

After I lock manually from command line:

gnome-screensaver-command -l

the "Lock screen" button starts working. But before this, I'm unable to lock the screen normally (with a session-menu button).

Dan Hallgren (danha891) wrote :

I'm running gnome-shell version 3.6.0-0ubuntu3 and lock screen still doesn't work. I can't see any gnome-screensaver process running either.

Pascal S (pascal.s) wrote :

Gnome-shell version 3.6.1. Neither lock screen, nor user switch work (at least from the session-menu buttons).

Kirill Müller (krlmlr) wrote :

Works for me in Ubuntu GNOME 13.04. I have changed to lightdm using the following:

apt-get install --no-install-recommends lightdm unity-greeter

After that, "Lock" and "Switch user" works correctly. I have the "alternative status menu" plugin installed (see http://askubuntu.com/a/115207/30266), don't know if this affects matters.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.