openConnection: connect: No such file or directory

Bug #1042423 reported by Trond-trondhuso on 2012-08-27
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Undecided
Unassigned

Bug Description

I found the line openConnection: connect: No such file or directory in my .xsession_errors file and did a search for it. At the end of that thread it was suggested to report a new bug with the command ubuntu-bug lightdm and so I did.

I am having problems with 12.04.1 not running in 3d mode.

System upgrader.

Computer system: Dell E4310

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lightdm 1.2.1-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Mon Aug 27 22:57:48 2012
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcEnviron:
 LC_TIME=en_GB.UTF-8
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: Upgraded to precise on 2012-08-23 (3 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
abadger (dave-netfm) wrote :

Same problem...upgrade Ubuntu 12.04 to 12.10 and now cannot remote access the server....

Failed to load session "gnome"

I only installed the XFCE desktop prior to upgrade ...so maybe this is related. Have tried install gnome and re-installing XFCE...stillno joy.

Here are various log file outputs....the last one agrees with same error as this buig report...

root@vrbs4:/var/log# tail -f /var/log/xrdp-sesman.log
[20121108-10:29:05] [INFO ] scp thread on sck 7 started successfully
[20121108-10:29:06] [INFO ] granted TS access to user msrbadmin
[20121108-10:29:06] [INFO ] starting Xvnc session...
[20121108-10:29:06] [INFO ] starting xrdp-sessvc - xpid=4351 - wmpid=4350
[20121108-10:29:09] [INFO ] session 4349 - user msrbadmin - terminated
^C

root@vrbs4:/var/log# tail -f /var/log/xrdp-sesman.log
Nov 8 10:30:26 vrbs4 x-session-manager[4474]: WARNING: GSIdleMonitor: IDLETIME counter not found
Nov 8 10:30:26 vrbs4 x-session-manager[4474]: WARNING: Session 'gnome' runnable check failed: Child process exited with code 1
root@vrbs4:/home/msrbadmin# tail -f .xsession-errors

Xsession: X session started for at Thu Nov 8 10:34:22 GMT 2012
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 109 (X_ChangeHosts)
  Value in failed request: 0x5
  Serial number of failed request: 6
  Current serial number in output stream: 8
localuser:msrbadmin being added to access control list
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 109 (X_ChangeHosts)
  Value in failed request: 0x5
  Serial number of failed request: 6
  Current serial number in output stream: 8
Setting IM through im-switch for locale=en_GB.
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
x-session-manager[4568]: WARNING: GSIdleMonitor: IDLETIME counter not found
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256
x-session-manager[4568]: WARNING: Session 'gnome' runnable check failed: Child process exited with code 1

nathan (pcnate) wrote :

This happened to me on 14.10 after installing xfce4

Daniel Ejsing-Duun (zilvador) wrote :

I noticed this while analysing a login loop after upgrading to 16.04.01.

I am also affected. Got the error when I updated from 14.04 to 16.04

PabloRQ (pablo-romeroquinteros) wrote :

Also in 16.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers